Ethernet Switching
Highlighted
Ethernet Switching

Access port configuration with ELS

‎12-05-2019 10:00 AM

I am  having some issues with an EX4300. There are a number of circuits that need to traverse a trunk uplink, some of these are single tagged and others are double tagged. As the customer traffic ingresses the switch we are OK with a single tag arriving and requiring an additional tag as it egresses the switch on the uplink (i.e. double tagged) and we are OK with a single tag arriving and egressing on the same uplink with that same single tag, but what I cannot work out is how receive an untagged packet and tag it as it egresses the switch on the uplink.

 

Below shows the uplink interface ge-0/0/0. It also shows ge-0/0/3 as a trunk port which will receive packets with tag 1000 and switch it to the uplink. I would like to configure ge-0/0/3 to receive untagged frames and for the frame to be tagged with VLAN 1000 as it egresses on ge-0/0/0.

 

{master:0}[edit]
lab@LAB-SW01# show interfaces ge-0/0/0
description "ge-0/3/9 LAB-PE-R2";
flexible-vlan-tagging;
mtu 1522;
encapsulation extended-vlan-bridge;
ether-options {
ethernet-switch-profile {
tag-protocol-id 0x8100;
}
}
unit 602 {
description L2VPN1;
vlan-id 602;
}
unit 1000 {
description L3VPN1;
vlan-id 1000;
}

{master:0}[edit]
lab@LAB-SW01# show interfaces ge-0/0/3
description "ge-0/0/3 LAB-CE-R1";
vlan-tagging;
encapsulation extended-vlan-bridge;
unit 1000 {
vlan-id 1000;
}

{master:0}[edit]
lab@LAB-SW01# show vlans
ELS-L2VPN1 {
interface ge-0/0/0.602;
interface ge-0/0/4.602;
}
ELS-L3VPN1 {
interface ge-0/0/0.1000;
interface ge-0/0/3.1000;
}

 

I have tried removing vlan-tagging, encapsulation, using encapsulation ethernet-bridge, using unit 0 but nothing works. Some of these result in commit errors, others do not, but nothing seems to work. What once seemed intuitive on traditional Junos has become so frustrating. Any help would be much appreciated.

 

JNCIE-ENT #552, JNCSP-ENT, JNCIP-SEC, JNCIP-SP, JNCIP-DC, JNCDS-DC, JNCDS-SEC, JNCDS-SP, CCNP, CCDA
6 REPLIES 6
Highlighted
Ethernet Switching

Re: Access port configuration with ELS

‎12-05-2019 04:12 PM

Check if you match PR1413700

Highlighted
Ethernet Switching

Re: Access port configuration with ELS

‎12-05-2019 08:21 PM

Hi Regalis,

 

Please check if this works for you:

 

 

set interfaces xe-0/0/34 flexible-vlan-tagging
set interfaces xe-0/0/34 native-vlan-id 150
set interfaces xe-0/0/34 encapsulation extended-vlan-bridge
set interfaces xe-0/0/34 unit 1000 vlan-id 1000
set interfaces xe-0/0/35 flexible-vlan-tagging
set interfaces xe-0/0/35 encapsulation extended-vlan-bridge
set interfaces xe-0/0/35 unit 602 vlan-id-list [602 1000]
set interfaces xe-0/0/35 unit 602 input-vlan-map push
set interfaces xe-0/0/35 unit 602 output-vlan-map pop
set vlans v602 interface xe-0/0/35.602
set vlans v1000 interface xe-0/0/35.1000
set vlans v1000 interface xe-0/0/34.1000

 

And if you use Junos 18.1R3-S9 (slightly newer than JTAC recommended) - https://kb.juniper.net/InfoCenter/index?page=content&id=KB21476&actp=METADATA, that'll rule out PR1413700.

 

Other Junos versions that include the PR1413700 fix: 
https://prsearch.juniper.net/InfoCenter/index?page=prcontent&id=PR1413700

 

Hope this helps.

Regards,
-r.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated Smiley Happy.

 

 

Highlighted
Ethernet Switching

Re: Access port configuration with ELS

‎12-06-2019 01:21 AM

Thanks for the response but that PR talks about an received untagged frame egresses as a single tagged frame when it is desired that it egresses as a double tagged frame. That is not the issue here. I just want an untagged frame to be received and egress the uplink as a single tagged frame.

JNCIE-ENT #552, JNCSP-ENT, JNCIP-SEC, JNCIP-SP, JNCIP-DC, JNCDS-DC, JNCDS-SEC, JNCDS-SP, CCNP, CCDA
Highlighted
Ethernet Switching

Re: Access port configuration with ELS

‎12-06-2019 01:24 AM

Thanks for the response.

 

It appears that the configuration shows a Q-in-Q access port (accepts single tagged frames and pushes/pops as required), and a truink port that also accepts a untagged frames into the native VLAN. I am after the configuration for an access port that will work with the trunk port.

JNCIE-ENT #552, JNCSP-ENT, JNCIP-SEC, JNCIP-SP, JNCIP-DC, JNCDS-DC, JNCDS-SEC, JNCDS-SP, CCNP, CCDA
Highlighted
Ethernet Switching

Re: Access port configuration with ELS

‎12-06-2019 03:30 AM

I have spoken to Juniper Ambassador, Paul Clarke who has informed me we have to use a mix of traditional Junos with ELS.

 

{master:0}[edit interfaces ge-0/0/3]
lab@LAB-SW01# show
description "ge-0/0/3 FLAB-PE-R1";
encapsulation extended-vlan-bridge;
unit 0 {
family ethernet-switching {
vlan {
members ELS-L3VPN1;
}
}
}

{master:0}[edit vlans ELS-L3VPN1]
lab@LAB-SW01# show
vlan-id 1000;
interface ge-0/0/0.1000;

 

JNCIE-ENT #552, JNCSP-ENT, JNCIP-SEC, JNCIP-SP, JNCIP-DC, JNCDS-DC, JNCDS-SEC, JNCDS-SP, CCNP, CCDA
Highlighted
Ethernet Switching

Re: Access port configuration with ELS

‎12-06-2019 03:32 AM

Good work Paul.

@PaulClarkeJNCIP