Ethernet Switching
Highlighted
Ethernet Switching

Aggregate Interface Warning

‎05-22-2009 08:18 AM

I have created an aggregate interface and assign two physical interfaces to this aggregate group. But when I commit the configure, I see the warning as below. How can I remove this warning message?

warning: Adding child member to an aggregate interface with the speed set to  AUTO will force the link  speed to 1G

5 REPLIES 5
Highlighted
Ethernet Switching

Re: Aggregate Interface Warning

‎05-22-2009 08:44 AM

Hi,

 

You can set the speed and duplex to the same for each member of the group.

 

set interfaces ge-0/0/x ether-options link-mode full-duplex

set interfaces ge-0/0/x ether-options speed 1g

 

I think if you do this before adding them to the group, you won't see the error.  Just note that if you hard code settings, you will need to do this on both sides of the link.

 

-John

John Judge
JNCIS-SEC, JNCIS-ENT,

If this solves your problem, please mark this post as "Accepted Solution". Kudos are appreciated.
Highlighted
Ethernet Switching

Re: Aggregate Interface Warning

‎05-23-2009 06:04 AM

 Hi, it doesn't work. I've got another error message.

 

'802.3ad'
   ae child device link-mode setting is not allowed

 

Highlighted
Ethernet Switching

Re: Aggregate Interface Warning

‎05-23-2009 08:10 AM

Hi,

 

Can you post your config to the ae0 interface?

 

-John

John Judge
JNCIS-SEC, JNCIS-ENT,

If this solves your problem, please mark this post as "Accepted Solution". Kudos are appreciated.
Highlighted
Ethernet Switching

Re: Aggregate Interface Warning

‎05-23-2009 11:58 PM

Hi All,

 

Setting link-mode on ae0 child member is currently not supported.

Plz check road-map for EX.

 

Note: hardcoding link-mode for ae0 itself is also not supported.

 

 

-Syed

JTAC 

Highlighted
Ethernet Switching

Re: Aggregate Interface Warning

‎05-24-2009 12:40 PM

Hi,


Thanks.  I found this out the hard way last night and was forced to delete the link-mode setting.  However, the speed option worked on both.  Thanks for the clarification.

 

-John

John Judge
JNCIS-SEC, JNCIS-ENT,

If this solves your problem, please mark this post as "Accepted Solution". Kudos are appreciated.
Feedback