Ethernet Switching
Ethernet Switching

Client getting IPv6 address from both DHCPv6 and SLAAC

‎06-12-2019 08:08 AM

I have a setup where I'm trying to just use DHCPv6 for address assignment.  I've got the following on my RA and from my understanding "managed-configuration" is supposed to set the M bit and I've confirmed that this is set from a wireshark trace but the client is still also receiving an address from slaac.  Is this normal?  I thought the M bit was supposed to tell the client to get all its info from DHCPv6.

 

show protocols router-advertisement
interface irb.406 {
managed-configuration;

prefix xxxx:xxxx:xxxx:xxxx::/64;

}

3 REPLIES 3
Ethernet Switching
Solution
Accepted by topic author lcroce
‎06-12-2019 08:51 AM

Re: Client getting IPv6 address from both DHCPv6 and SLAAC

‎06-12-2019 08:49 AM

Hi,

 

Could you try no-autonomous option under the prefix 

prefix 2001:200::/64 {
                no-autonomous;
            }

 

------------------------------------

If this solves your problem, please mark this post as "Accepted Solution.

Regards,
A.A.
Ethernet Switching

Re: Client getting IPv6 address from both DHCPv6 and SLAAC

[ Edited ]
‎06-12-2019 08:50 AM

Update: Figured out what was going on.  I needed to unset the A bit as well with " set protocols router-advertisement interface irb.406 prefix xxxx:xxxx:xxxx:xxxx::/64 no-autonomous

 

EDIT:  Thanks, pradkm.  I figured it out before I saw your post but I'll mark it as solution anyway.

Ethernet Switching

Re: Client getting IPv6 address from both DHCPv6 and SLAAC

‎06-12-2019 08:51 AM
Hi,

Removing the prefix statement "prefix xxxx:xxxx:xxxx:xxxx::/64;" from the configuration should stop the RA from advertising an IP address to the connected client.

Yes, the knob "managed-configuration" is to set the M bit which is to inform the client that the stateful autoconfiguration is available for use.
Reference: https://www.juniper.net/documentation/en_US/junos/topics/reference/configuration-statement/managed-c...

To enable DHCPv6 only advertisement, setting the M flag is not enough but also clear the A flag which is probably done by removing the prefix configuration.

Thanks,
Pradeep
Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!

Juniper Internal