Ethernet Switching
Ethernet Switching

Duplicate Frames IRB

08.05.17   |  
‎08-05-2017 09:40 PM

Noticed that even after a factory reset to defaults, the switch will will duplicate broadcast frames if the default vlan is attached to a L3 IRB interface. When two switches are connected, end hosts see 4 double frames instead of 1, the more switches in a chain the more multiplication of frames at the furthest switch. Noticed this behaviour on the EX3400, can anyone else confirm this on their end? Very easy to spot with DHCP messages.

6 REPLIES
Ethernet Switching

Re: Duplicate Frames IRB

08.06.17   |  
‎08-06-2017 08:43 AM

Have you opened a case with Juniper TAC?  

 

I assume what is happening is that frame is being forwarded as any broadcast (or multicast) would, and is also being sent (copied) to RE, who then forwards it as well.  As to why, that is a good question.

 

For DHCP packets, multiple copies should not be an issue.  I assume you have no DHCP config of any type on the switch as well, yes?

Ethernet Switching

Re: Duplicate Frames IRB

08.08.17   |  
‎08-08-2017 11:27 PM

Was what I was thinking also. No DHCP config on the switches. I noticed it because Cisco SPA phones refused to boot up, looks like there may be a bug on their firmware that causes the to lockup. Was hoping someone else from the community would be able to confirm this issue.

Highlighted
Ethernet Switching

Re: Duplicate Frames IRB

08.09.17   |  
‎08-09-2017 03:50 AM

I think an easy way to prove this would be to create a FF associated with lo0 to discard the packet, and see if now you see just one.

 

What version of SW are you running on your EX3400?  Do you have any other Juniper EX switches to test them as well?

 

Do you have a case open with TAC, and if not why not?  I case is open, please send number.

Ethernet Switching

Re: Duplicate Frames IRB

08.10.17   |  
‎08-10-2017 10:58 PM

Firewall input rule on lo0 to discard packets sent to broadcast fixes the problem, looks like the IRB is definitely forwarding broadcast packets. I can also confirm this is happening regardless of the vlan and that this does not affect the EX2300-48P running 15.1X53-D55. Currently the switch in question is running 15.1X53-D55 but can confirm the problem is also present on D56. No service contract on the switch, working with the vendor to get it on there so that I can file a JTAC case.

Ethernet Switching

Re: Duplicate Frames IRB

08.11.17   |  
‎08-11-2017 08:04 AM

Maybe a typo "this does not affect the EX2300-48P running 15.1X53-D55"?  D55 has the behavior or not?  You later state D56 shows same behavior, which I assume is multiple packets.

 

Can you send your EX2300 config?

Ethernet Switching

Re: Duplicate Frames IRB

08.11.17   |  
‎08-11-2017 08:33 AM

Sorry, too many sleepless nights.

 

Non Issue:

EX2300 running D55

 

Issue:

EX3400 running D55

EX3400 running D56

 

 

The attached config generates the error.

Attachments