Ethernet Switching
Highlighted
Ethernet Switching

EX2200 (Junos 12.3R12.4) Routing-instance doesn't work?

[ Edited ]
‎11-08-2017 12:35 AM

Hello.

trying to implement RI at EX2200

 show configuration | display set
set version 15.1R6.7
set system services ssh protocol-version v2
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set chassis alarm management-ethernet link-down ignore
set interfaces ge-0/0/0 unit 0 family ethernet-switching
set interfaces ge-0/0/1 unit 0 family ethernet-switching
set interfaces ge-0/0/2 unit 0 family ethernet-switching
set interfaces ge-0/0/3 unit 0 family ethernet-switching
set interfaces ge-0/0/4 unit 0 family ethernet-switching
set interfaces ge-0/0/5 unit 0 family ethernet-switching
set interfaces ge-0/0/6 unit 0 family ethernet-switching
set interfaces ge-0/0/7 unit 0 family ethernet-switching
set interfaces ge-0/0/8 unit 0 family ethernet-switching
set interfaces ge-0/0/9 unit 0 family ethernet-switching
set interfaces ge-0/0/10 unit 0 family ethernet-switching
set interfaces ge-0/0/11 unit 0 family ethernet-switching
set interfaces ge-0/0/12 unit 0 family ethernet-switching
set interfaces ge-0/0/13 unit 0 family ethernet-switching
set interfaces ge-0/0/14 unit 0 family ethernet-switching
set interfaces ge-0/0/15 unit 0 family ethernet-switching
set interfaces ge-0/0/16 unit 0 family ethernet-switching
set interfaces ge-0/0/17 unit 0 family ethernet-switching
set interfaces ge-0/0/18 unit 0 family ethernet-switching
set interfaces ge-0/0/19 unit 0 family ethernet-switching
set interfaces ge-0/0/20 unit 0 family ethernet-switching
set interfaces ge-0/0/21 unit 0 family ethernet-switching
set interfaces ge-0/0/22 unit 0 family ethernet-switching
set interfaces ge-0/0/23 unit 0 family ethernet-switching
set interfaces ge-0/1/0 unit 0 family ethernet-switching
set interfaces ge-0/1/1 unit 0 family ethernet-switching
set interfaces ge-0/1/2 unit 0 family ethernet-switching
set interfaces ge-0/1/3 unit 0 family ethernet-switching
set interfaces vlan unit 0 family inet filter input FBF_Filter
set interfaces vlan unit 0 family inet address 172.16.4.254/16
set routing-options interface-routes rib-group inet FBF
set routing-options static route 0.0.0.0/0 next-hop 172.16.0.102
set routing-options rib-groups FBF import-rib inet.0
set routing-options rib-groups FBF import-rib FBF.inet.0
set protocols igmp-snooping vlan all
set protocols rstp
set protocols lldp interface all
set protocols lldp-med interface all
set firewall family inet filter FBF_Filter term first from destination-address 172.16.4.254/32
set firewall family inet filter FBF_Filter term first then accept
set firewall family inet filter FBF_Filter term second from source-address 172.16.0.0/16
set firewall family inet filter FBF_Filter term second from destination-address 10.44.44.0/24
set firewall family inet filter FBF_Filter term second then routing-instance FBF
set firewall family inet filter FBF_Filter term last then accept
set routing-instances FBF instance-type forwarding
set routing-instances FBF routing-options static route 0.0.0.0/0 next-hop 172.16.0.250
set ethernet-switching-options storm-control interface all
set vlans default l3-interface vlan.0
root> show route

inet.0: 3 destinations, 3 routes (3 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

0.0.0.0/0          *[Static/5] 00:33:21
                    > to 172.16.0.102 via vlan.0
172.16.0.0/16      *[Direct/0] 00:33:21
                    > via vlan.0
172.16.4.254/32    *[Local/0] 00:33:40
                      Local via vlan.0

FBF.inet.0: 3 destinations, 3 routes (3 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

0.0.0.0/0          *[Static/5] 00:33:21
                    > to 172.16.0.250 via vlan.0
172.16.0.0/16      *[Direct/0] 00:33:21
                    > via vlan.0
172.16.4.254/32    *[Local/0] 00:33:21
                      Local via vlan.0

{master:0}

 

at windows host (172.16.1.180/16) do trace to 10.44.44.20 and got

172.16.4.254

172.16.0.102

 

what's wrong?

 

UPD: rolled back to 12.3R12.4

18 REPLIES 18
Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-08-2017 01:10 AM

Hi WingDog,

 

It it's not recommended to run Junos releases newer than 12.3 on the EX2200-platform due to memory limitations.

 

Ref: https://kb.juniper.net/InfoCenter/index?page=content&id=S:TSB17138&IQ_SESSION_ID=ffc22345-66bd-4bdf-...

 

This is also stated when looking at JTAC recommended releases for the EX2200/EX2200-C: https://kb.juniper.net/InfoCenter/index?page=content&id=KB21476&actp=METADATA

 

I will suggest to downgrade to 12.3 before doing any further debugging on the issue.


--
Best regards,

Jonas Hauge Klingenberg
Juniper Ambassador & Technology Architect, SEC DATACOM A/S (Denmark)
Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-08-2017 04:35 AM

Hi, jonashauge.

I've upgraded from 12.3R12 just to test RI at 15.1 because it doesn't waork at 12.3 😉

 

anyway I'll rollback now 😃

Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-08-2017 11:52 PM

now Junos 12.3R12.4 and nothing changed.

any ideas?

Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-09-2017 01:59 AM

Your config will not work.  Not sure exactly what you needs are but Routing-Instances MUST include interfaces, at a minimum, if you want traffic to work within a routing-instance.  I believe instance-type forwarding would be L2, and it appears you want L3, so your instance-type should be virtual-router (VRF type).

 

For additional info check out the links below:

 

http://aconaway.com/2012/10/31/junos-basics-routing-instances/

 

https://www.juniper.net/documentation/en_US/junos/topics/concept/routing-instances-overview.html

 

https://www.juniper.net/documentation/en_US/junos/topics/example/logical-system-security-interface-r...

 

 

 

 

Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-09-2017 02:34 AM

this config work at SRX.

I'm trying to catch traffic from specific subnet and change route for it.

 

Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-09-2017 02:55 AM

You wrote:

 

at windows host (172.16.1.180/16) do trace to 10.44.44.20 and got

172.16.4.254

172.16.0.102

 

Does 172.16.0.102 (what ever that is) know how to get to 10 network?  If not, not going to work.

Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-09-2017 03:37 AM

172.16.4.254 is default gateway for Windows Client.

tracert to 10.44.44.20 must be forwarded (juniper filter-based forwaring instance) to 172.16.0.250, but not default routed to 172.16.0.102

Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-09-2017 03:40 AM
root> show route instance
Instance             Type
         Primary RIB                                     Active/holddown/hidden
master               forwarding
         inet.0                                          3/0/0

FBF                  forwarding
         FBF.inet.0                                      3/0/0

__juniper_private1__ forwarding
         __juniper_private1__.inet.0                     4/0/0

__juniper_private2__ forwarding
         __juniper_private2__.inet.0                     0/0/1

__master.anon__      forwarding

{master:0}
root> show route

inet.0: 3 destinations, 3 routes (3 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

0.0.0.0/0          *[Static/5] 00:09:40
                    > to 172.16.0.102 via vlan.0
172.16.0.0/16      *[Direct/0] 00:09:40
                    > via vlan.0
172.16.4.254/32    *[Local/0] 00:10:00
                      Local via vlan.0

FBF.inet.0: 3 destinations, 3 routes (3 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

0.0.0.0/0          *[Static/5] 00:09:40
                    > to 172.16.0.250 via vlan.0
172.16.0.0/16      *[Direct/0] 00:09:40
                    > via vlan.0
172.16.4.254/32    *[Local/0] 00:09:40
                      Local via vlan.0

{master:0}
Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-09-2017 03:51 AM

Is this then needed?

 

set routing-options static route 0.0.0.0/0 next-hop 172.16.0.102 

 

Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-09-2017 03:59 AM

this is needed.

I need Filter-based forwarding. with several filters.

Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-09-2017 04:08 AM

Suggest you work with Juniper TAC, as this appears to be purely a routing situation.

Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-09-2017 04:17 AM

I have no any service contract =(

Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-09-2017 04:19 AM

That is never a good idea -;(

Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-09-2017 09:23 AM

Do you see "Warning: statement ignored: unsupported platform" message when you issue #show firewall ?

 

Regards, Wojtek

Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-09-2017 10:55 AM
On Ex 2200, even on 15.1 r6, still FBF support is not there as it is not listed feature..

You can create the routing instance but you won't be able to do fbf using routing instance..

*************************************
HTH.
Accept this as solution if it resolved your issue.
Kudos would be appreciated too.
Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-09-2017 01:02 PM

Yes, FBF not supported on EX2200 - good catch.  See below:

 

https://pathfinder.juniper.net/feature-explorer/feature-info.html?fKey=1062&fn=Filter-based%20forwar...)

 

Nor is this support on EX2300.  EX2300 also does not support Routing-Instances.

Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-09-2017 08:24 PM

Hi.

ok, thank you for explanations.

is there any other way to achieve my needs at Ex2200?

 

Highlighted
Ethernet Switching

Re: EX2200 (Junos 15.1R6.7) Routing-instance doesn't work?

‎11-15-2017 03:16 AM

The ex2200 does not support filter based forwarding where you can forward traffic based on criteria like source address or port.

 

The ex2200 does support virtual router routing instances where you can put different interfaces into a routing instance with a different route table for standard destination address based forwarding.

 

So if you can accomplish your routing goals using destination routes you can move in that direction.

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Feedback