Ethernet Switching
Highlighted
Ethernet Switching

EX2200 vlan issue

‎09-26-2019 12:05 AM

Hello guys, I have a problem with ma ex switch, could you help me?

 

I have EX2200 and SRX100H2, I had some config with vlans and EX2200 and it work great, now I declared another with conected to one of the port of SRX, i have done this before with antoher vlans 

 

example

srx fe-0/0/1  -> ex 2200  ge-0/0/1   and ports on ex 1-10 is vlan x and so on

srx fe-0/0/2  -> ex 2200  ge-0/0/11   and ports on ex 11-20 is vlan  y and so on

srx fe-0/0/3  -> ex 2200  ge-0/0/21 and ports on ex 21-30 is vlan x and so on

and fe0/0/3 is the issue but whe I connected directly to SRX everything works fine

 

Now when I created another one the upload on the pc is very slow aroud 0Mb, but downlowad works fine

and I do not kow where is the problem

 

Have you any clue what is happening?

 
5 REPLIES 5
Highlighted
Ethernet Switching

Re: EX2200 vlan issue

‎09-26-2019 05:05 AM

check to see that the pc connects at full duplex and speed on the switch compared to the SRX

and the same with the fe-0/0/3 to ex port connection

 

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Highlighted
Ethernet Switching

Re: EX2200 vlan issue

‎09-26-2019 05:06 AM

Not sure if I understood well.  It should be good if you include the ports configuration to have a better idea.

 

I see that vlan x is on ports fe-0/0/1 & fe-0/0/3, maybe spanning-tree could be causing something.  But I am just assuming, maybe that is not relevant.  Also check if you have some policy applied on the SRX, some times the SRX rules those packets.

Highlighted
Ethernet Switching

Re: EX2200 vlan issue

‎09-30-2019 02:36 AM

Hello Steve on both the connection is set on auto negotiation

 

interface on srx
show interfaces fe-0/0/4
Physical interface: fe-0/0/4, Enabled, Physical link is Up
  Interface index: 139, SNMP ifIndex: 513
  Link-level type: Ethernet, MTU: 1514, Link-mode: Full-duplex, Speed: 100mbps,
  BPDU Error: None, MAC-REWRITE Error: None, Loopback: Disabled,
  Source filtering: Disabled, Flow control: Disabled
  Device flags   : Present Running
  Interface flags: SNMP-Traps Internal: 0x0
  CoS queues     : 8 supported, 8 maximum usable queues
  Current address: 3c:61:04:e0:e4:44, Hardware address: 3c:61:04:e0:e4:44
  Last flapped   : 2019-09-30 10:58:04 CEST (00:09:32 ago)
  Input rate     : 232 bps (0 pps)
  Output rate    : 1560 bps (3 pps)
  Active alarms  : None
  Active defects : None
  Interface transmit statistics: Disabled

  Logical interface fe-0/0/4.0 (Index 76) (SNMP ifIndex 522)
    Flags: SNMP-Traps 0x0 Encapsulation: ENET2
    Input packets : 162133
    Output packets: 173907
    Security: Zone: sec_zone_x
    Allowed host-inbound traffic : dhcp https ping ssh
    Protocol inet, MTU: 1500
      Flags: Sendbcast-pkt-to-re
      Addresses, Flags: Is-Preferred Is-Primary
        Destination: 10.0.51/24, Local: 10.0.51.1, Broadcast: 10.0.51.255



interface on ex conected to fe-0/0/4 on srx
show interfaces ge-0/0/10
Physical interface: ge-0/0/10, Enabled, Physical link is Up
  Interface index: 139, SNMP ifIndex: 505
  Link-level type: Ethernet, MTU: 1514, Speed: Auto, Duplex: Auto, BPDU Error: None, MAC-REWRITE Error: None, Loopback: Disabled, Source filtering: Disabled, Flow control: Enabled,
  Auto-negotiation: Enabled, Remote fault: Online, Media type: Copper
  Device flags   : Present Running
  Interface flags: SNMP-Traps Internal: 0x4000
  Link flags     : None
  CoS queues     : 8 supported, 8 maximum usable queues
  Current address: 44:aa:50:24:78:cd, Hardware address: 44:aa:50:24:78:cd
  Last flapped   : 2019-09-30 10:58:02 CEST (00:14:19 ago)
  Input rate     : 1064 bps (1 pps)
  Output rate    : 15424 bps (6 pps)
  Active alarms  : None
  Active defects : None
  Interface transmit statistics: Disabled

  Logical interface ge-0/0/10.0 (Index 78) (SNMP ifIndex 506)
    Flags: Up SNMP-Traps 0x4000 Encapsulation: ENET2
    Input packets : 11
    Output packets: 25339
    Protocol eth-switch
      Flags: None

	  
	  
interface conected to pc from ex
show interfaces ge-0/0/22
Physical interface: ge-0/0/22, Enabled, Physical link is Up
  Interface index: 151, SNMP ifIndex: 531
  Link-level type: Ethernet, MTU: 1514, Speed: Auto, Duplex: Auto, BPDU Error: None, MAC-REWRITE Error: None, Loopback: Disabled, Source filtering: Disabled, Flow control: Enabled,
  Auto-negotiation: Enabled, Remote fault: Online, Media type: Copper
  Device flags   : Present Running
  Interface flags: SNMP-Traps Internal: 0x4000
  Link flags     : None
  CoS queues     : 8 supported, 8 maximum usable queues
  Current address: 44:aa:50:24:78:d9, Hardware address: 44:aa:50:24:78:d9
  Last flapped   : 2019-09-30 11:11:54 CEST (00:00:59 ago)
  Input rate     : 24800 bps (3 pps)
  Output rate    : 0 bps (0 pps)
  Active alarms  : None
  Active defects : None
  Interface transmit statistics: Disabled

  Logical interface ge-0/0/22.0 (Index 90) (SNMP ifIndex 532)
    Flags: Up SNMP-Traps 0x4000 Encapsulation: ENET2
    Input packets : 1740
    Output packets: 4954
    Protocol eth-switch
      Flags: None

When I connect directly to srx there is no problem with the net or work. On the switch I configure only the vlan and port.

I upgraded the latest version on srx and ex but it does not help.

 

I have olso tp-link switch and it work with no problem.

 

 

 

 

 

 

 

Highlighted
Ethernet Switching

Re: EX2200 vlan issue

‎09-30-2019 02:38 AM

Hello Randero, It was only a mistake with in my example.

If I had a policy on srx then when I conect directly it will be the same problem?

 

this is a part of my config

 

config on srx
services {
		dhcp {
			pool 10.0.51.0/24 {
                address-range low 10.0.51.101 high 10.0.51.240;
                name-server {
                    10.0.1.50;
                    10.0.1.51;
                }
                router {
                    10.0.51.1;
                }
                propagate-settings ge-0/0/4.0;
            }
		}
}
interfaces {			
	fe-0/0/4 {
        unit 0 {
            family inet {
                address 10.0.51.1/24;
            }
        }
    }
}


	security-zone sec_zone_x 
		{
            host-inbound-traffic {
                system-services {
                    all;
                }
            }
            interfaces {
                fe-0/0/4.0 {
                    host-inbound-traffic {
                        system-services {
                            dhcp;
                            ping;
                            ssh;
                            https;
                        }
                    }
                }
            }
            application-tracking;
        }
			
			
			
			

config on ex swith
interfaces {
	ge-0/0/10 {
        unit 0 {
            family ethernet-switching;
        }
    }

    ge-0/0/22 {
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members test;
                }
            }
        }
    }
}


vlans {
    test {
        vlan-id 11;
        interface {
            ge-0/0/10.0;
        }
    }
}
Highlighted
Ethernet Switching

Re: EX2200 vlan issue

‎10-03-2019 03:04 AM

This is very weard, when create new vlan thery is a problem with comunicate on this vlan.

Feedback