Ethernet Switching
Highlighted
Ethernet Switching

EX2300 -c 12p 15.1X53-D591.1 does not come back after power restoration

‎05-15-2020 07:54 AM

Is that normal that it does not come back after power restoration? I had to completely unplug power cord and plug it back in order to get the switch up & runing again. I thought it should come back when power restore. Am I wrong? 

4 REPLIES 4
Highlighted
Ethernet Switching

Re: EX2300 -c 12p 15.1X53-D591.1 does not come back after power restoration

‎05-15-2020 07:55 AM

I see only these in the logs:

 

 eventd[7628]: SYSTEM_ABNORMAL_SHUTDOWN: System abnormally shut down

eventd[7628]: SYSTEM_OPERATIONAL: System is operational

Highlighted
Ethernet Switching

Re: EX2300 -c 12p 15.1X53-D591.1 does not come back after power restoration

‎05-15-2020 08:27 AM

You are correct in that it should, and my experience always has with EX, BUT and unexpected and abnormal shutdown might cause issues, where something like this or a reboot might be required.  I assume the switch is not on a controllable UPS.

Highlighted
Ethernet Switching

Re: EX2300 -c 12p 15.1X53-D591.1 does not come back after power restoration

‎05-15-2020 09:57 AM
Hi LOGTECH, In most of the power outage scenarios EX devices gets stuck in hung state and manual power cycle is needed to bring it back. When power comes back may be there are fluctuations and it may not receive the amount it needed to boot up. To understand more on EX2300 power system please refer below link. https://www.juniper.net/documentation/en_US/release-independent/junos/topics/topic-map/ex2300-power-... If this solves your problem, please mark this post as "Accepted Solution" so we can help others too   Kudos are appreciated too    Regards, Nadeem  
Highlighted
Ethernet Switching

Re: EX2300 -c 12p 15.1X53-D591.1 does not come back after power restoration

[ Edited ]
‎05-15-2020 09:59 AM

Hello Logtech,

Greetings!

 

Is the switch in the hung state or struck in a boot loader? if yes, you can share with us the boot logs to have a quick look and check what's causing the issue?

 

Any switch is expected to come back up online after the power restoration. As the switch in question hasn't come back up, I suspect an issue with the switch hardware parts.

 

In logs:

 

eventd[7628]: SYSTEM_ABNORMAL_SHUTDOWN: System abnormally shut down

eventd[7628]: SYSTEM_OPERATIONAL: System is operational

 

Basically, eventd process is the one that Configures the application to handle all generated events.

 

From the logs, it says the system was Abnormally Shutdown as the removal of the power cord while the device was running causes the abnormal shutdown.

 

The normal shutdown happens when a user runs a reboot or shutdown command from the CLI of the switch to shut down the switch gracefully.

 

Use the CLI command "request system power-offfrom operational mode, which displays a message to the CLI, then disconnect the switch from electrical power.  This command will also notify other users connected to the switch about the operation.

This article describes the recommended methods for turning off or rebooting the EX Series switch.

 

https://kb.juniper.net/InfoCenter/index?page=content&id=KB11356&cat=EX4500&actp=LIST

 

As the power cord was plugged out suddenly, it has lead to an Abnormal shutdown, and also if the device reboots suddenly on its, it may cause an abnormal shutdown.

 

Paste the logs so that we can have a look.

If the device is continuously booting or powered-off, I would suggest you to open a JTAC case for the same.

 

I hope this helps. Please mark this post "Accept as solution" if this answers your query.

 

Kudos are always appreciated! Smiley Happy

 

Best Regards,

Lingabasappa H

 

 

 

 

Feedback