Ethernet Switching
Highlighted
Ethernet Switching

EX2300 running 18.1R3.3. not able to change speed for DAC connector on XE ports

‎06-10-2020 12:37 AM

Hi everybody,

I would like to change the speed on a DAC connector located at XE-0/1/0 from 10G to 1G because I haven't managed to upgrade the central router (it is still running 1G). The SFP is registered correctly and when running a loop from XE-0/1/0 <-> XE-0/1/1 it is workinf flawlessly. The same is valid if the same cable is running in 1G mode in two ports (loop) in the router device. But have the DAC as a link between both units, the link isn't coming up.

What I miss here is a manual speed setting (which is available for GE interfaces).

Appreciate any help.

/Sebastian

6 REPLIES 6
Highlighted
Ethernet Switching

Re: EX2300 running 18.1R3.3. not able to change speed for DAC connector on XE ports

[ Edited ]
‎06-10-2020 12:56 AM

Hi wirseefahrer,

Greetings !
I think this config should work:

set interfaces xe-0/1/0 speed 1g
set interfaces xe-0/1/0 gigether-options auto-negotiation

{master}[edit]
root@lab# show | compare
[edit interfaces]
+ xe-0/1/0 {
+ speed 1g;
+ gigether-options {
+ auto-negotiation;
+ }
+ }



Try enabling the speed using the command as above, you could also use the auto-negotiation to negotiate speed to lower of the two in case there is difference in speed of the links.

Hope this helps.

 

Please mark "Accept as solution" if this answers your query. 

 

Kudos are appreciated too! 

 

Regards, 

Sharat Ainapur

Highlighted
Ethernet Switching

Re: EX2300 running 18.1R3.3. not able to change speed for DAC connector on XE ports

‎06-10-2020 01:02 AM

Hello Sebastian,

Greetings!

 

As per the description, i understand that DAC cable link between two router is not coming up, but the DAC cablelink between 2 ports[xe-0/1/0- xe-0/1/1] in the same device is up and working fine. Let me know if i have to consider some more observations.

 

Please provide the output of the below command:

 

show interfaces xe-0/1/0 extensive

show interfaces xe-0/1/1 extensive

 

Also, can you tell me which is the peer end device? If it is Juniper device, provide the above output from the peer end device as well:

show interfaces <interface_name> extensive

 

Links for reference:

https://www.juniper.net/documentation/en_US/junos/topics/topic-map/switches-interface-gigabit.html

https://www.juniper.net/documentation/en_US/junos/topics/topic-map/rate-selectability-configuring.ht...

https://www.juniper.net/documentation/en_US/junos/topics/topic-map/switches-interface-port.html

 

I hope this helps. Please mark this post "Accept as solution" if this answers your query.

 

Kudos are always appreciated! Smiley Happy

 

Best Regards,

Lingabasappa H

Highlighted
Ethernet Switching

Re: EX2300 running 18.1R3.3. not able to change speed for DAC connector on XE ports

‎06-10-2020 02:15 AM

Hi wirseefahrer

 

Good day!!

 

Doing research I was only able to find this:

 

Starting in Junos OS Release 18.1R2, the multi-rate speed is supported on EX2300-48MP and EX2300-24MP switches. The speed configuration statement is supported on both multi-rate gigabit ethernet interface (mge) and gigabit ethernet (ge) interface. The mge interface is a rate-selectable (multirate) Gigabit Ethernet interface that can support speeds of 10-Gbps, 5-Gbps, and 2.5-Gbps over CAT5e/CAT6/CAT6a cables. In the EX2300, the mge interface supports 100-Mbps, 1-Gbps, and 2.5-Gbps speeds, which can be configured by using the speed configuration statement. Note that 10Mbps speed is supported only on ge interfaces of EX2300 switch.

 

https://www.juniper.net/documentation/en_US/junos/topics/reference/configuration-statement/speed-edi...

 

 

The link is mot referring to the uplink ports, but only the standard ports. I reserved a automation device that is running 18.1R2 and I was not able to find the speed command either so, this might be a limitation with this device.

 

with the show chassis hardware:

PIC 1 REV 07 650-078097 XP3119130027 6x1G/10G SFP/SFP+

 

Please mark "Accepted Solution" if this helps.

Kudos are always appreciated

 

Thanks 

Suraj 

Highlighted
Ethernet Switching
Solution
Accepted by topic author wirseefahrer
‎06-10-2020 01:12 PM

Re: EX2300 running 18.1R3.3. not able to change speed for DAC connector on XE ports

‎06-10-2020 01:12 PM

I'm impressed - what a fast response time.

 

Below the output of "show chassis hardware"

...
PIC 1 REV 19 650-059968 JY0217380253 4x10G SFP/SFP+
..

Anybody that have an EX2300-24MP laying around and is willing to ship it to Sweden? 🙂

Once again many thanks for the support.

/Sebastian

 

Highlighted
Ethernet Switching

Re: EX2300 running 18.1R3.3. not able to change speed for DAC connector on XE ports

‎06-11-2020 02:31 PM

A DAC cable is essentially SFP's with cable built in.

SFP's are set to a particular speed in hardware. I'm not aware of any way to change this (in any vendor). 

I'm also not aware of any 1G DAC cables.

You could buy 1G SFPs and run fibre or copper cables.

Highlighted
Ethernet Switching

Re: EX2300 running 18.1R3.3. not able to change speed for DAC connector on XE ports

‎06-29-2020 03:48 PM

Hi everybody,

I finally got that up and running. I've disabled the xe-0/1/1 port and enabled ge-0/1/1 port. Then I configured trunk mode including targeted VLAN subnets and the link became available with just 1GbE on a 10GbE SFP+ port. The only thing that is annoying is the blink speed LED that isn't attached to the info-select button at all. Link is working stable since 4 days ago running a non-Juniper SFP module.

So this is really strange that the docuumentation is telling is that this wouldn't work at all but the reality is showing us something else. But once again many thanks for the help I got - I've learned a lot.

Feedback