Ethernet Switching
Ethernet Switching

EX4300 ELS Q-in-Q uplink interface with Vlan Trunk

2 weeks ago

Hello.

 

I found that there is alot of changes in q-in-q configuration for ELS switches. My configuration in the  the lab is now working but I would like to add more "normal" vlan trunk to the same interface anyone know how to do this?

 

CPE (acess)<-----SW-1-ELS-SW ------> (all-trunk) SW-2 (all-trunk) ------> SW-3-ELS-SW ------> (access) CPE

 

With my current config below I'm not able to ping between switches in the 10.42.6.0 network.

 

SW-1-ELS-SW

root# show interfaces 
ge-0/0/0 {
    flexible-vlan-tagging;
    mtu 9192;
    encapsulation extended-vlan-bridge;
    ether-options {
        ethernet-switch-profile {
            tag-protocol-id 0x8100;
        }
    }
    unit 426 {
        family ethernet-switching {
            interface-mode trunk;
            vlan {
                members 426;
            }
        }
    }
    unit 4000 {
        vlan-id 4000;
    }
}
ge-0/0/1 {
    flexible-vlan-tagging;
    native-vlan-id 150;                 
    encapsulation extended-vlan-bridge;
    unit 0 {
        vlan-id-list 1-4000;
        input-vlan-map push;
        output-vlan-map pop;
    }
}
irb {
    unit 426 {
        family inet {
            address 10.42.6.1/24;
        }
    }
}

root# show vlans 
v4000 {
    interface ge-0/0/0.4000;
    interface ge-0/0/1.0;
}
v426 {
    vlan-id 426;
    l3-interface irb.426;
}

SW-2

 

root# show interface
ge-0/0/0 {
    mtu 9192;
    unit 0 {
        family ethernet-switching {
            port-mode trunk;
            vlan {
                members all;
            }
        }
    }
}
ge-0/0/1 {
    mtu 9192;
    unit 0 {
        family ethernet-switching {
            port-mode trunk;
            vlan {
                members all;
            }
        }
    }
}
vlan {
    unit 426 {                          
        family inet {
            address 10.42.6.2/24;
        }
    }
}

root# show vlans 
v4000 {
    vlan-id 4000;
}
v426 {
    vlan-id 426;
    l3-interface vlan.426;
}

SW-3-ELS-SW

 

root# show interfaces 
ge-0/0/0 {
    flexible-vlan-tagging;
    mtu 9192;
    encapsulation extended-vlan-bridge;
    ether-options {
        ethernet-switch-profile {
            tag-protocol-id 0x8100;
        }
    }
    unit 426 {
        family ethernet-switching {
            interface-mode trunk;
            vlan {
                members 426;
            }
        }
    }
    unit 4000 {
        vlan-id 4000;
    }
}
ge-0/0/1 {
    flexible-vlan-tagging;
    native-vlan-id 150;                 
    encapsulation extended-vlan-bridge;
    unit 0 {
        vlan-id-list 1-4000;
        input-vlan-map push;
        output-vlan-map pop;
    }
}
irb {
    unit 426 {
        family inet {
            address 10.42.6.3/24;
        }
    }
}

root# show vlans 
v4000 {
    interface ge-0/0/0.4000;
    interface ge-0/0/1.0;
}
v426 {
    vlan-id 426;
    l3-interface irb.426;
}
7 REPLIES 7
Ethernet Switching

Re: EX4300 ELS Q-in-Q uplink interface with Vlan Trunk

2 weeks ago

Try using "encapsulation flexible-ethernet-services" instead of extended-vlan-bridge.

 

https://www.juniper.net/documentation/en_US/junos/topics/topic-map/switches-interface-flexible.html

 

Ethernet Switching

Re: EX4300 ELS Q-in-Q uplink interface with Vlan Trunk

2 weeks ago

Seems like EX4300 is not supporting this encapsulation. It's not appearing as an option.

 

Even though it's written about in your doc link..

Ethernet Switching
Solution
Accepted by topic author sesa
2 weeks ago

Re: EX4300 ELS Q-in-Q uplink interface with Vlan Trunk

2 weeks ago

Hi Sesa, 

 

Per doc : 

https://www.juniper.net/documentation/en_US/junos/topics/topic-map/switches-interface-flexible.html

NOTE  : For EX4300 device, the service provider style configuration (encapsulation extended-vlan-bridge) is recommended only for QinQ scenarios. For other scenarios, use the enterprise style configuration.

 

Can you try removing family ethernet-switching and include vlan-ids , for example:? 

 

facing customer
root@EX# show | display set | match ge-0/0/0
set interfaces ge-0/0/0 flexible-vlan-tagging
set interfaces ge-0/0/0 encapsulation extended-vlan-bridge
set interfaces ge-0/0/0 unit 0 vlan-id-list 4
set interfaces ge-0/0/0 unit 0 vlan-id-list 33-34
set interfaces ge-0/0/0 unit 0 vlan-id-list 3000
set interfaces ge-0/0/0 unit 0 vlan-id-list 3092
set interfaces ge-0/0/0 unit 0 vlan-id-list 3096
set interfaces ge-0/0/0 unit 0 vlan-id-list 3100
set interfaces ge-0/0/0 unit 0 vlan-id-list 3104
set interfaces ge-0/0/0 unit 0 input-vlan-map push
set interfaces ge-0/0/0 unit 0 output-vlan-map pop
set vlans VLAN-778 interface ge-0/0/0.0
 
Facing provider
root@EX# show | display set | match ge-0/0/1 
set interfaces ge-0/0/1 flexible-vlan-tagging
set interfaces ge-0/0/1 encapsulation extended-vlan-bridge
set interfaces ge-0/0/1 unit 778 vlan-id 778
set vlans VLAN-778 interface ge-0/0/1.778

 

Please, Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!
 
Regards, 
Franky
Ethernet Switching

Re: EX4300 ELS Q-in-Q uplink interface with Vlan Trunk

2 weeks ago

Hello Franky.

 

Thank you this is working as intented I have tried it.

 

I'm facing another problem. How do I add an l3-interface to one of the vlans on the interface facing provider.

 

I have a case where I have to do mgmt access on the same port as q-in-q.

 

I have tried the config but the switch is not reachable on the assgined IP

 

set interfaces ae0 vlan-tagging
set interfaces ae0 mtu 9192
set interfaces ae0 encapsulation extended-vlan-bridge
set interfaces ae0 unit 426 vlan-id 426
set interfaces ae0 unit 4000 vlan-id 4000


set interfaces irb unit 426 family inet address 10.42.6.3/24


set vlans v4000 interface ge-1/0/1.0
set vlans v4000 interface ae0.4000
set vlans v426 vlan-id 426
set vlans v426 interface ae0.426
set vlans v426 l3-interface irb.426

Ethernet Switching

Re: EX4300 ELS Q-in-Q uplink interface with Vlan Trunk

[ Edited ]
2 weeks ago

Hi Sesa,

I'm glad the first issue got resolved!

 

For your second issue, I think because irb will become up when this is bounded to family-ethernet-switching interface(not sure if in your case is up or down), not vlan-ids.

 

set interfaces ae0 vlan-tagging
set interfaces ae0 mtu 9192
set interfaces ae0 encapsulation extended-vlan-bridge
set interfaces ae0 unit 426 vlan-id 426
set interfaces ae0 unit 4000 vlan-id 4000
set interfaces irb unit 426 family inet address 10.42.6.3/24 >>>> here!
set vlans v4000 interface ge-1/0/1.0
set vlans v4000 interface ae0.4000
set vlans v426 vlan-id 426
set vlans v426 interface ae0.426
set vlans v426 l3-interface irb.426 >>>> here!


Try this one and remove the irb interfaces.

set interfaces ae0 unit 426 vlan-id 426 family inet address 10.42.6.3/24

Try checking if the L3 is learning mac address in the other P router interface.

Please, Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!

 

Thank you,
Franky

Ethernet Switching

Re: EX4300 ELS Q-in-Q uplink interface with Vlan Trunk

2 weeks ago

Hello Franky!

 

Thanks again for your reply. It was my misstake, I forgot to add ae0.426 under vlans.

 

set vlans v426 vlan-id 426
set vlans v426 interface ae0.426
set vlans v426 l3-interface irb.426

Ethernet Switching

Re: EX4300 ELS Q-in-Q uplink interface with Vlan Trunk

2 weeks ago

Hello Sesa, 

 

Oh cool! thanks for accepting my solution, much appreciated! 


@sesa wrote:

Hello Franky!

 

Thanks again for your reply. It was my misstake, I forgot to add ae0.426 under vlans.

 

set vlans v426 vlan-id 426
set vlans v426 interface ae0.426
set vlans v426 l3-interface irb.426


 

Have  a good day!

Franky