Ethernet Switching
Ethernet Switching

EX4500 VC - version

02.11.12   |  
‎02-11-2012 03:32 PM

I'm about to rollout 3 sets of EX4500s in VC mode.  The recommended version for EX4500 in VC mode is currently JUNOS 11.1R6.4.  However the recommended version site also says that "Expected End of Life for Junos Release 11.1 will happen on 05/15/2012, so please contact Juniper TAC (JTAC) to discuss additional options if required."

 

These switches will be running our storage network via iSCSI so software upgrades in the future will be very tough to do.  I'm thinking I'll just go the most recent version  - 11.4R1.6.  

 

Anyone else running EX4500 in VC mode with this version?  Any thoughts or suggestions?

5 REPLIES
Ethernet Switching

Re: EX4500 VC - version

02.15.12   |  
‎02-15-2012 05:42 AM

I have a VC of 2 EX4500, the only limitation I have running JunOS11.4R1.6 is that QOS des not work on aggregated interfaces. I have just downgraded them the 11.3R5.3 that has been published last night as recommended by my Juniper technical contact to verify that it is a 11.4R1.6 bug

Ethernet Switching

Re: EX4500 VC - version

02.15.12   |  
‎02-15-2012 05:25 PM

yemgi,

 

can you clarify -- QoS on AE interfaces is working in 11.3R5, and not 11.4R1, with the same config?  If so, do you have a PR number?

 

Thanks,

 

will

Highlighted
Ethernet Switching

Re: EX4500 VC - version

[ Edited ]
02.17.12   |  
‎02-17-2012 05:48 AM

I have performed the downgrade to 11.3R5 and QOS on LAG is still not working. As soon as I apply a scheduler-map on an ae interface it shuts it down.

The tech notes indicate that it is supported on the 4500-VC from 11.2R1

http://www.juniper.net/techpubs/en_US/release-independent/junos/topics/concept/ex-series-software-fe...

 

I do not have a PR, I am dealing directly with my Juniper technical contact

Ethernet Switching

Re: EX4500 VC - version

02.18.12   |  
‎02-18-2012 11:46 AM

do you mind posting the relevent portions of your config?

 

now that I think about it, IIRC you apply QoS configuration to the physical interfaces of the LAG, not the LAG interface itself per se, although my config isn't barking a commit error when I configure a QoS settings on an AE interface (scheduler-map, classifier, and rewrite-rule)

 

wimclend

Ethernet Switching

Re: EX4500 VC - version

02.21.12   |  
‎02-21-2012 05:00 AM

We found the issue, it was due to the scheduler map not making use of queue 7.

It is now working fine on JunOS 11.3R5 and 11.4R1.

You have to apply QOS on the ae interface not the physiscal interface