Ethernet Switching
Highlighted
Ethernet Switching

EX4650 - 100gb vc-ports not passing client traffic

[ Edited ]
‎03-22-2020 10:24 AM

I have two EX4650 switches in a preprovisioned virtual chassis:

root@SwitchFabric> show virtual-chassis

Preprovisioned Virtual Chassis
Virtual Chassis ID: 92a8.0532.c3fd
Virtual Chassis Mode: Enabled
Mstr Mixed Route Neighbor List
Member ID Status Serial No Model prio Role Mode Mode ID Interface
0 (FPC 0) Prsnt XH3718360056 ex4650-48y-8c 129 Backup N VC 1 vcp-255/0/54
1 vcp-255/0/55
1 (FPC 1) Prsnt XH3718360020 ex4650-48y-8c 129 Master* N VC 0 vcp-255/0/54
0 vcp-255/0/55

{master:1}
root@SwitchFabric> show configuration virtual-chassis
preprovisioned;
no-split-detection;
member 0 {
role routing-engine;
serial-number XH3718360056;
}
member 1 {
role routing-engine;
serial-number XH3718360020;
}

 

root@SwitchFabric> show chassis hardware
Hardware inventory:
Item Version Part number Serial number Description
Chassis XH3718360020 Virtual Chassis
Routing Engine 0 BUILTIN BUILTIN RE-EX4650-48Y-8C
Routing Engine 1 BUILTIN BUILTIN RE-EX4650-48Y-8C
FPC 0 REV 09 650-083242 XH3718360056 JNP48Y8C-CHAS
CPU BUILTIN BUILTIN FPC CPU
PIC 0 BUILTIN BUILTIN 48x25G-8x100G
Xcvr 54 REV 01 740-061000 1P1C40A4296BR QSFP28-100G-CU1M
Xcvr 55 REV 01 740-061000 1P1C40A4296GH QSFP28-100G-CU1M
Power Supply 0 REV 04 740-070750 1F178310119 JPSU-650W-AC-AI
Power Supply 1 REV 04 740-070750 1F178310031 JPSU-650W-AC-AI
Fan Tray 0 Fan Tray, Back to Front Airflow - AFI
Fan Tray 1 Fan Tray, Back to Front Airflow - AFI
Fan Tray 2 Fan Tray, Back to Front Airflow - AFI
Fan Tray 3 Fan Tray, Back to Front Airflow - AFI
Fan Tray 4 Fan Tray, Back to Front Airflow - AFI
FPC 1 REV 09 650-083242 XH3718360020 JNP48Y8C-CHAS
CPU BUILTIN BUILTIN FPC CPU
PIC 0 BUILTIN BUILTIN 48x25G-8x100G
Xcvr 54 REV 01 740-061000 1P1C40A4296BR QSFP28-100G-CU1M
Xcvr 55 REV 01 740-061000 1P1C40A4296GH QSFP28-100G-CU1M

 

They are connected using two 100Gbps DAC cables on ports 54 and 55 (I tried other 100Gbps ports too, this did not make a difference). The virtual chassis forms correctly, but there is no traffic flow between clients on the two switches. They can communicate within a switch, but not between them. If I configure ports 1-48 as vc-ports (I tested on port 15) and connect 10Gbps DACs, then it works fine, but 100Gbps breaks things. What am I missing?

 

Edit: Forgot to mention, it's running version 18.4R2-S3.

4 REPLIES 4
Highlighted
Ethernet Switching
Solution
Accepted by topic author Boris Mekler
‎03-22-2020 12:33 PM

Re: EX4650 - 100gb vc-ports not passing client traffic

‎03-22-2020 11:02 AM

I don't think that VC is officially supported on QFX5120/EX4650 until 19.3/19.4

 

https://www.juniper.net/documentation/en_US/junos/topics/concept/virtual-chassis-qfx-series-understa... 

 

Two QFX5120 switches or up to four EX4650 switches (a non-mixed Virtual Chassis), as follows:

  • Starting in Junos OS Release 19.3R1, you can interconnect two QFX5120-48Y or EX4650-48Y switches into a Virtual Chassis.

  • Starting in Junos OS Release 19.4R1, you can interconnect up to four EX4650-48Y switches into a Virtual Chassis.

Highlighted
Ethernet Switching

Re: EX4650 - 100gb vc-ports not passing client traffic

‎03-22-2020 11:12 AM

@Boris, as @smiker stated VC is not "officially" support until 19.3R1, as well as any future releases.  Even though configurable and working, TAC may not provide full support, unless you are on 19.3R1 or higher.

 

Just a FYI.

Highlighted
Ethernet Switching

Re: EX4650 - 100gb vc-ports not passing client traffic

‎03-22-2020 11:29 AM

Understood. I was actually in the middle of updating to 19.2R2-S4 as I wrote the post (I'm a bit wary of bleeding-edge releases); if that does not help, I will update to 19.4R1-S1.

Highlighted
Ethernet Switching

Re: EX4650 - 100gb vc-ports not passing client traffic

‎03-22-2020 12:34 PM

19.2 did not resolve it, but 19.4 did - it appears to be working fine now. Thank you.

Feedback