Ethernet Switching
Ethernet Switching

How to optimize VC failover

‎10-18-2011 11:48 PM
Hi all, We have to setup 2x EX4200 as the core switch and some EX 2200 as access switch. We have already configure GRES and nonstop-routing on the EX4200 VC. http://www.juniper.net/techpubs/en_US/junos/topics/task/configuration/nsr-ex-series-cli.html When I trigger the switchover command, no packet lost found and the Master RE switch over successfully. However, when I power off the master RE switch (unplug the power). There is around 4 packet lost. Is there anyway to optimize the packet lost for accident shutdown? Thanks! Fai
5 REPLIES 5
Ethernet Switching

Re: How to optimize VC failover

‎10-19-2011 01:49 AM

Hi Fai,

 

If you're runnig the latest version of Junos (11.3) you can configure Non-Stop Bridging as well which should minimise any disruption during a fail-over - to activate it, turn on GRES (which you've done), turn on synchronisation and then enable nonstop-briding:

 

set chassis redundancy graceful-switchover

set system commit synchronize

set ethernet-switching-options nonstop-bridging

 Hope this helps

Ben Dale
JNCIP-ENT, JNCIP-SP, JNCIP-DC, JNCIE-SEC #63
Juniper Ambassador
Follow me @labelswitcher
Ethernet Switching

Re: How to optimize VC failover

‎10-19-2011 01:55 AM
Hi dfex, nonstop-bridging also has been configured. So seems that is the best results what we can get at this moment. Thank for advise! Fai
Ethernet Switching

Re: How to optimize VC failover

‎10-19-2011 07:14 AM

configure your EX-2200 to form a LACP LAG to the two EX-4200 Members.  With LACP running on the AE I have gotten my failover down to 1 ping or none ( depending which member the session was going to).

 

Hope this helps.

Ethernet Switching

Re: How to optimize VC failover

‎10-20-2011 05:41 AM

Hi Magraw,

  When I failover using cli, I also can get 1 or none ping lost.

  However, when I force shutdown the master, I've got around 4 ping lost. How about your case?

 

Thanks!

Ethernet Switching

Re: How to optimize VC failover

‎10-23-2011 10:16 AM

I am taking into an account that your Layer EX 4200 has got the two units ..

 

Can you check after applying this command ??

 

set virtual-chassis no-split-detection ;

 

Thanks,

MBM...

 

------------------------------

If this post reslove your problem, please accept this solution ...

 

Kudos would be appreciated...