Ethernet Switching
Highlighted
Ethernet Switching

Issues with CISCO 375OE and Juniper 2300

‎05-22-2019 09:33 PM

Hey there

I have a cisco 3750e switch that is trunked to port 0/0/35 on the juniper switch.  Everything lights up fine but I cannot ping to anything. VLAN 1 is disabled on the Cisco Switch because we are using VLAN 27 as the management vlan. How do I get this working? Thanks Smiley Happy

18 REPLIES 18
Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-22-2019 09:38 PM

Please share both Switch's configuration and let me know the ip address you are trying to ping

 

 

Thanks,
Nellikka
JNCIE x3 (SEC #321; SP #2839; ENT #790)
Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!
Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-23-2019 02:43 AM

Your trunk port on the ex2300 has what configuration currently?

set interfaces ge-0/0/0 unit 0 family ethernet-switching interface-mode trunk

set interfaces ge-0/0/0 unit 0 family ethernet-switching vlan members 27

and all other vlans on the port

 

https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/bridging-native-vlan-id-...

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-23-2019 04:10 AM

Hello,

 


@thecrozz wrote:

Hey there

I have a cisco 3750e switch that is trunked to port 0/0/35 on the juniper switch. 


 

Juniper J2300 router is not a switch and it does not have port 0/0/35

https://www.andovercg.com/datasheets/juniper-j2300-j4300-j6300-router.pdf

HTH

Thx

Alex

_____________________________________________________________________

Please ask Your Juniper account team about Juniper Professional Services offerings.
Juniper PS can design, test & build the network/part of the network as per Your requirements

+++++++++++++++++++++++++++++++++++++++++++++

Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-23-2019 10:21 AM

Hi there

It is a EX2300 48 port switch Smiley Happy

Currently on the Cisco 2960 the configuration we have VLAN 1 disabled (as per best practices)

Current configuration : 92 bytes
!
interface GigabitEthernet1/0/24
 description "TO SSWC-2210-1"
 switchport mode trunk
end

SSWC-MEDIABOOTH-1#
.May 23 11:19:06.529 MDT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/24, changed state to down
SSWC-MEDIABOOTH-1#
.May 23 11:19:07.541 MDT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/24, changed state to down
SSWC-MEDIABOOTH-1#
.May 23 11:19:15.689 MDT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/24, changed state to up
SSWC-MEDIABOOTH-1#
.May 23 11:19:17.539 MDT: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on GigabitEthernet1/0/24 VLAN27.
.May 23 11:19:17.539 MDT: %SPANTREE-2-BLOCK_PVID_PEER: Blocking GigabitEthernet1/0/24 on VLAN0001. Inconsistent peer vlan.
.May 23 11:19:17.539 MDT: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking GigabitEthernet1/0/24 on VLAN0027. Inconsistent local vlan.
.May 23 11:19:17.545 MDT: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 3 on GigabitEthernet1/0/24
SSWC-MEDIABOOTH-1#VLAN1713.
.May 23 11:19:17.545 MDT: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking GigabitEthernet1/0/24 on VLAN1713. Inconsistent local vlan.
.May 23 11:19:17.702 MDT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/24, changed state to up

 

On the Juniper 2300 it is


blake.crossley@SSWC-2210-1# run show configuration interfaces ge-0/0/35
description "TO MEDIA BOOTH SWITCH";
unit 0 {
    family ethernet-switching {
        interface-mode trunk;
        vlan {
            members [ 1713 all ];
        }
        storm-control default;
    }
}

{master:0}[edit]

 

Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-23-2019 10:29 AM

Hi there

vlan 27 is the management vlan and yes I am aware that vlan 1 is the default on a juniper switch.

We disabled vlan 1 on our cisco devices so vlan 27 is our management.

we also have 1713, 2213,2313,2613 on the switch.

 

Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-23-2019 10:32 AM

Hi there, 

 

Are you running VSTP on ex2300 ? make sure its enabled on the port and vlan 

set protocols vstp vlan xxx interface ge-0/0/35

 

Also which xSTP flavor is running on the Cisco ? 

 

Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too! Smiley Happy

Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-23-2019 10:38 AM

This happens on the cisco interface..

 

SSWC-MEDIABOOTH-1#
.May 23 11:37:31.584 MDT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/24, changed state to up
.May 23 11:37:33.068 MDT: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on GigabitEthernet1/0/24 VLAN27.
.May 23 11:37:33.068 MDT: %SPANTREE-2-BLOCK_PVID_PEER: Blocking GigabitEthernet1/0/24 on VLAN0001. Inconsistent peer vlan.
.May 23 11:37:33.068 MDT: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking GigabitEthernet1/0/24 on VLAN0027. Inconsistent local vlan.
.May 23 11:37:33.068 MDT: %SP
SSWC-MEDIABOOTH-1#ANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 3 on GigabitEthernet1/0/24 VLAN1713.
.May 23 11:37:33.068 MDT: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking GigabitEthernet1/0/24 on VLAN1713. Inconsistent local vlan.
SSWC-MEDIABOOTH-1#
.May 23 11:37:33.639 MDT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/24, changed state to up

Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-23-2019 02:05 PM

Hi, 

 

I think there is a mismatch in xSTP flavors, make sure you are using vstp to make it compatible with Cisco switch.

 

Try change it and let us know.

 

Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too! Smiley Happy

 

Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-23-2019 08:22 PM

How do I change it to vstp on the juniper side?

Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-23-2019 08:33 PM

Hi thecrozz,

 

Please refer: https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/spanning-trees-vstp-els-...

 

While configuring VSTP though, it'll be worth to be aware of this too:
https://kb.juniper.net/InfoCenter/index?page=content&id=KB18291

 

Hope this helps.

Regards,
-r.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated Smiley Happy.

Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-23-2019 08:34 PM

Please go through this post: https://forums.juniper.net/t5/IOS-to-Junos-I2J-Tips/VSTP-PVST-Spanning-Tree/td-p/136123

 

 

Thanks,
Nellikka
JNCIE x3 (SEC #321; SP #2839; ENT #790)
Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!
Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-23-2019 08:35 PM

@aarseniev wrote:

Hello,

 


@thecrozz wrote:

Hey there

I have a cisco 3750e switch that is trunked to port 0/0/35 on the juniper switch. 


 

Juniper J2300 router is not a switch and it does not have port 0/0/35

https://www.andovercg.com/datasheets/juniper-j2300-j4300-j6300-router.pdf

HTH

Thx

Alex


He mentioned in one of the posts "It is a EX2300 48 port switch Smiley Happy"

 

Hope this helps.

Regards,
-r.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated Smiley Happy.

Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-23-2019 08:45 PM

Hi there so what do I do issue vstp globally on the juniper switch or just interface ge-0/0/35

I am very new to Juniper, thanks!

Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-23-2019 08:55 PM

Hi thecrozz,

 

You can apply it for the interested vlans and if you only have one interface that you need spanning-tree for then specify it like this :

set protocols vstp vlan <vlan-id> interface <intf_name>

 

Ideally you'd want to enable spanning-tree on all redundant links so please check your network if another interface forms a closed loop and needs spanning-tree or its just needed for this port because cisco has it enabled on their side.

 

Regarding VLANs where include, you vlan-id 1 if that's not trunked or disabled on cisco.  Apply VSTP per vlan-id.

 

set protocols vstp vlan 100 interface <intf_name>
set protocols vstp vlan 200 interface <intf_name>

 

 

Hope this helps.

 

Regards,
-r.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated Smiley Happy.

Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-23-2019 09:57 PM

So I tried it and it worked for a minute then dropped the entire switch (Juniper).  I had to rollback to earlier this evening to get it working again. Ugh this shouldnt be that hard.

Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-23-2019 10:04 PM

Hi thecrozz,

 

That means you're likely leaving a loop in the network.  This might need a quick yet careful study of the topology and VLANs trunked on each link.  I'll be surprised if someone has a better advise here.

 

Hope this helps.

Regards,
-r.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated Smiley Happy.

Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-24-2019 05:42 AM

I asked this question a cisco forum and they responded with ...

t looks like you are running MST on the Cisco device

>> May 23 21:18:43.974 MDT: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking GigabitEthernet1/0/24 on MST0

 

And that PVST is running on the Juniper side:

.May 23 21:18:39.911 MDT: %SPANTREE-2-PVSTSIM_FAIL: Blocking designated port Gi1/0/24: Inconsitent superior PVST BPDU received on VLAN 27, claiming root 8200:0008.e3ff.fd90

 

To fix this issue:

a) the best option is to configure the Juniper switch to take part to the same MST region

b) or you should increase the STP priority on the Juniper side to avoid the failure of the consistency check at MST / PVST border link.

 

Having all devices running MST is the best long term solution. Be sure that the Juniper will not be the root bridge.

 

Hope to help

Giuseppe

Ethernet Switching

Re: Issues with CISCO 375OE and Juniper 2300

‎05-24-2019 06:50 AM

Yes that message ">> May 23 21:18:43.974 MDT: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking GigabitEthernet1/0/24 on MST0" would indicate Cisco is configured to run with MSTP.

 

I believe of the 2 choices listed, 'a' would be the better and safer option.

 

As for "best" option - take a look at your network lay-out and determine what needs to change in order to eliminate the need for STP altogether.  There are a large number of technologies and design options that eliminate the need to run STP, and that list is only growing.

 

HTH