Ethernet Switching
Ethernet Switching

LACP Tx on AE Not Incrementing

04.08.12   |  
‎04-08-2012 10:49 AM

Several times in the past few months (at totally different sites/switches), I've run into problems where an AE would not come up running LACP.  I usually setup both sides to be LACP-active.


Digging deeper, the AE interface shows down.  When I do "show int AEx extensive", ethernet link on the physical interfaces show up.  But when I scroll down further and look at the LACP tx and rx packets, usually one side is receiving, but not transmitting LACP frames.  In LACP active mode, both sides should transmit/initiate LACP packets, correct?


Things I've tried:

-deleting/readding the AE (never seems to work)

-capturing LACP packets on the intefaces (IIRC, one side truly wasn't transmitting LACP packets indicating a problem)

-removing LACP and just using static link aggregation (always works)

-restarting the ethernet-switching process (only tried this once, but didn't work and caused weirder issues)

-rebooted the entire switch (seems to work)


Has anybody seen this?  Is it a bug?  I'm almost always running the recommended version of software on the switch.