Ethernet Switching
Highlighted
Ethernet Switching

MX QinQ tunneling with native-vlan-id

‎07-03-2019 05:57 AM

I don't seem to find any documentation regarding the use of QinQ tunneling in combination with the native-vlan-id.

 

Here's what I'm trying to do. On one side I got a QinQ interface where the S-VLAN is the native-vlan-id and hence should accept untagged packets. The C-VLAN is tagged.

On the other side I got a QinQ interface where both S-VLAN and C-VLAN are tagged.

These two sides are interconnected with a l2circuit. where I on both side swap the S-VLAN to 1 so that it can talk to each other.

Is what I'm doing correct?

 

Side A:

 

flexible-vlan-tagging;
native-vlan-id 650;
unit 0 {
    encapsulation vlan-ccc;
    vlan-tags outer 0x8100.650 inner 0x8100.650;
    input-vlan-map {
        swap;
        vlan-id 1;
    }
    output-vlan-map swap;
    family ccc {
        mtu 1530;
    }
}

interface ge-1/0/1.0 {
virtual-circuit-id 650650;
mtu 1530;
}

 

Side B:

    unit 10650 {
        description "CUST: Expereo // virtual-circuit-id: 650650";
        encapsulation vlan-ccc;
        vlan-tags outer 0x8100.650 inner 0x8100.650;
        input-vlan-map {
            swap;
            vlan-id 1;
        }
        output-vlan-map swap;
        family ccc {
            mtu 1530;
        }
    }

interface xe-0/0/1.10650
virtual-circuit-id 650650;
mtu 1530;
}

 

 

3 REPLIES 3
Ethernet Switching

Re: MX QinQ tunneling with native-vlan-id

‎07-03-2019 07:10 AM

"Is what I'm doing correct?" -> if working, I'd say yes, if not working I'd say no?  So which is it?

Ethernet Switching

Re: MX QinQ tunneling with native-vlan-id

‎07-03-2019 07:27 AM

Hi Beezlebub,

 

This is probably what you need: Here is an example :
https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/qinq-tunneling-qfx-serie...


For example, the following configuration makes xe-0/0/1.10 a member of S-VLAN v10, enables Q-in-Q tunneling, maps packets from C-VLANs 100 through 200 to S-VLAN 10, and enables xe-0/0/1 to accept untagged packets. If a packet originates in C-VLAN 100 and needs to be sent across the S-VLAN, a tag with VLAN ID 10 is added to the packet. When a packet is forwarded (internally) from the S-VLAN interface to interface xe-0/0/1, the tag with VLAN ID 10 is removed.

set vlans v10 interface xe-0/0/1.10
set interfaces xe-0/0/1 flexible-vlan-tagging
set interfaces xe-0/0/1 encapsulation extended-vlan-bridge
set interfaces xe-0/0/1 unit 10 vlan-id-list 100-200
set interfaces xe-0/0/1 native-vlan-id 150
set interfaces xe-0/0/1 unit 10 input-vlan-map push
set interfaces xe-0/0/1 unit 10 output-vlan-map pop

 

Other very useful references on the same topic:

https://www.juniper.net/documentation/en_US/junos/topics/topic-map/q-in-q.html

https://forums.juniper.net/t5/Ambassador-Insights/Configuring-Q-in-Q-Tunneling-ELS/ba-p/424100

 

Hope this helps.

Regards,
-r.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated Smiley Happy.

Ethernet Switching

Re: MX QinQ tunneling with native-vlan-id

‎07-03-2019 01:05 PM

Check if you can get any hint from this KB:

https://kb.juniper.net/InfoCenter/index?page=content&id=KB31650&actp=METADATA

 

In the above example, it is using a bridge-domain to tunnel CEs. You can also use VPLS or L2 circuit. But on CE facing side, the VLAN configuration and VLAN input/output mapping operation is the same. 

 

My understanding is, native-vlan is supported on all types of layer 2 interfaces. In Q-in-Q case, it can determine if the packet is coming in with both S-VLAN/C-VLAN or just C-VLAN by checking EtherType(TPID) 


Mengzhe Hu
JNCIE x 3 (SP DC ENT)