Ethernet Switching
Highlighted
Ethernet Switching

Mixing 'families' (inet / Ethernet-switching) on AE interface

‎08-08-2014 08:54 AM

Hi, I've a EX4550 (JUNOS 12.3R4.6) switch with one AE interface. This AE has vlan-tagging enabled. All units on this AE interface are family inet. This AE connects to our backbone. Now I've one interface, ge-0/0/3, which needs to be 'bridged' to ae1.300. So ae1.300 needs family ethernet-switching.  The thing is, the following config does not work, but it does pass 'commit check':

interfaces ge-0/0/3 {                    
   unit 0 {
       family ethernet-switching {
           port-mode access;
           vlan {
               members vlan300;
           }
       }
   }
}

ae1 {
    vlan-tagging;
    aggregated-ether-options {
        lacp {
            passive;
        }
    }
    unit 300 {  << Doesn't seem to work
        vlan-id 300;
        family ethernet-switching;
    }
    unit 370 {   << Works
        vlan-id 370;
        family inet {
            address 1.2.3.82/29;
        }
    }
}

Anyone an idea? Is it possible? If so, what am I doing wrong? ;o)

 

Thanks!

Onno.

- Onno

[Click the "Star" for Kudos if you think I earned it!
If this solution worked for you please flag my post as an "Accepted Solution" so others can benefit..]
2 REPLIES 2
Highlighted
Ethernet Switching

Re: Mixing 'families' (inet / Ethernet-switching) on AE interface

‎08-08-2014 11:53 AM

You can only configure family ethrenet-switching on unit 0 and and you cannot configure another family type with ethernet-swithing on the same port.

[edit interfaces ge-0/0/8 unit 0 family]
'ethernet-switching'
An interface cannot have both family ethernet-switching and vlan-tagging configured
error: configuration check-out failed: (statements constraint check failed)

show ge-0/0/8
unit 0 {
family ethernet-switching {
port-mode access;
}
}
unit 2 {
family inet;

[edit interfaces ge-0/0/8]
'unit 2'
Only unit 0 is valid for this encapsulation error: configuration check-out failed

[KUDOS PLEASE! If you think I earned it!
If this solution worked for you please flag my post as an "Accepted Solution" so others can benefit..]
Highlighted
Ethernet Switching

Re: Mixing 'families' (inet / Ethernet-switching) on AE interface

‎08-08-2014 12:26 PM

Hello,


@Onno wrote:

Hi, I've a EX4550 (JUNOS 12.3R4.6) switch 

<skip>

Anyone an idea? Is it possible? If so, what am I doing wrong? ;o)

 

Thanks!

Onno.


My answers:

1/ To allow a mixture of different subinterfaces/units (L3-routed vs L2-switched) on same physical interface You will need a feature called "flexible-ethernet-services"

2/ The said feature is not supported on EX4550 or any Juniper EX4xxx/EX3xxx/EX2xxx series products

3/ Please use only L2-switched subinterfaces/units on ae1, configure a vlan with id 370 + irb.370 interface assigned to that vlan and add Your IP address 1.2.3.82/29 to irb.370 (this is new ELS-style config for switching products supported from 12.3R2 onwards)

HTH

Thanks

Alex

_____________________________________________________________________

Please ask Your Juniper account team about Juniper Professional Services offerings.
Juniper PS can design, test & build the network/part of the network as per Your requirements

+++++++++++++++++++++++++++++++++++++++++++++

Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Feedback