Ethernet Switching
Ethernet Switching

NETWORK ACCESS TO LAN not working from certain servers in VX Rail after Juniper ex- 3400 integration

‎08-29-2019 06:56 AM

We integrated 2 24-port Ex2200 into a 48-port  EX3400. IN the new EX3400 with the 4 ports (4,5,22,45) connected to VXRail, we cannot access some servers whose IP belongs to LAN, but under the old 2 ex2200, with ports 4,5,22 in one  and port 21 in the other connected to VXRail, we were able to access those servers.

 

I matched all the port configs, but found that there is no vlan LAN, which is our default vlan, trunked through the old and new switches to the RXrails. I trunked LAN through 1 of the 5 ports in the new switch. Our whole network crashed after that point.

I rolled back my config to the one without LAN being trunked.

 

We still cannot access some servers on the VX Rails whose IP belongs to the LAN vlan. The firewall settings in our SRX340 remain the same.

 

Any ideas and suggestions?

3 REPLIES 3
Ethernet Switching

Re: NETWORK ACCESS TO LAN not working from certain servers in VX Rail after Juniper ex- 3400 integration

‎08-29-2019 08:26 AM

Hi Wayne,

 

We might need to look at the vlans and the topology to comment better.  Just to throw some ideas:

a) Are you trying to access the server from within the "LAN" or outside.  In either case, it might be important the EX3400 is aware of the VLAN in question.  

b) Configuring the VLAN "LAN" causing a crash sounds like a loop.  Do you have spanning-tree enabled? I assume no because you only had two EX2200s earlier.  If the 3400 connects to both the 2200s, we have a potential redundant path and you need to enable spanning-tree.  If you only have a few VLANs (in 10's), RSTP might be a simple choice.  If there are several (100's), consider MSTP.  Again, topology will help here.

 

References for RSTP:

https://www.juniper.net/documentation/en_US/junos/topics/topic-map/spanning-tree-configuring-rstp.ht...

https://kb.juniper.net/InfoCenter/index?page=content&id=KB33693&cat=EX3400&actp=LIST

 

After enabling RSTP, ensure the VLAN in question is trunked and test out.

 

Hope this helps.

Regards,
-r.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated Smiley Happy.

 

Ethernet Switching

Re: NETWORK ACCESS TO LAN not working from certain servers in VX Rail after Juniper ex- 3400 integration

‎08-30-2019 07:03 AM

Thanks for your insight, -R.

 

The 2 2200 are not connected to the 3400. All the ports on them have been moved to the 48-port 3400. 

 

we are trying to access the server from outside the LAN in the VXrail. All the ports that are connected to VXrail switch does not have LAN trunked. The servers are virtual but their IPs belong to LAN.  We have about a dozen of vlans, So we used RSTP.

 

I am thinking of create  a separate interface that trunks only LAN and on the VXRail switch do the same. What do you think?

 

Ethernet Switching

Re: NETWORK ACCESS TO LAN not working from certain servers in VX Rail after Juniper ex- 3400 integration

‎08-30-2019 07:08 AM
Finding it a bit tough to imagine without a visual Wayne.

Hope this helps.

Regards,
-r.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated Smiley Happy.

Juniper Business Use Only