Ethernet Switching
Highlighted
Ethernet Switching

NTP Not working ?

02.24.12   |  
‎02-24-2012 07:15 AM

My EX2200 Switch with Junos 11.1R3.5 i can set ntp and it worked

but when i upgrade to Junos 11.4R1.6 when i run this command i got this error

 

xxxxxxx@xxxxxxxxxxxxx> show ntp status
/usr/bin/ntpq: socket: Protocol not supported

xxxxxxx@xxxxxxxxxxxxx> show ntp associations
/usr/bin/ntpq: socket: Protocol not supported

 

i think this have to do with license ?

 

 

Thx

8 REPLIES
Ethernet Switching

Re: NTP Not working ?

02.24.12   |  
‎02-24-2012 10:59 AM
NTP definitely does not require a license . . . can you post your config? if its the same config working in 11.1 and not working in 11.4 you probably want to contact JTAC -- but NTP is definitely not a licensed feature. will
Ethernet Switching
Solution
Accepted by topic author Ibrahim Lubis
‎08-26-2015 01:27 AM

Re: NTP Not working ?

02.24.12   |  
‎02-24-2012 11:27 AM

This is caused by a ntp bug, that was introduced in 11.4.  It only affected the output of 'show ntp' commands.  It did not affect ntp sync functionality.  It is being tracked as PR/722528.  The fix for this problem, has not yet been released.

 

Regards,

Ben

Ethernet Switching

Re: NTP Not working ?

02.24.12   |  
‎02-24-2012 08:25 PM
Oke, thanx ben
Ethernet Switching

Re: NTP Not working ?

07.03.12   |  
‎07-03-2012 03:52 AM

Hi,

 

I'm seeing same problem on 12.1R2.9 OS - "/usr/bin/ntpq: socket: Protocol not supported". Is there a bug again or is it related to something else?

 

Thanks

Ethernet Switching

Re: NTP Not working ?

07.03.12   |  
‎07-03-2012 09:46 AM

istankus wrote:

Hi,

 

I'm seeing same problem on 12.1R2.9 OS - "/usr/bin/ntpq: socket: Protocol not supported". Is there a bug again or is it related to something else?

 

Thanks


This is the same issue.  The next maintenance release of 12.1 will include the fix.

Ethernet Switching

Re: NTP Not working ?

07.16.12   |  
‎07-16-2012 06:37 PM

I was wondering why I hadn't seen this before.  Bug is it may not work if you don't have an IP address on the lo0 interface.

 

There was some software in the past that was attempting to do local communication on the switch using 127.0.0.1 but misbehaving because a) we had firewall filters in place on lo0, and b) 127.0.0.1 was not explicitly configured.  To deal with the problem at the time I updated our standard configurations to include the following:

set interfaces lo0 unit 0 family inet address 127.0.0.1/32

That ensures lo0 always exists and has an address.  No negative repercussions assigning the loopback address to the loopback interface even if you don't use the loopback interface for anything else.

 

Using 127.0.0.1/32 is also a very useful trick when using apply-path prefix lists.

set policy-options prefix-list PL-BGP_PEERS 127.0.0.1/32
set policy-options prefix-list PL-BGP_PEERS apply-path "protocols bgp group <*> neighbor <*>"

If the apply-path doesn't exist (for example, no bgp peers yet) and there is no other prefix in the prefix list then the prefix list is effectively 0/0 (any).  Add 127.0.0.1/32 to the prefix list and it now always has something and will always work as expected in the firewall filters.

 

Cheers!

 

-Chad

Ethernet Switching

Re: NTP Not working ?

07.17.12   |  
‎07-17-2012 01:58 AM

Thanks Chad!

 

Fixed my issue.

 

show ntp associations
/usr/bin/ntpq: socket: Protocol not supported

lab123@lab123> show configuration interfaces lo0

lab123@lab123> edit
Entering configuration mode

[edit]
lab123@lab123# set interface lo0.0 family inet address 127.0.0.1/32

[edit]
lab123@lab123# commit check
configuration check succeeds

[edit]
lab123@lab123# commit and-quit
commit complete
Exiting configuration mode

lab123@lab123> show ntp associations
remote refid st t when poll reach delay offset jitter
==============================================================================
10.71.10.14 159.134.192.1 3 - 1 64 1 2.156 -287472 1.402

lab123@lab123>

 

 

Ethernet Switching

Re: NTP Not working ?

01.13.14   |  
‎01-13-2014 03:17 AM

Hi guys,

I had same problem...and adding of  an ip to lo0 solved the problem

set interfaces lo0 unit 0 family inet address 127.0.0.1/32 

 

Thanks