Ethernet Switching
Highlighted
Ethernet Switching

PWHT for residential subscriber management

[ Edited ]
‎05-28-2019 02:53 AM

Hi,

 

since to many days I'm struggling with a PWHT setup by referring to the following howto:

 

https://www.juniper.net/documentation/en_US/release-independent/nce/topics/example/nce-141-example-s...

 

In my case EX4600-40F is used on the PE side wheras MX104 is my BNG. To start simple my problem is the following:

- the CE facing interfaces do not receive tagged frames on it's appropriate logical interface form any connected CE

 

My current CE device is connected to PE port ge-0/0/3 and will send single tagged (VLAN 7) frames (dhcp discovers) that should reach my BNG that acts a a DHCP server.

 

show interfaces ge-0/0/3
flexible-vlan-tagging;
encapsulation flexible-ethernet-services;
gigether-options {
loopback;
}
unit 1 {
encapsulation vlan-ccc;
vlan-id-list 1-10;
}

 

For some reason I don't see any input output pakets on the logical interface ge-0/0/3.1, but I do see some packets for untagged traffic on ge-0/0/3.32767 :

 

run show interfaces ge-0/0/3
Physical interface: ge-0/0/3, Enabled, Physical link is Up
Interface index: 657, SNMP ifIndex: 537
Link-level type: Flexible-Ethernet, MTU: 1522, LAN-PHY mode, Speed: 1000mbps, BPDU Error: None, Loop Detect PDU Error: None, Ethernet-Switching Error: None, MAC-REWRITE Error: None,
Loopback: Enabled, Source filtering: Disabled, Flow control: Disabled, Auto-negotiation: Enabled, Remote fault: Online, Media type: Fiber
Device flags : Present Running Loop-Detected
Interface flags: SNMP-Traps Internal: 0x4000
CoS queues : 12 supported, 12 maximum usable queues
Current address: b8:c2:53:a9:c2:06, Hardware address: b8:c2:53:a9:c2:06
Last flapped : 2019-05-28 08:35:19 CEST (02:58:55 ago)
Input rate : 0 bps (0 pps)
Output rate : 0 bps (0 pps)
Active alarms : None
Active defects : None
PCS statistics Seconds
Bit errors 0
Errored blocks 0
Ethernet FEC statistics Errors
FEC Corrected Errors 0
FEC Uncorrected Errors 0
FEC Corrected Errors Rate 0
FEC Uncorrected Errors Rate 0
Interface transmit statistics: Disabled

Logical interface ge-0/0/3.1 (Index 567) (SNMP ifIndex 538)
Flags: Up SNMP-Traps Redundancy-Device 0x4000 VLAN-Tag [ 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 ] Encapsulation: VLAN-CCC
Input packets : 0
Output packets: 0
Protocol ccc, MTU: 1522
Flags: None

Logical interface ge-0/0/3.32767 (Index 566) (SNMP ifIndex 539)
Flags: Up SNMP-Traps 0x4004000 VLAN-Tag [ 0x0000.0 ] Encapsulation: ENET2
Input packets : 19
Output packets: 19

 

So this is actually my issue I'm despairing of. I'm really sure my CE device will send tagged frames, but I'm not sure if there are any limitations for the EX4600. Indeed there are some MPLS limitations for QFX and EX series:

 

https://www.juniper.net/documentation/en_US/junos/topics/reference/general/mpls-limitations-qfx-seri...

 

E.g.

  • (QFX5100, QFX5110, QFX5120, QFX5200, QFX5210, EX4600) When VLAN bridge encapsulation is enabled on a CE connected interface, the switch drops packets if both flexible Ethernet services and VLAN CCC encapsulations are configured on the same logical interface. Only one can be configured, not both. For example:

    set interfaces xe-0/0/18 encapsulation flexible-ethernet-services, or set interfaces xe-0/0/18 encapsulation vlan-ccc.

For my setup VLAN bridge encapsulation is not enabled so this limitation won't apply here.

 

The whole l2circuit itself is working. I do have a connection in up state and can ping from both directions (PE / BNG) via ping mpls l2circuit interface ...

 

IMHO the issue is not related to LDP / MPLS or l2circuit configuration. Is there another limitation I didn't considered yet? Are there any other show / debug commands I can uses to investigate further?

 

I attached the PE configuration to the thread (removed private parts, changed ip addresses).

 

 

 

 

Attachments

2 REPLIES 2
Highlighted
Ethernet Switching

Re: PWHT for residential subscriber management

[ Edited ]
‎05-28-2019 05:50 AM

Hello Okutscher,

 

The only thing that really stands out is the loopback configuration on your port, which probably is not needed:


@okutscher wrote:

gigether-options {
loopback;
}

Can you please delete it and see if there is any difference?


Best regards,
Sergii
-------------------------------------------------------------------
Please accept the solution if your problem is resolved Smiley Happy
-------------------------------------------------------------------

Highlighted
Ethernet Switching

Re: PWHT for residential subscriber management

‎05-28-2019 07:59 AM

Hi,

 

unfortunately this doesn't change anything. This is my current interface configuration:

 

flexible-vlan-tagging;
encapsulation flexible-ethernet-services;
unit 1 {
encapsulation vlan-ccc;
vlan-id-list 1-10;
}