Ethernet Switching
Highlighted
Ethernet Switching

Port is never up on my juniper.

‎11-07-2019 05:58 AM

Hi guys,

 

I have one problem for the EX 2300 24T series switch. Today i bought Card Access Controller on my company. But when i connection to on my juniper EX 2300 24 T series switch. Card Access Controller never be port UP. However when i  put one hub between switch and card. Connection is UP. How can i fixed this problem. Card Access Controller runnig vlan 1 and my Juniper switch have a default configuration. Card model is a gallagher cardax 3000.

 

Thank you for help.

 

8 REPLIES 8
Highlighted
Ethernet Switching

Re: Port is never up on my juniper.

‎11-07-2019 08:34 AM

The Cardax 3000 runs at 10Mb -- try hardcoding your switch port:

 

set interfaces interface-name speed 10m

Highlighted
Ethernet Switching

Re: Port is never up on my juniper.

‎11-07-2019 08:51 AM

I was thinking what @smiker stated was probably the situation.  You could confirm this when the hub is in place.  Just check the port speed and duplex on the hub for the links that are up.  I am going to assume 1GE/1000M on interface to EX2300 and 10 (maybe HDX?) on the interface to Cardax 3000.  What ever the Cardax side shows, hard code that on EX2300 and see what happens.

Highlighted
Ethernet Switching

Re: Port is never up on my juniper.

‎11-07-2019 09:29 PM

Hi everyone again,

i tried change speed all of options. However port dont be up. I tried this command line.

 

set interfaces interface-name speed 10m link-mode halfduplex

set interfaces interface-name speed 10m link-mode fullduplex

set interfaces interface-name speed 100m link-mode halfduplex

set interfaces interface-name speed 100m link-mode fullduplex

set interfaces interface-name speed 1g link-mode fullduplex

set interfaces interface-name speed auto link-mode fullduplex

set interfaces interface-name speed auto-10m-100m link-mode fullduplex

 

any have diffrenet idea about this problem?

 

 

 

Highlighted
Ethernet Switching

Re: Port is never up on my juniper.

‎11-08-2019 12:17 AM

I know you are saying it's a default configuration.. but did you by any chance configure both rstp and vstp on you switchports?

 

I've seen another case with an embedded device where the link never came up but worked on a random unmanaged switch - and having both rstp and vstp on the same interface on the EX2300 or EX3400 made it break.


--
Best regards,

Jonas Hauge Klingenberg
Juniper Ambassador & Technology Architect, SEC DATACOM A/S (Denmark)
Highlighted
Ethernet Switching

Re: Port is never up on my juniper.

‎11-11-2019 11:16 PM

Hi,

 

Do you have any configuration about your idea ?

 

Best Regards,

Highlighted
Ethernet Switching

Re: Port is never up on my juniper.

‎11-11-2019 11:49 PM
Hi Cagataysag<>,

Believe what he meant was "check if you have both RSTP and VSTP" protocols configured for the interface and remove at least one i.e.

show configuration | display set | match | match stp <<<<<<<<<edit
delete protocols vstp interface

Hope this helps.

Regards,
-r.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated Smiley Happy.
Highlighted
Ethernet Switching
Solution
Accepted by topic author Cagataysag
‎11-12-2019 12:38 AM

Re: Port is never up on my juniper.

‎11-11-2019 11:55 PM

Hi,

 

I deleted rstp configure command on my switch but my port is dont be up again. I cannot this problem. Also i dont have any configuration vtsp on my switch.

 

Best Regards.

Highlighted
Ethernet Switching

Re: Port is never up on my juniper.

‎11-12-2019 07:08 AM
Could you please get "show interfaces extensive " when the port is up with the hub?

Hope this helps.

Regards,
-r.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated Smiley Happy.