Ethernet Switching
Highlighted
Ethernet Switching

Problem with Juniper SFP "CM_JAVA [FPC:0 PIC:1]: Failed to uplink SFP 1 EEPROM"

[ Edited ]
‎04-13-2017 04:08 AM

Hi All,

 

we have a switch that is constantly spamming the following messages:

Apr 13 13:00:29 sw04.hil.uto chassism[1227]: XCVR: XCVR 1 EEPROM read Failed
Apr 13 13:00:29 sw04.hil.uto chassism[1227]: xcvr_cache_eeprom: xcvr_read_eeprom failed - link:1 pic_slot:1
Apr 13 13:00:29 sw04.hil.uto chassism[1227]: CM_LED: Unable to set frontpanel led for register: 0x3c bit loc 0
Apr 13 13:00:30 sw04.hil.uto chassism[1227]: cm_read_i2c errno:16, device:13
Apr 13 13:00:30 sw04.hil.uto chassism[1227]: I2C bus busy. Attempting I2C bus reset: device = 13
Apr 13 13:00:30 sw04.hil.uto chassism[1227]: I2C bus reset done!!
Apr 13 13:00:30 sw04.hil.uto chassism[1227]: CM_JAVA [FPC:0 PIC:1]: Failed to uplink SFP 1 EEPROM
Apr 13 13:00:30 sw04.hil.uto chassism[1227]: XCVR: XCVR 1 EEPROM read Failed

 

We also see a high amount of delay when we ping this host, it is also a Juniper compatible optic.

 

If anyone could help me in terms of some troubleshooting/fixing that would be great.

 

***EDIT***

Switch Model- EX2200-C-12T-2G

Version - 12.3R12.4

Uptime - 64 weeks

 

Kind regards,

 

Dennis Verheul

NEP Worldwide

5 REPLIES 5
Highlighted
Ethernet Switching

Re: Problem with Juniper SFP "CM_JAVA [FPC:0 PIC:1]: Failed to uplink SFP 1 EEPROM"

‎04-13-2017 05:57 AM

Hi,

 

You do not indicate;

 

-Type of EX switch

-Junos running

-Type of compatible optics

 

The e-prom is probably wrong coded in the optics, please run: show chassis hardware and indicate what you get on the pic row where you have inserted the actual sfp in terms of

 

Version

Part number

Serial number

Description

 

 

MICDUF
Highlighted
Ethernet Switching

Re: Problem with Juniper SFP "CM_JAVA [FPC:0 PIC:1]: Failed to uplink SFP 1 EEPROM"

‎04-13-2017 06:52 AM

Hi MICDUF,

 

Pardon me for not excluding the information, i've added it to the origina post.

Aas for the output of the show chassis hardware command:

REV 01   740-011614   VE134100217       SFP-LX10

 

We use these kind of optics almost everywhere and this is the only environment where we see this behaviour.

Highlighted
Ethernet Switching

Re: Problem with Juniper SFP "CM_JAVA [FPC:0 PIC:1]: Failed to uplink SFP 1 EEPROM"

‎04-13-2017 06:57 AM

Looks to be some sort of HW issue, not SW, so why not just RMA the switch?

Highlighted
Ethernet Switching

Re: Problem with Juniper SFP "CM_JAVA [FPC:0 PIC:1]: Failed to uplink SFP 1 EEPROM"

‎04-13-2017 07:01 AM

Hi,

 

We're looking for a solution with the least downtime, as it is a live environment.

Highlighted
Ethernet Switching

Re: Problem with Juniper SFP "CM_JAVA [FPC:0 PIC:1]: Failed to uplink SFP 1 EEPROM"

‎10-03-2019 02:27 PM

I realize this is an old thread but did you find a solution?  We have an EX4200 that is spamming the same messages.  Thanks.

Feedback