Ethernet Switching
Ethernet Switching

QFX - Not Passing Vlans via Trunk?

[ Edited ]
‎11-15-2019 10:37 AM

Hey Guys,

 

What do I have wrong?

 

I can get an IP if I use access mode and switch to untagged in the rest of my network, but tagging isn't working. 

 

 

ae1 = Trunk to Distro switch with a LACP, then that switch has an interface connected to DHCP server with all vlans tagged. 

 

Ge-[1-2]/0/3 = connection to downstream devices with vlans tagged on their nics

 

See anything wrong? 

 

vlans {
    Hosted {
        vlan-id-list 1-3999;
    }
    default {
        vlan-id 4000;
    }


    ae1 {
        flexible-vlan-tagging;
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members all;


    ge-1/0/2 {
flexible-vlan-tagging;
unit 0 {
    family ethernet-switching {
        interface-mode trunk;
        vlan {
            members all;
        }
    }
}
                }                       
            }
        }
    }
    ge-1/0/3 {
        ether-options {
            802.3ad ae1;
        }
    }
 ge-0/0/2 {
flexible-vlan-tagging;
unit 0 {
    family ethernet-switching {
        interface-mode trunk;
        vlan {
            members all;
        }
    }
}
    ge-0/0/3 {
        ether-options {
            802.3ad ae1;
        }
    }
6 REPLIES 6
Ethernet Switching

Re: QFX - Not Passing Vlans via Trunk?

‎11-17-2019 03:57 AM

Did you want your default vlan id to be untagged on the trunk ports?

If so you need to declare that as a native vlan and remove from the members list

 

https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/bridging-native-vlan-id-...

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Ethernet Switching

Re: QFX - Not Passing Vlans via Trunk?

‎11-17-2019 05:07 PM

Hey, 

 

Nope. 

 

This is acting as our distro switch so it needs to just be a trunk and allow all vlans. 

 

Outside of that, does anything look wrong? 

Ethernet Switching

Re: QFX - Not Passing Vlans via Trunk?

[ Edited ]
‎11-18-2019 02:56 AM

Sorry, just noticed you say that lacp is enabled on the link.  You would need to add to your ae config

set interfaces ae1 aggregated-ether-options lacp (active or passive per you setup on the other side)

 

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Ethernet Switching

Re: QFX - Not Passing Vlans via Trunk?

‎11-18-2019 06:36 AM

so the LAG will come up if I dont' have that?

 

I can run "show int ae1" and it's up/up

 

Still not passing traffic sadly 

 

This is odd. 

Ethernet Switching

Re: QFX - Not Passing Vlans via Trunk?

‎11-18-2019 09:31 PM

Hi RoutingFrames,

 

Please double check if the ingress/egress ports have all the intended vlans allowed.  

 

For the LAG "ae1", yes it will show up/up if the other end does not have LACP configured.  However, it is a good idea to configure LACP on both ends so the LAG will only come up only when there are LACP packets sent/received properly.  That sometimes helps find transport issues and the health of the link as such.

 

Hope this helps.

 

Regards,
-r.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated Smiley Happy.

Ethernet Switching

Re: QFX - Not Passing Vlans via Trunk?

‎11-20-2019 02:36 AM

I assume you now have the lacp matching with the other switch and it still does not work.

What is the device connected here?

 

You can use the monitor interface command to verify packets are passing the ae port when up and running.

 

 

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home