Ethernet Switching
Ethernet Switching

QFX3500-48s4q-acrb stuck in virtual chassis/linecard config

‎07-12-2017 04:43 PM

I would like to reset some QFX3500's that my company just got in back to fresh out of box factory config, however they seem to be stuck in a Virtual-chassis setup. I have even tried doing a fresh clean install from the loader prompt with the --format, and these units still seem to be stuck in the virtual chassis config. 

 

When I try doing the command "show chassis hardware detail" I get the following output.

 

root@P6893-C:LC:0% cli
root@P6893-C> show chassis hardware detail
error: the chassis-control subsystem is not running

root@P6893-C>

 

I have tried the "restart chassis-control" command. The units just come back stating that they could not be started.

 

I have tried doing a zeroize and going into config and doing a "load factory-default" when I do this command I get the following output.

 

root@P6893-C# load factory-default
warning: activating factory configuration
[edit]
'protocols'
warning: statement has no contents; ignored

[edit]
root@P6893-C#

 

for the life of me I just can't get these units to reset to factory defaults. 

What am I missing here?

12 REPLIES 12
Ethernet Switching

Re: QFX3500-48s4q-acrb stuck in virtual chassis/linecard config

‎07-16-2017 04:48 PM

I believe you need to use zeroize in this case.

 

request system zeroize

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Ethernet Switching

Re: QFX3500-48s4q-acrb stuck in virtual chassis/linecard config

[ Edited ]
‎07-17-2017 01:23 PM

Already tried that. It is one of the first things that I did as noted in my original post.

 

 

 

Ethernet Switching

Re: QFX3500-48s4q-acrb stuck in virtual chassis/linecard config

‎07-19-2017 03:56 PM

Sorry, I did not read closely enough.

 

There is a potenial issue with split detection on devices that are alone after having been in a virtual chassis.

 

Try adding this line to the configuration and commiting.

 

set virtual-chassis no-split-detection

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Ethernet Switching

Re: QFX3500-48s4q-acrb stuck in virtual chassis/linecard config

‎07-21-2017 09:35 AM

Hi mdpeel 

 

What is the image verison you are running on this ? Can you try and load 14.1X53-D42 and check if you still see issues with chassis control subsystem?

 

Thanks

Arul

 

 

Ethernet Switching

Re: QFX3500-48s4q-acrb stuck in virtual chassis/linecard config

‎01-16-2018 02:04 PM

Sorry took so long to reply, Had to set these aside and move on to other things. I have version 14.1X53-D25.2 installed

Ethernet Switching

Re: QFX3500-48s4q-acrb stuck in virtual chassis/linecard config

[ Edited ]
‎01-16-2018 02:11 PM

I did the "set virtual-chassis no-split-detection" with no change.  At this point and time there should be no config on the unit that I am working on. I have even tried Reverting to the Default Factory Configuration doing the following steps. With no luck.

[edit]
user@switch# load factory-default
[edit]
user@switch# delete system commit factory-settings
[edit]
user@switch# commit

 

 

Ethernet Switching

Re: QFX3500-48s4q-acrb stuck in virtual chassis/linecard config

‎01-16-2018 05:08 PM

I have also downloaded the install media image created the installation usb media and the system still seems to be stuck as a linecard even with a format install.

Ethernet Switching

Re: QFX3500-48s4q-acrb stuck in virtual chassis/linecard config

‎01-16-2018 08:08 PM
I can’t believe doing an install format wouldn’t reset that. Delete all files under /config/vchassis and reboot.
Ethernet Switching

Re: QFX3500-48s4q-acrb stuck in virtual chassis/linecard config

‎01-17-2018 09:26 AM

still a no go. Could this be a hardware issue of some sort?

Ethernet Switching

Re: QFX3500-48s4q-acrb stuck in virtual chassis/linecard config

‎01-19-2018 03:17 AM

I agree that this is starting to look like a hardware RMA will be needed.

I suggest you open a JTAC ticket for review.

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Ethernet Switching

Re: QFX3500-48s4q-acrb stuck in virtual chassis/linecard config

‎01-30-2018 08:21 AM

Did you try to 1) delete the whole config but the root password 2) apply your own preprovisioned VC configuration with this single switch defined as member ID 0  and routing-engine role (you will have to use P6893-C if this is true for that switch, as its serial-number, as the shorter SN that is printed on its label will not work) 3) commit and reboot 4) give it some minutes after reboot.

Once it has this applied you could further try to use 'request virtual-chassis reactivate' to make this one become master and active.

Ethernet Switching

Re: QFX3500-48s4q-acrb stuck in virtual chassis/linecard config

[ Edited ]
‎02-20-2018 04:46 PM

I went ahead and deleted all configurations except for the password then did the config how you suggested, commited and then rebooted.

However when the unit came back up after the reboot the config had reverted back to what it was before.

For some reason the unit is not saving the config. 

After doing a commit is there anything else that I need to be doing to save the config?

 

Here is the conf that one of the units keeps reverting to.

 

root@P6893-C> show configuration
## Last commit: 2018-02-21 01:48:50 UTC by root
version 15.1R6.7;
system {
arp {
aging-timer 5;
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
file interactive-commands {
interactive-commands any;
}
}
commit {
factory-settings {
reset-chassis-lcd-menu;
}
}
## Warning: missing mandatory statement(s): 'root-authentication'
}
protocols {
igmp-snooping {
##
## Warning: configuration block ignored: unsupported platform (qfx3500)
##
vlan all;
}
}

root@P6893-C>