Ethernet Switching
Ethernet Switching

QFX5100 port lockup

‎10-25-2019 03:37 PM

Hi!

We have a few QFX5100s and in one of them four ports do not accept QSFP+ DAC cables (and probably not fiber QSFP+ modules) right now. The ports in question are et-0/0/16 to 19. We could reboot the switch and the ports would probably come up, but as this is a production switch, we'd like to explore other options first. I suspect that the QFX5100-24Q has its physical ports divided into port groups where a certain number of ports share some hardware, like a PHY or MAC chip. Reading up on the matter, I see that the QFX10k 36Q has its ports in groups of three, as do lots of other 40/100 G switches. In a deep dive PDF about the QFX5100, I read that the 24Q version can channelize ports 4 to 24, not 0-3. That makes me think that this model has ports grouped in groups of four. That would align with ports 16-19 that we're having problems with. Does anyone know if this is indeed so, and can this common piece of hardware (4-port MAC/PHY/whatever) be reset without too much risk of upsetting the rest of the system?

 

I have seen a similar scenario in an Avaya VSP9k where ports were divided in groups of 8 and each group consisted of two lanes with 4 ports each. One lane (ports 21-24) locked up and caused a massive traffic storm as the combined MC-LAG ICL/ICCP link (called IST in Avayas SMLT terminology) was on port 23 and 24.

 

From other vendors (Avaya, Extreme, Cisco and others) I know port grpoups exist, but I seem to be unable to find info on the QFX5100-24Q in that regard. Can anyone help?

 

/Fredrik

1 REPLY 1
Highlighted
Ethernet Switching

Re: QFX5100 port lockup

‎10-25-2019 04:05 PM

...and by the way, we can see the DAC cables when doing this:

 

> start shell
> vty fpc0
> show qsfp list

but not when typing "show chassis hardware".

 

When inserting a DAC in port 16, we get the following:

Oct 19 12:33:42 qfx5100-1 fpc0 qsfp-0/0/16 plugged in
Oct 19 12:33:42 qfx5100-1 fpc0 FAILED to write the QSFP IDEEPROM for port: 16 start addr: 127 - length: 1
Oct 19 12:33:42 qfx5100-1 fpc0 qsfp_tk_select_mem_page: qsfp-0/0/16 failed to select mem page 0 addr 0x7f err 1000

 

But, again, I'm mostly interested in if the fact that all ports work except ports 0/0/16 to 19 can be due to some port grouping, and of course if we can recover without rebooting the switch or pfe.

Feedback