Ethernet Switching
Ethernet Switching

Recovering an EX4200 which won't boot to loader> prompt

‎05-31-2019 07:48 AM

I have an EX4200 which won't boot to the loader> prompt. Unfortunately I don't have output from the console at the moment.

 

I found instructions on how to recover using USB once you get to the loader> prompt, but I can't find anything about how to recover if that prompt doesn't appear.

 

Can someone help?

10 REPLIES 10
Ethernet Switching

Re: Recovering an EX4200 which won't boot to loader> prompt

‎05-31-2019 08:16 AM

This is the link I found to recover from USB:

 

https://kb.juniper.net/InfoCenter/index?page=content&id=KB10386&actp=METADATA

 

But I can't do this because I can't get to a prompt to tell the switch to do this.

Ethernet Switching

Re: Recovering an EX4200 which won't boot to loader> prompt

‎05-31-2019 12:46 PM

Hi there, 

 

Is the console cable working ? check if you are using the right console settings and you select the correct COM number in device manager , also a common port setting will be 9600 / 8 / none / 1 / none, also try using another cable , if you have another one and see if that works.

 

If the switch is not loading loader prompt or not getting anything on the console screen, then you might probably need to replace the equipment, since loader prompt is the only recovery mode for ex4200.

 

Please mark my solution as accepted if it helped, Kudos are appreciated as well.  Smiley Happy

 

Ethernet Switching

Re: Recovering an EX4200 which won't boot to loader> prompt

‎05-31-2019 02:16 PM

Yeah the console works, I'm just 2000 miles away from it so it's hard to get to.

 

It boots up and has some error, then reboots in a loop.

 

Yeah we might have to replace it.

 

Thanks.

Ethernet Switching

Re: Recovering an EX4200 which won't boot to loader> prompt

‎05-31-2019 02:51 PM

No problem.

In curious which errors are you receiving in console, maybe there is something else to check.

Ethernet Switching

Re: Recovering an EX4200 which won't boot to loader> prompt

‎06-03-2019 06:18 AM

Good Day,

 

There is a KB27255 which answer s your question.

[EX/QFX] Recover EX switch while it cannot get into loader prompt

https://kb.juniper.net/InfoCenter/index?page=content&id=KB27255

Hope it will help you.

Highlighted
Ethernet Switching

Re: Recovering an EX4200 which won't boot to loader> prompt

‎06-03-2019 05:52 PM

Since you have a boot loop, you need to try and interupt the boot process near the start before it can get to the failed process that causes to the loop to occur.  Once interuptted successfully let us know what the prompt is.

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Ethernet Switching

Re: Recovering an EX4200 which won't boot to loader> prompt

‎06-05-2019 11:29 AM

I can't seem to make the boot process stop. It just loops. This is what I see:

 

Rebooting...

U-Boot 1.1.6 (Feb  6 2008 - 11:27:42)

Board: EX4200-48T 2.7
EPLD:  Version 6.0 (0x85)
DRAM:  Initializing (1024 MB)
FLASH: 8 MB
USB:   scanning bus for devices... 2 USB Device(s) found
       scanning bus for storage devices... 1 Storage Device(s) found

Consoles: U-Boot console
Found compatible API, ver. 7

FreeBSD/PowerPC U-Boot bootstrap loader, Revision 2.1
(marcelm@apg-bbuild01.juniper.net, Wed Feb  6 11:23:55 PST 2008)
Memory: 1024MB
Waiting for PHY auto negotiation to complete...... TIMEOUT !
Waiting for PHY realtime link...... TIMEOUT !
 done
eTSEC0: No link.
eTSEC2: No link.
panic: uboot_eth0: initialisation failed.

--> Press a key on the console to reboot <--

I tried break and control C and other stuff but it won't interrupt this process. If I hit a key it just reboots.

 

Any ideas?

Ethernet Switching

Re: Recovering an EX4200 which won't boot to loader> prompt

‎06-05-2019 04:48 PM

It appears that either the internal media is corrupted or a hardware failure.

 

If you have a working ex4200, insert a USB drive and then run a snapshot to the USB.

request system snapshot media usb

 

On your computer then copy an install file for your version of junos into the /var/tmp directory.

 

then insert this drive into the broken device and then power it on.

If the hardware is good enough it will boot from the USB image.

 

From here you can then install with format junos on the internal media for the saved installer file.

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Ethernet Switching

Re: Recovering an EX4200 which won't boot to loader> prompt

‎06-05-2019 09:32 PM

This seems like a hardware failure. You might have to go for the replacement here.

To recover we somehow need to load the atleast the initial boot (which seems to be failing to initiate here) and get to the loader prompt for a format install.

 

Hope this helps.

 

Thanks

 

Ethernet Switching

Re: Recovering an EX4200 which won't boot to loader> prompt

‎06-06-2019 12:40 AM

Good Day,

 

Yes, this is most likely hardware issue, replacement is the only solution in this case.