Ethernet Switching
Ethernet Switching

Route VLANS

‎09-05-2019 01:05 PM

Hi all.

I have a question. I configured my switch and I made 2 VLAN's, I did everything correctly. I set 2 hosts up in port 1 (Vlan 10) and port 2 (vlan 10).

But I have a very weird problem. I can ping my own gateway and the other gateway from each host, but I can not ping hosts from each host.

 

 ## Last changed: 2000-02-24 03:12:30 UTC
version 15.1X53-D591.1;
system {
auto-snapshot;
ports {
auxiliary port-type rj45;
}
root-authentication {
encrypted-password "$5$u.mxnUhZ$dnIMTbjJZpX1l9QLlycoSjtCEML43tsxO34qShONkK8";
}
services {
web-management {
http;
}
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
file interactive-commands {
interactive-commands any;
}
}
processes {
dhcp-service {
traceoptions {
file dhcp_logfile size 10m;
level all;
flag all;
}
}
}
}
chassis {
redundancy {
graceful-switchover;
}
}
interfaces {
ge-0/0/0 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/1 {
unit 0 {
family ethernet-switching {
vlan {
members PC;
}
storm-control default;
}
}
}
ge-0/0/2 {
unit 0 {
family ethernet-switching {
vlan {
members Printer;
}
storm-control default;
}
}
}
ge-0/0/3 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/4 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/5 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/6 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/7 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/8 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/9 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/10 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/11 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/12 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/13 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/14 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/15 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/16 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/17 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/18 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/19 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/20 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/21 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/22 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/23 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/24 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/25 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/26 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/27 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/28 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/29 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/30 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/31 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/32 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/33 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/34 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/35 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/36 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/37 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/38 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/39 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/40 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/41 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/42 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/43 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/44 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/45 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/46 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/47 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/1/0 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
xe-0/1/0 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/1/1 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
xe-0/1/1 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/1/2 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
xe-0/1/2 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/1/3 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
xe-0/1/3 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
irb {
unit 0 {
family inet {
dhcp {
vendor-id Juniper-ex2300-48p;
}
}
}
unit 10 {
family inet {
address 172.16.77.126/25;
}
}
unit 20 {
family inet {
address 172.16.77.190/26;
}
}
}
vme {
unit 0 {
family inet {
dhcp {
vendor-id Juniper-ex2300-48p;
}
}
}
}
}
forwarding-options {
storm-control-profiles default {
all;
}
}
protocols {
lldp {
interface all;
}
lldp-med {
interface all;
}
igmp-snooping {
vlan default;
}
rstp {
interface ge-0/0/0;
interface ge-0/0/1;
interface ge-0/0/2;
interface ge-0/0/3;
interface ge-0/0/4;
interface ge-0/0/5;
interface ge-0/0/6;
interface ge-0/0/7;
interface ge-0/0/8;
interface ge-0/0/9;
interface ge-0/0/10;
interface ge-0/0/11;
interface ge-0/0/12;
interface ge-0/0/13;
interface ge-0/0/14;
interface ge-0/0/15;
interface ge-0/0/16;
interface ge-0/0/17;
interface ge-0/0/18;
interface ge-0/0/19;
interface ge-0/0/20;
interface ge-0/0/21;
interface ge-0/0/22;
interface ge-0/0/23;
interface ge-0/0/24;
interface ge-0/0/25;
interface ge-0/0/26;
interface ge-0/0/27;
interface ge-0/0/28;
interface ge-0/0/29;
interface ge-0/0/30;
interface ge-0/0/31;
interface ge-0/0/32;
interface ge-0/0/33;
interface ge-0/0/34;
interface ge-0/0/35;
interface ge-0/0/36;
interface ge-0/0/37;
interface ge-0/0/38;
interface ge-0/0/39;
interface ge-0/0/40;
interface ge-0/0/41;
interface ge-0/0/42;
interface ge-0/0/43;
interface ge-0/0/44;
interface ge-0/0/45;
interface ge-0/0/46;
interface ge-0/0/47;
interface ge-0/1/0;
interface xe-0/1/0;
interface ge-0/1/1;
interface xe-0/1/1;
interface ge-0/1/2;
interface xe-0/1/2;
interface ge-0/1/3;
interface xe-0/1/3;
}
}
vlans {
PC {
vlan-id 10;
l3-interface irb.10;
domain-type bridge;
}
Printer {
vlan-id 20;
l3-interface irb.20;
domain-type bridge;
}
default {
vlan-id 1;
l3-interface irb.0;
}
}
poe {
interface all;
}

12 REPLIES 12
Ethernet Switching

Re: Route VLANS

‎09-05-2019 02:00 PM

I think you are talking about irb.10 and irb.20

Are you saying from your switch, you can ping host in vlan 10 and vlan 20. But host can't ping each other?


Mengzhe Hu
JNCIE x 3 (SP DC ENT)
Ethernet Switching

Re: Route VLANS

‎09-05-2019 02:13 PM

Typo (most common mistake) in subnet masks - 172.16.77.190/26 should be /25

Ethernet Switching

Re: Route VLANS

‎09-05-2019 02:29 PM

Actually, I have connected two PC, one Vlan10 (PC1: port 1, 172.16.77.1/25-Gateway: 172.16.77.126) and another one Vlan 20 (PC2: port 2, 172.16.77.129/26-Gateway: 172.16.77.190).

I can ping 172.16.77.190 form PC1, but I can not ping 172.16.77.129 and

I can ping 172.16.77.126 from PC2, but I can not ping 172.16.77.1

I do not know what is the problem?

 

Ethernet Switching

Re: Route VLANS

‎09-05-2019 02:57 PM

Nooop, 172.16.77.190 /26 is correct. the issue is something else.


@rccpgm wrote:

Typo (most common mistake) in subnet masks - 172.16.77.190/26 should be /25


 

Ethernet Switching

Re: Route VLANS

‎09-05-2019 03:25 PM

So sorry, my bad.  Do the host/clients have the right DefGW on them?

Ethernet Switching

Re: Route VLANS

‎09-05-2019 03:45 PM

Yes, they do as I mentioned.

Ethernet Switching

Re: Route VLANS

‎09-05-2019 04:03 PM

Makes no sense.  I assume ARP and MAC tables look right, yes?  Do you know if either of the hosts receives the remote's Ping?  Looking for one-way traffic being bad for some unknown reason, . . .

 

BTW, what model switch, not that it should matter.

Ethernet Switching

Re: Route VLANS

‎09-05-2019 06:38 PM

Try this:

1. Use IP on physical interface instead of irb

2. Based on type of switch, in some we use irb for L3, in some other we use VLAN interface. Maybe switch to vlan.10 / vlan.20 ?

 


Mengzhe Hu
JNCIE x 3 (SP DC ENT)
Ethernet Switching

Re: Route VLANS

‎09-19-2019 08:53 AM

I believe the subnets defined under IRB interfaces are overlapping. Could you please change the subnets and check?

 

unit 10 {
family inet {
address 172.16.77.126/25;
}
}
unit 20 {
family inet {
address 172.16.77.190/26;
}

Ethernet Switching

Re: Route VLANS

‎09-19-2019 11:00 AM

172.16.77.126/25 does not overlap with 172.16.77.190/26.

 

172.16.77.0 - 172.16.77.127

172.16.77.128 - 172.16.77.191

Ethernet Switching

Re: Route VLANS

‎09-19-2019 11:18 AM

Are you sure you want domain-type bridge here? I don't know what that accomplishes in this context. 

 

vlans {
PC {
vlan-id 10;
l3-interface irb.10;
domain-type bridge;
}
Printer {
vlan-id 20;
l3-interface irb.20;
domain-type bridge;
}
default {
vlan-id 1;
l3-interface irb.0;
}
}
Ethernet Switching

Re: Route VLANS

‎09-19-2019 11:26 AM

@EhsanZ - this ever get resolved?  Should be very straight forward.