Ethernet Switching
Highlighted
Ethernet Switching

Set interface speed on QFX5100-48T VCF

2 weeks ago

Hello,

we have VCF with QFX5100-48T as leaf. Currently running 18.2R3-S2.9 flex."
Leaf is RJ45 10G switch. After reboot of server link stays down and autonefogiation is reported as "Incomplete". Strange is that I interface is reported as media type fiber.

Physical interface: xe-2/0/30, Enabled, Physical link is Down                                                                                                                                                                                              [126/11171]
  Interface index: 789, SNMP ifIndex: 772, Generation: 291      
  Description: description                          
  Link-level type: Ethernet, MTU: 1514, LAN-PHY mode, Link-mode: Auto, Speed: Auto, BPDU Error: None, Loop Detect PDU Error: None, Ethernet-Switching Error: None, MAC-REWRITE Error: None, Loopback: Disabled, Source filtering: Disabled, Flow control: Disabled,
  Auto-negotiation: Enabled, Remote fault: Offline, Media type: Fiber

I also can't set speed manualy there is just missing option in settings:

snajdr@srv-10g-juniper# show| compare                                                                                              
[edit interfaces xe-2/0/30 ether-options]               
-  auto-negotiation;                                       
+  no-auto-negotiation;                                                                                                            
                                                                                                                                   
{master:0}[edit interfaces xe-2/0/30]                                                                                                                                                                                                                                 
snajdr@srv-10g-juniper# commit                                                                                                     
[edit interfaces xe-2/0/30]                                                                                                        
  'ether-options'                                        
    Configure interfaces <interface-name> speed, as auto negotiation is disabled
error: configuration check-out failed                                                                                              
                                                                                                                                   
{master:0}[edit interfaces xe-2/0/30]                                                                                              
snajdr@srv-10g-juniper# set speed            
                            ^                                                                                                      
syntax error.                                        

I have speed manualy configured on some same switches which are not in VCF.

Anybody ever experienced this and resolved it?

3 REPLIES 3
Highlighted
Ethernet Switching

Betreff: Set interface speed on QFX5100-48T VCF

2 weeks ago

Hello skvedo,

 

> Strange is that I interface is reported as media type fiber.

 

Are you using QFX5e image? Then it is possible that you run into this cosmetic issue:

https://prsearch.juniper.net/InfoCenter/index?page=prcontent&id=PR1419732

 

Additionally, you should not configure "no-auto-negotiation" on QFX5100-48T devices. If you want do disable AN, then delete "auto-negotiation". Please find more details here:

https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/ten-gigabit-interfaces-q...

 

> After reboot of server link stays down and autonefogiation is reported as "Incomplete".

 

Which port types do your server have? 1G, 10G? Are the server's port settings configured to AN or do they have fixed settings?

 

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution".
If you think that my answer was helpful, please spend some Kudos.
Highlighted
Ethernet Switching

Betreff: Set interface speed on QFX5100-48T VCF

2 weeks ago

Hi Skevedo .

I hope you`re doing great.

 

Here you go, I am expecting this helps you to dort that out.

 

The correct configuration for Juniper QFX5100-48T switches to negotiate any speed possible is:
set interfaces xe-0/0/0 ether-options auto-negotiation
set interfaces xe-0/0/0 speed auto
 
If you want a server to come up at 10g/full, the correct configuration is:
set interfaces xe-0/0/0 ether-options auto-negotiation
set interfaces xe-0/0/0 speed 10g

The same works for 1G .

 

https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/ten-gigabit-interfaces-q...

 

If this solves your problem, please mark this post as "Accepted Solution" so we can help others too

Kind regards.

 

 

 

Highlighted
Ethernet Switching

Betreff: Set interface speed on QFX5100-48T VCF

Wednesday

Hello F1ght3r,

  • we are using 5e image on QFX5100 because spine switches are QFX5110.
  • server has 10G-T ports, default settings for network as said by collegue managing it. When I connected laptop (with only 1G NIC) it negotiated 1G so believe auto-negotianion is enabled on server

I have noticed when moved cable to another port on switch (default config, auto-negotiation on) link is up AN succeded. Collegue noticed that switch port goes haywire during server transition UEFI - Legacy boot. After that it looks like AN is stuck on switch for particular port (so far until switch reboot, didn't found any workaround yet). When connected laptop 1G NIC interface was up, but AN in same not success state and laptop bailed to 100M/HalfDuplex

<from show interface XYZ extensive>
  Autonegotiation information:
    Negotiation status: Incomplete

<laptop>
$ ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Speed: 100Mb/s
        Duplex: Half
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: on (auto)
Cannot get wake-on-lan settings: Operation not permitted
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes

@esmorale:
It just don't let me use any command to manual set interface speed on VCF cluster.

{master:0}[edit interfaces xe-2/0/27]
snajdr@VCF# set ether-options auto-negotiation ?
Possible completions:
  <[Enter]>            Execute this command
> 802.3ad              IEEE 802.3ad
+ apply-groups         Groups from which to inherit configuration data
+ apply-groups-except  Don't inherit configuration data from these groups
  asynchronous-notification  Enable sending asynchronous notification to peer on CCC-down
  autostate-exclude    Interface will not contribute to IRB state
> configured-flow-control  Enable flow control
> ethernet-switch-profile  Ethernet virtual LAN/media access control-level options
  flow-control         Enable flow control
  ignore-l3-incompletes  Ignore L3 incomplete errors
  loopback             Enable loopback
> mpls                 MPLS options
  no-flow-control      Don't enable flow control
  no-loopback          Don't enable loopback
  |                    Pipe through a command

{master:0}[edit interfaces xe-2/0/27]
snajdr@VCF# set sp?                                 
No valid completions

But on 2 same switches (QFX5100-48T) in VC I can set it:

{master:1}[edit interfaces]
snajdr@VC# set xe-0/0/48 speed ?
Possible completions:
  100m                 
  10g                  
  1g                   
  auto                 Enable auto negotiation of interface speed