Ethernet Switching
Ethernet Switching

There is no fan 2 in Ex-4300 ?

‎09-16-2019 06:44 AM

Hi Everyone 

 

We have two (EX-4300- 48 T) switches configured in virtual chassis . I am keep getting this alarm in the logs . 

"

chassisd[1674]: fan_mojito_speed_check fan speed failure
alarmd[1669]: Alarm set: FAN JAVA color=RED, class=CHASSIS, reason=FPC 1 Fan 2 not spinning
craftd[1668]: Major alarm set, FPC 1 Fan 2 not spinning
alarmd[1669]: Alarm cleared: FAN JAVA color=RED, class=CHASSIS, reason=FPC 1 Fan 2 not spinning
craftd[1668]: Major alarm cleared, FPC 1 Fan 2 not spinning ". 

 

but when i run this below mentioned command . i am not seeing the fan 2 .  Is this fan 2 is bulit in the management board of the switches ? why i am able to see it in the below mentioned output . Kindly help how i can resolve it ?. 

Thanks 

 

 

"

show chassis environment | match Fan
Fans FPC 0 Fan 0 OK Spinning at normal speed
FPC 0 Fan 0 Airflow OK Airflow Out (AFO)
FPC 0 Fan 1 OK Spinning at normal speed
FPC 0 Fan 1 Airflow OK Airflow Out (AFO)
FPC 1 Fan 0 OK Spinning at normal speed
FPC 1 Fan 0 Airflow OK Airflow Out (AFO)
FPC 1 Fan 1 OK Spinning at normal speed
FPC 1 Fan 1 Airflow OK Airflow Out (AFO)

"

 

7 REPLIES 7
Ethernet Switching

Re: There is no fan 2 in Ex-4300 ?

‎09-16-2019 07:58 AM

didn't find much about fan 2. Seems misleading log as there's only fan0 and fan1. Most cases ended up with chassis replacement.

I suggest to open jtac case 


@jsnow_0445 wrote:

Hi Everyone 

 

We have two (EX-4300- 48 T) switches configured in virtual chassis . I am keep getting this alarm in the logs . 

"

chassisd[1674]: fan_mojito_speed_check fan speed failure
alarmd[1669]: Alarm set: FAN JAVA color=RED, class=CHASSIS, reason=FPC 1 Fan 2 not spinning
craftd[1668]: Major alarm set, FPC 1 Fan 2 not spinning
alarmd[1669]: Alarm cleared: FAN JAVA color=RED, class=CHASSIS, reason=FPC 1 Fan 2 not spinning
craftd[1668]: Major alarm cleared, FPC 1 Fan 2 not spinning ". 

 

but when i run this below mentioned command . i am not seeing the fan 2 .  Is this fan 2 is bulit in the management board of the switches ? why i am able to see it in the below mentioned output . Kindly help how i can resolve it ?. 

Thanks 

 

 

"

show chassis environment | match Fan
Fans FPC 0 Fan 0 OK Spinning at normal speed
FPC 0 Fan 0 Airflow OK Airflow Out (AFO)
FPC 0 Fan 1 OK Spinning at normal speed
FPC 0 Fan 1 Airflow OK Airflow Out (AFO)
FPC 1 Fan 0 OK Spinning at normal speed
FPC 1 Fan 0 Airflow OK Airflow Out (AFO)
FPC 1 Fan 1 OK Spinning at normal speed
FPC 1 Fan 1 Airflow OK Airflow Out (AFO)

"

 


 


Mengzhe Hu
JNCIE x 3 (SP DC ENT)
Ethernet Switching

Re: There is no fan 2 in Ex-4300 ?

‎09-16-2019 07:58 AM

Hi,

EX4300-48T is shipped with only 2 Fantrays.

Could you paste the output of show chassis hardware ?

 

Regards

Ethernet Switching

Re: There is no fan 2 in Ex-4300 ?

‎09-16-2019 08:13 AM

Please find below mentioned outputs : 

 

 

show chassis hardware :

 

Hardware inventory:
Item Version Part number Serial number Description
Chassis xxxx Virtual Chassis
Routing Engine 0 REV 30 650-044931 xxxx EX4300-48T
Routing Engine 1 REV 30 650-044931 xxxx EX4300-48T
FPC 0 REV 30 650-044931 xxxx EX4300-48T
CPU BUILTIN BUILTIN FPC CPU
PIC 0 REV 30 BUILTIN BUILTIN 48x 10/100/1000 Base-T
PIC 1 REV 30 BUILTIN BUILTIN 4x 40GE QSFP+
Xcvr 0 REV 01 740-038624 xxxx-1 QSFP+-40G-CU1M
Xcvr 1 REV 01 740-038624 xxxx-1 QSFP+-40G-CU1M
PIC 2 REV 02 611-063980 xxxx 4x 1G/10G SFP/SFP+
Xcvr 0 REV 01 740-021308 xxxx SFP+-10G-SR
Power Supply 0 REV 02 740-046873 xxxx JPSU-350-AC-AFO-A
Power Supply 1 REV 02 740-046873 xxxx JPSU-350-AC-AFO-A
Fan Tray 0 Fan Module, Airflow Out (AFO)
Fan Tray 1 Fan Module, Airflow Out (AFO)
FPC 1 REV 30 650-044931 xxxx EX4300-48T
CPU BUILTIN BUILTIN FPC CPU
PIC 0 REV 30 BUILTIN BUILTIN 48x 10/100/1000 Base-T
PIC 1 REV 30 BUILTIN BUILTIN 4x 40GE QSFP+
Xcvr 0 REV 01 740-038624 xxxx-2 QSFP+-40G-CU1M
Xcvr 1 REV 01 740-038624 xxxx-2 QSFP+-40G-CU1M
PIC 2 REV 02 611-063980 xxxx 4x 1G/10G SFP/SFP+
Xcvr 0 REV 01 740-021308 xxxx SFP+-10G-SR
Power Supply 0 REV 02 740-046873 xxxx JPSU-350-AC-AFO-A
Power Supply 1 REV 02 740-046873 xxxx JPSU-350-AC-AFO-A
Fan Tray 0 Fan Module, Airflow Out (AFO)
Fan Tray 1 Fan Module, Airflow Out (AFO)

 

------------------------------------------------------------------------------------------------------------------------------------------

 

show version :


fpc0:
--------------------------------------------------------------------------

Model: ex4300-48t
JUNOS EX Software Suite [13.2X51-D35.3]
JUNOS FIPS mode utilities [13.2X51-D35.3]
JUNOS Online Documentation [13.2X51-D35.3]
JUNOS EX 4300 Software Suite [13.2X51-D35.3]
JUNOS Web Management [13.2X51-D35.3]
JUNOS py-base-powerpc [13.2X51-D35.3]

fpc1:
--------------------------------------------------------------------------

Model: ex4300-48t
JUNOS EX Software Suite [13.2X51-D35.3]
JUNOS FIPS mode utilities [13.2X51-D35.3]
JUNOS Online Documentation [13.2X51-D35.3]
JUNOS EX 4300 Software Suite [13.2X51-D35.3]
JUNOS Web Management [13.2X51-D35.3]
JUNOS py-base-powerpc [13.2X51-D35.3]

 

Ethernet Switching

Re: There is no fan 2 in Ex-4300 ?

‎09-16-2019 08:32 AM

Hi,

 

EX4300 just has two fan trays.

 

Just looking at the previous cases, could see issues with only "Fan 1 not spinning" and "Fan 2 not spinning" but never a log that says "Fan 0 not spinning". Looking at this, it might be that "Fan 2 not spinning" refers to issues with Fan 1 on the chassis.

 

Hence, if the frequency of such logs is very high, please reseat Fan 1 and see if the logs re-occur. If you still seem them, it is better you open a case with JTAC for further investigation.

 

Thanks,
Pradeep
Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!

Ethernet Switching

Re: There is no fan 2 in Ex-4300 ?

[ Edited ]
‎09-16-2019 09:22 AM

You won't be able to open a case with 13.2X51, that was EOL'ed over three years ago. In general, early versions of 13 have lots of issues. I would upgrade to to 14.1X53 or 17.3R3 (hitting 14.1X53 on the way) and check again, being sure to note your current config vs syntax changes under 17.

Ethernet Switching

Re: There is no fan 2 in Ex-4300 ?

‎09-16-2019 10:16 AM

@smicker wrote:

You won't be able to open a case with 13.2X51, that was EOL'ed over three years ago. In general, early versions of 13 have lots of issues. I would upgrade to to 14.1X53 or 17.3R3 (hitting 14.1X53 on the way) and check again, being sure to note your current config vs syntax changes under 17.


Agree with @smicker.  EX4300 actually not even supported for 13.2.  Suggested releases to try would be either 14.1X53-D[latest] or 18.2R3-S1.  The later is listed under Junos SR pulldown under OS.

 

Suggest you post your results.

Ethernet Switching

Re: There is no fan 2 in Ex-4300 ?

‎09-16-2019 08:56 PM

 EX-4300 is having only two Fan modules, Please refer the following Juniper hardware documentation for more details 

 https://www.juniper.net/documentation/en_US/release-independent/junos/topics/reference/general/cooli...

 The Alarm reporting on Fan-2 may be an issue on code, but you can physically check the LED of the Fan module and identify the   failed one.

 

Thanks,

Ganesan