Switching

last person joined: 16 hours ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  Two l3-interface on the same vlan

    Posted 12-12-2014 16:04

    Hi,

     

    I would like to set two l3-interface on the same vlan, something like that

    interfaces {
        vlan {
            unit 0 {
                family inet {
                    address 1.2.3.4/24;
                }
            }
            unit 1 {
                family inet {
                    address 1.2.3.1/24;
                }
            }
        }
    }
    
    vlans {
        mgmt {
            vlan-id 10;
            l3-interface vlan.0;
            l3-interface vlan.1;
        }
    }

     

    But i can't set two l3-interface (the second set ovverides the first.

     

    Is any way to do this? My idea is that vlan.0 and vlan.1 stays in two different routing-instances, vlan.0 in the default VR (that i use only for in-band management) and the other is the VR were there are all the other networks, so vlan.1 would be the default route for all the management network.

     

    Thank you for any help

     

    [edit] I have a EX4200



  • 2.  RE: Two l3-interface on the same vlan
    Best Answer

     
    Posted 12-13-2014 05:31

    You cannot do this.  I'm not sure what it is you are trying to accomplish, but from your description, you might be able to do something like this:

     

    interfaces {
    	ge-0/0/0 {
    		vlan-tagging;
    		vlan-id 10;
    		unit 0 {
    			family inet {
    				address 1.2.3.4/24;
    			}
    		}
    	}
    	ge-0/0/1 {
    		unit 0 {
    			family ethernet-switching {
    				vlan members mgmt;
    			}
    		}
    	}
    	vlan {
    		unit 0 {
    			family inet {
    				address 1.2.3.1/24;
    			}
    		}
    	}
    }
    vlans {
    	mgmt {
    		vlan-id 10;
    		l3-interface vlan.0;
    	}
    }
    routing-instances {
    	mgmt {
    		instance-type virtual-router;
    		interface ge-0/0/0.0;
    	}
    }

     But again, I'm not sure why you wouldn't just make a single interface and use that for both in-band management and as the default gateway for the management network.

     

     



  • 3.  RE: Two l3-interface on the same vlan

    Posted 12-13-2014 06:05

    Thank for your help. It looks like a workaround, but it should work.