Ethernet Switching
Ethernet Switching

connecting EX4300 VC to EX4600 non-VC

‎07-22-2016 10:40 AM

I am having an issue connecting a VC of EX4300s for a non-VC of EX4600s.  As you can see from the topology (sorry for using the wrong stencils) the 4600s are using the et-0/0/24 as a trunk port for all VLANs.  The l3-irb interfaces are defined (VRRP) on the 4600s and the stack of 4300s are only doing layer 2.

 

All others times I have done a setup like this I would use (2) 10G uplinks from each 4600 and do LACP.  I'm stuck on how to do this with a VC to non-VC.  The uplink interfaces on all these devices are setup and standard trunks running RSTP.

 

I am only using (1) 10G uplink from each 4600 going to 2 members in the VC.  When plugged into the VC, I can ping the gateway just fine, but when I unplug the uplink the 1st 4600, I lose connectivity.  Any ideas on how to troubleshoot this?

Attachments

10 REPLIES 10
Ethernet Switching

Re: connecting EX4300 VC to EX4600 non-VC

‎07-22-2016 11:05 AM

Please send the configuration of both VC switches to look further.

 

 

Thanks

Amit

Ethernet Switching

Re: connecting EX4300 VC to EX4600 non-VC

[ Edited ]
‎07-22-2016 11:38 AM

I removed some non-sense to make the configs shorter:

 

EX4600A:

 

version 14.1X53-D35.3;
system {
**REMOVED**
        }
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
    processes {
        inactive: dhcp-service {
            traceoptions {
                file dhcp_logfile size 10m;
                level all;
                flag all;
            }
        }
        app-engine-virtual-machine-management-service {
            traceoptions {
                level notice;
                flag all;
            }
        }
    }
    ntp {
**REMOVED**
    }
}
chassis {
    aggregated-devices {
        ethernet {
            device-count 249;
        }
    }
}
interfaces {
    xe-0/0/0 {
        description Area-A;
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members vlan240;
                }
            }
        }
    }
    xe-0/0/1 {
        description area-B;
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members vlan232;
                }
            }
        }
    }

    et-0/0/24 {
        description trunk-to-B-node;
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members all;
                }
            }
        }
**REMOVED**
    em1 {
        unit 0 {
            family inet {
                dhcp {
                    vendor-id Juniper-ex4600-40f;
                }
            }
        }
    }
    irb {
        unit 0 {
            family inet {
                dhcp {
                    vendor-id Juniper-ex4600-40f;
                }
            }
        }
        unit 200 {
            family inet {
                address 172.18.200.2/21 {
                    vrrp-group 200 {
                        virtual-address 172.18.200.1;
                        priority 200;
                        accept-data;
                    }
                }
            }
        }
        unit 208 {
            family inet {
                address 172.18.208.2/21 {
                    vrrp-group 208 {
                        virtual-address 172.18.208.1;
                        priority 200;
                        accept-data;
                    }
                }
            }
        }
        unit 216 {
            family inet {
                address 172.18.216.2/21 {
                    vrrp-group 216 {
                        virtual-address 172.18.216.1;
                        priority 200;
                        accept-data;
                    }
                }
            }
        }
        unit 224 {
            family inet {
                address 172.18.224.2/21 {
                    vrrp-group 224 {
                        virtual-address 172.18.224.1;
                        priority 200;
                        accept-data;
                    }
                }
            }
        }
        unit 232 {
            family inet {
                address 172.18.232.2/21 {
                    vrrp-group 232 {
                        virtual-address 172.18.232.1;
                        priority 200;
                        accept-data;
                    }
                }
            }
        }
        unit 240 {
            family inet {
                address 172.18.240.2/21 {
                    vrrp-group 240 {
                        virtual-address 172.18.240.1;
                        priority 200;
                        accept-data;
                    }
                }
            }
        }
        unit 248 {
            family inet {
                address 172.18.248.2/22 {
                    vrrp-group 248 {
                        virtual-address 172.18.248.1;
                        priority 200;
                        accept-data;
                    }
                }
            }
        }
    }
    vme {
        unit 0 {
            family inet {
                dhcp {
                    vendor-id Juniper-ex4600-40f;
                }
            }
        }
    }
}
forwarding-options {
    storm-control-profiles default {
        all;
    }
}
protocols {
    inactive: ospf {
        traceoptions {
            file OSPF-DEBUG.txt size 5m files 5;
            flag error detail;
            flag hello detail;
        }
        area 0.0.0.41 {
            interface irb.232;
            interface irb.248;
            interface irb.240;
            interface irb.224;
            interface irb.216;
            interface irb.208;
            interface irb.200;
            interface xe-0/0/22.0;
        }
    }
    lldp {
        interface all;
    }
    lldp-med {
        interface all;
    }
    igmp-snooping {
        vlan default;
    }
    rstp {
        interface xe-0/0/0;
        interface xe-0/0/1;
        interface xe-0/0/2;
        interface xe-0/0/3;
        interface xe-0/0/4;
        interface xe-0/0/5;
        interface xe-0/0/6;
        interface xe-0/0/7;
        interface xe-0/0/8;
        interface xe-0/0/9;
        interface xe-0/0/10;
        interface xe-0/0/11;
        interface xe-0/0/12;
        interface xe-0/0/13;
        interface xe-0/0/14;
        interface xe-0/0/15;
        interface xe-0/0/16;
        interface xe-0/0/17;
        interface xe-0/0/18;
        interface xe-0/0/19;
        interface xe-0/0/20;
        interface xe-0/0/21;
        interface xe-0/0/22;
        interface xe-0/0/23;
        interface et-0/0/24;
        interface xe-0/0/24:0;
        interface xe-0/0/24:1;
        interface xe-0/0/24:2;
        interface xe-0/0/24:3;
        interface et-0/0/25;
        interface xe-0/0/25:0;
        interface xe-0/0/25:1;
        interface xe-0/0/25:2;
        interface xe-0/0/25:3;
        interface et-0/0/26;
        interface xe-0/0/26:0;
        interface xe-0/0/26:1;
        interface xe-0/0/26:2;
        interface xe-0/0/26:3;
        interface et-0/0/27;
        interface xe-0/0/27:0;
        interface xe-0/0/27:1;
        interface xe-0/0/27:2;
        interface xe-0/0/27:3;
    }
}
vlans {
    default {
        vlan-id 1;
        l3-interface irb.0;
    }
    vlan200 {
        vlan-id 200;
        l3-interface irb.200;
    }
    vlan208 {
        vlan-id 208;
        l3-interface irb.208;
    }
    vlan216 {
        vlan-id 216;
        l3-interface irb.216;
    }
    vlan224 {
        vlan-id 224;
        l3-interface irb.224;
    }
    vlan232 {
        vlan-id 232;
        l3-interface irb.232;
    }
    vlan240 {
        vlan-id 240;
        l3-interface irb.240;
    }
    vlan248 {
        vlan-id 248;
        l3-interface irb.248;
    }
}

{master:0}

 

 

EX4600B:

 

version 14.1X53-D35.3;
system {
**REMOVED**
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
    processes {
        dhcp-service {
            traceoptions {
                file dhcp_logfile size 10m;
                level all;
                flag all;
            }
        }
        app-engine-virtual-machine-management-service {
            traceoptions {
                level notice;
                flag all;
            }
        }
    }
    ntp {
**REMOVED**
    }
}
chassis {
    aggregated-devices {
        ethernet {
            device-count 249;
        }
    }
}
interfaces {
    xe-0/0/0 {
        description Area-A;
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members vlan240;
                }
            }
        }
    }
    xe-0/0/1 {
        description area-B;
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members vlan232;
                }
            }
        }
    }
    xe-0/0/2 {
        description area-C1;
        unit 0 {
            family ethernet-switching {
                vlan {
                    members vlan216;
                }
            }
        }
    }
    et-0/0/24 {
        description trunk-to-A-node;
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members all;
                }
            }
        }
    }
**REMOVED**
    em1 {
        unit 0 {
            family inet {
                dhcp {
                    vendor-id Juniper-ex4600-40f;
                }
            }
        }
    }
    irb {
        unit 0 {
            family inet {
                dhcp {
                    vendor-id Juniper-ex4600-40f;
                }
            }
        }
        unit 200 {
            family inet {
                address 172.18.200.3/21 {
                    vrrp-group 200 {
                        virtual-address 172.18.200.1;
                        priority 150;
                    }
                }
            }
        }
        unit 208 {
            family inet {
                address 172.18.208.3/21 {
                    vrrp-group 208 {
                        virtual-address 172.18.208.1;
                        priority 150;
                    }
                }
            }
        }
        unit 216 {
            family inet {
                address 172.18.216.3/21 {
                    vrrp-group 216 {
                        virtual-address 172.18.216.1;
                        priority 150;
                    }
                }
            }
        }
        unit 224 {
            family inet {
                address 172.18.224.3/21 {
                    vrrp-group 224 {
                        virtual-address 172.18.224.1;
                        priority 150;
                    }
                }
            }
        }
        unit 232 {
            family inet {
                address 172.18.232.3/21 {
                    vrrp-group 232 {
                        virtual-address 172.18.232.1;
                        priority 150;
                    }
                }
            }
        }
        unit 240 {
            family inet {
                address 172.18.240.3/21 {
                    vrrp-group 240 {
                        virtual-address 172.18.240.1;
                        priority 150;
                    }
                }
            }
        }
        unit 248 {
            family inet {
                address 172.18.248.3/22 {
                    vrrp-group 248 {
                        virtual-address 172.18.248.1;
                        priority 150;
                    }
                }
            }
        }
    }
    vme {
        unit 0 {
            family inet {
                dhcp {
                    vendor-id Juniper-ex4600-40f;
                }
            }
        }
    }
}
forwarding-options {
    storm-control-profiles default {
        all;
    }
}
protocols {
    inactive: ospf {
        traceoptions {
            file OSPF-DEBUG.txt size 5m files 5;
            flag error detail;
            flag hello detail;
        }
        area 0.0.0.41 {
            interface irb.232;
            interface irb.248;
            interface irb.240;
            interface irb.224;
            interface irb.216;
            interface irb.208;
            interface irb.200;
            interface xe-0/0/22.0;
        }
    }
    lldp {
        interface all;
    }
    lldp-med {
        interface all;
    }
    igmp-snooping {
        vlan default;
    }
    rstp {
        interface xe-0/0/0;
        interface xe-0/0/1;
        interface xe-0/0/2;
        interface xe-0/0/3;
        interface xe-0/0/4;
        interface xe-0/0/5;
        interface xe-0/0/6;
        interface xe-0/0/7;
        interface xe-0/0/8;
        interface xe-0/0/9;
        interface xe-0/0/10;
        interface xe-0/0/11;
        interface xe-0/0/12;
        interface xe-0/0/13;
        interface xe-0/0/14;
        interface xe-0/0/15;
        interface xe-0/0/16;
        interface xe-0/0/17;
        interface xe-0/0/18;
        interface xe-0/0/19;
        interface xe-0/0/20;
        interface xe-0/0/21;
        interface xe-0/0/22;
        interface xe-0/0/23;
        interface et-0/0/24;
        interface xe-0/0/24:0;
        interface xe-0/0/24:1;
        interface xe-0/0/24:2;
        interface xe-0/0/24:3;
        interface et-0/0/25;
        interface xe-0/0/25:0;
        interface xe-0/0/25:1;
        interface xe-0/0/25:2;
        interface xe-0/0/25:3;
        interface et-0/0/26;
        interface xe-0/0/26:0;
        interface xe-0/0/26:1;
        interface xe-0/0/26:2;
        interface xe-0/0/26:3;
        interface et-0/0/27;
        interface xe-0/0/27:0;
        interface xe-0/0/27:1;
        interface xe-0/0/27:2;
        interface xe-0/0/27:3;
    }
}
vlans {
    default {
        vlan-id 1;
        l3-interface irb.0;
    }
    vlan200 {
        vlan-id 200;
        l3-interface irb.200;
    }
    vlan208 {
        vlan-id 208;
        l3-interface irb.208;
    }
    vlan216 {
        vlan-id 216;
        l3-interface irb.216;
    }
    vlan224 {
        vlan-id 224;
        l3-interface irb.224;
    }
    vlan232 {
        vlan-id 232;
        l3-interface irb.232;
    }
    vlan240 {
        vlan-id 240;
        l3-interface irb.240;
    }
    vlan248 {
        vlan-id 248;
        l3-interface irb.248;
    }
}
 

 

EX4300 (virtual chassis):

 

version 14.1X53-D35.3;
**REMOVED**
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
    processes {
        dhcp-service {
            traceoptions {
                file dhcp_logfile size 10m;
                level all;
                flag all;
            }
        }
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family ethernet-switching {
                interface-mode access;
                vlan {
                    members 240;
                }
                storm-control default;
            }
        }
**REMOVED**
    ge-0/0/47 {
        unit 0 {
            family ethernet-switching {
                interface-mode access;
                vlan {
                    members 240;
                }
                storm-control default;
            }
        }
    }
    xe-0/2/0 {
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members [ 7 240 ];
                }
            }
        }
    }
**REMOVED**
    xe-2/2/0 {
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members [ 7 240 ];
                }
            }
        }
    }
**REMOVED**
    ge-3/0/47 {
        unit 0 {
            family ethernet-switching {
                interface-mode access;
                vlan {
                    members 240;
                }
                storm-control default;
            }
        }
    }
    irb {
        unit 0 {
            family inet {
                dhcp {
                    vendor-id Juniper-ex4300-48p;
                }
            }
        }
    }
    vme {
        unit 0 {
            family inet {
                dhcp {
                    vendor-id Juniper-ex4300-48p;
                }
            }
        }
    }
}
forwarding-options {
    storm-control-profiles default {
        all;
    }
}
protocols {
    lldp {
        interface all;
    }
    lldp-med {
        interface all;
    }
    igmp-snooping {
        vlan default;
    }
    rstp {
        interface ge-0/0/0;
        interface ge-0/0/1;
        interface ge-0/0/2;
        interface ge-0/0/3;
        interface ge-0/0/4;
        interface ge-0/0/5;
        interface ge-0/0/6;
        interface ge-0/0/7;
        interface ge-0/0/8;
        interface ge-0/0/9;
        interface ge-0/0/10;
        interface ge-0/0/11;
        interface ge-0/0/12;
        interface ge-0/0/13;
        interface ge-0/0/14;
        interface ge-0/0/15;
        interface ge-0/0/16;
        interface ge-0/0/17;
        interface ge-0/0/18;
        interface ge-0/0/19;
        interface ge-0/0/20;
        interface ge-0/0/21;
        interface ge-0/0/22;
        interface ge-0/0/23;
        interface ge-0/0/24;
        interface ge-0/0/25;
        interface ge-0/0/26;
        interface ge-0/0/27;
        interface ge-0/0/28;
        interface ge-0/0/29;
        interface ge-0/0/30;
        interface ge-0/0/31;
        interface ge-0/0/32;
        interface ge-0/0/33;
        interface ge-0/0/34;
        interface ge-0/0/35;
        interface ge-0/0/36;
        interface ge-0/0/37;
        interface ge-0/0/38;
        interface ge-0/0/39;
        interface ge-0/0/40;
        interface ge-0/0/41;
        interface ge-0/0/42;
        interface ge-0/0/43;
        interface ge-0/0/44;
        interface ge-0/0/45;
        interface ge-0/0/46;
        interface ge-0/0/47;
        interface ge-0/2/0;
        interface xe-0/2/0;
        interface ge-0/2/1;
        interface xe-0/2/1;
        interface ge-0/2/2;
        interface xe-0/2/2;
        interface ge-0/2/3;
        interface xe-0/2/3;
        interface xe-2/2/0;
    }
}
virtual-chassis {
**REMOVED**
    }
}
vlans {
    default {
        vlan-id 1;
        l3-interface irb.0;
    }
    vlan240 {
        description pc/data;
        vlan-id 240;
    }
    vlan7 {
        description management;
        vlan-id 7;
    }
}
poe {
    interface all;
}

 

Ethernet Switching

Re: connecting EX4300 VC to EX4600 non-VC

‎07-22-2016 12:12 PM

Hi

 

I am not able to see this type of configuration (combine 2 interconnected ports to make aggregated ethernet) used for switch to switch connectivity.

 

Use your numbers instead of xxx.

 

 

 

xe-x/x/x {

        ether-options {

            802.3ad ae2;

        }

    }

    xe-x/x/x {

        ether-options {

            802.3ad ae2;

 

 

ae2 {

        description xxxxx;

        aggregated-ether-options {

            link-speed 10g;

            lacp {

                active;

                periodic fast;

            }

        }

        unit 0 {

            family ethernet-switching {

                port-mode trunk;

                vlan {

                    members [ xxx ];

 

 

 

 

Ethernet Switching

Re: connecting EX4300 VC to EX4600 non-VC

‎07-22-2016 12:37 PM

Thanks for the reply.  I have always used AE interfaces with LACP in the past, but as mentioned with dual uplinks to each physical switch.

 

Will I still need that configured on the 4300 stack AND the 4600s?

Ethernet Switching

Re: connecting EX4300 VC to EX4600 non-VC

‎07-22-2016 12:42 PM

Hello

 

I have used AE's each and every time while doing switch to switch interconnection.

 

Please try that one and let me know if working then marked as accepted solution.

 

 

Thanks

Amit

Ethernet Switching

Re: connecting EX4300 VC to EX4600 non-VC

‎07-22-2016 02:34 PM

I actually tried this intinally.  Did it again, and ae2 comes up on the 4300VC LACP shows distributing and collecting.

 

On the 4600 side, I se the "A" switch to periodic fast active, the "B" switch I did the same but ae2 never shows as up.  I tried doing periodic fast passive, but the same results.

 

So in summary, I setup ae2 on all 2 devices:

 

ae2 on 4300 VC = up @ 10G

ae2 on 4600A = up @ 10G

ae2 on 4600B = down

 

I'm still seeing the same behavior, I think it may have something to do with spanning tree priority between each 4600 since I am using et-0/0/24 as a trunk port between the two.

Ethernet Switching

Re: connecting EX4300 VC to EX4600 non-VC

[ Edited ]
‎07-22-2016 07:18 PM

Amit it is not possible to configure LACP between three physically separate switches.

SRXs, your options are either MC-LAG or just regular layer 2 STP. Make sure you configure a layer 2 link between the 4600's trunking all of your VRRPed vlans.

 

Also, assuming your diagram is correct, your vlan tags are not matching up. xe-0/0/1 on the two 4600's is trunking vlan 232 but the 4300 is trunking vlans 7 and 240 on xe-0/2/0 and xe-2/2/0.

Ethernet Switching

Re: connecting EX4300 VC to EX4600 non-VC

‎07-23-2016 05:23 AM

Could you confirm the spanning tree status of all the ports involved?  Perhaps blocking ports are working against your communication paths.

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Ethernet Switching

Re: connecting EX4300 VC to EX4600 non-VC

‎07-23-2016 02:19 PM

Hi,

 

I believe LACP [802.3ad] LAG can only be setup between 2 logical switches.

In this case, there's 3 logical switches EX4300VC, EX4600A and EX4600B.

LACP on EX4600B stays down because EX4300VC sees a different system ID other than the other LAG partner i.e EX4600A. Thus, no synchronisation flag is sent back in the LACP PDU to EX4600B.

 

MC-LAG allows for LAG over 2 different logical partners.

MC-LAG is supported as fromJunos OS 13.2X51-D25 on EX4600.

https://pathfinder.juniper.net/feature-explorer/feature-info.html?fKey=4070&fn=Multichassis+link+agg...

 

Cheers,

Ashvin

 

Ethernet Switching

Re: connecting EX4300 VC to EX4600 non-VC

‎07-26-2016 10:31 AM

I went back to a non-AE/LACP configuration.  I have done 3 logical switches with (2) 8208s and a VC of QFX5100s.  In that setup, I (2) uplinks from each switch member going to the each 8208.  This setup is different since I am using only 1 uplink.

 

Everything is working as expected now but I'm fighting a latency issue that I'm working with JTAC on.