Ethernet Switching
Highlighted
Ethernet Switching

interesting lacp / ae issue

‎09-10-2020 01:48 PM

I have a juniper ex4300 configured with a bunch of vlans on an AE interface. connected to this I have a cisco 3750 switch.

the link AE to PC is setup with LACP. On the production cisco the link never comes up. neither the pc nor the gigE interface.

The juniper shows athe AE as down but the ge-0/2/0 interface as up. I've checked the config several times and both sides match

native vlan, the vlans themselfs. the are both set to active active. nothing I can think of gets the link to come up......

 

here's the funny thing. I took a spare cisco 3750 switch with the same version ios and the config from the production cisco and put it on the spare 3750, AND IT WORKS JUST AS IT SHOULD with the Juniper. 

 

anyone have any ideas why the production switch doesn't come up?, yes I changed the optics, had the fiber tested, even moved to a different sfp slot on the production cisco 3750. still won't come up.....

 

any help appreciated

7 REPLIES 7
Highlighted
Ethernet Switching

Re: interesting lacp / ae issue

‎09-10-2020 03:02 PM

 

Hey Big,

 

I hope you are doing great, seems to be an issue with LACP, are you seeing the LACP PDU's going back and forth? are they collecting and distributing? at least one of them is in active mode? 

 

>show lacp statistic interface aex

>show lacp interface aex

 


If this solves your problem, please mark this post as "Accepted Solution" so we can help others too \:)/

Regards,

Lil Dexx
JNCIE-ENT#863, 3X JNCIP-[SP-ENT-DC], 4X JNCIA [cloud-DevOps-Junos-Design], Champions Ingenius, SSYB

Highlighted
Ethernet Switching

Re: interesting lacp / ae issue

‎09-11-2020 07:59 AM

no you don't see lacp rx packets when the juniper is connected to the production cisco. the lacp tx counter increments as it should.

 

when connected to the spare cisco 3750, which works, both counters increment

 

Highlighted
Ethernet Switching

Re: interesting lacp / ae issue

‎09-11-2020 11:43 AM

Hey Big,

 

Assuming that this information is from the CISCO perspective what the Juniper device is showing as rx and tx?

Can you share the LACP configuration from both sides ( Cisco and Juniper)

Have you tried doing some packet captures?


If this solves your problem, please mark this post as "Accepted Solution" so we can help others too \:)/

Regards,

Lil Dexx
JNCIE-ENT#863, 3X JNCIP-[SP-ENT-DC], 4X JNCIA [cloud-DevOps-Junos-Design], Champions Ingenius, SSYB

Highlighted
Ethernet Switching

Re: interesting lacp / ae issue

‎09-11-2020 02:33 PM

keep in mode the literally exact cisco config works in a different 3750


!--------------------------- cisco side ----------------------------------------
!
spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree extend system-id
!
!
!vlan internal allocation policy ascending
!
vlan 171
name guest
!
vlan 269
name vendl4
!
vlan 270
name 130.199.218.0/24
!
vlan 271
name 130.199.219.0/24
!
vlan 272
name 130.199.220.0/24
!
vlan 273
name 130.199.221.0/24
!
vlan 274
name 130.199.222.0/24
!
vlan 275
name 130.199.223.0/24
!
vlan 399
name 10.251.118.0/24
!
vlan 441
name 10.251.124.0/29
!
vlan 442
name 10.251.124.16/28
!
vlan 641
name 10.251.120.0/24
!
vlan 642
name 10.251.121.0/24
!
vlan 643
name 10.251.122.0/24
!
vlan 644
name 10.251.123.0/24
!
vlan 2404
name 10.251.252.0/24
!
vlan 2406
name 10.251.250.0/24
!
vlan 2408
name 10.251.248.0/24
!
vlan 2410
name 10.251.246.0/24
!
vlan 2412
name 10.251.244.0/24
!
vlan 2414
name 10.251.242.0/24
!
vlan 2420
name 10.251.236.0/24
!
vlan 3404
name 10.251.4.0/24
!
vlan 3406
name 10.251.6.0/24
!
vlan 3408
name 10.251.8.0/24
!
vlan 3410
name 10.251.10.0/24
!
vlan 3412
name 10.251.12.0/24
!
vlan 3414
name 10.251.14.0/24

!
interface Port-channel42
description
switchport trunk encapsulation dot1q
switchport trunk native vlan 641
switchport trunk allowed vlan 171,270-275,399,441,442,641-644,2404,2406,2408
switchport trunk allowed vlan add 2410,2412,2414,2420,3404,3406,3408,3410,3412
switchport trunk allowed vlan add 3414
switchport mode trunk
switchport nonegotiate
spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/2
description
switchport trunk encapsulation dot1q
switchport trunk native vlan 641
switchport trunk allowed vlan 171,270-275,399,441,442,641-644,2404,2406,2408
switchport trunk allowed vlan add 2410,2412,2414,2420,3404,3406,3408,3410,3412
switchport trunk allowed vlan add 3414
switchport mode trunk
switchport nonegotiate
udld port disable
no cdp enable
spanning-tree link-type point-to-point
channel-group 42 mode active
!

------------------------------- juniper side ------------------------------------------

set interfaces ge-0/2/0 description
set interfaces ge-0/2/0 ether-options 802.3ad ae0
set interfaces ae0 description
set interfaces ae0 native-vlan-id 641
set interfaces ae0 aggregated-ether-options minimum-links 1
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae0 unit 0 family ethernet-switching vlan members 171
set interfaces ae0 unit 0 family ethernet-switching vlan members 270-275
set interfaces ae0 unit 0 family ethernet-switching vlan members 399
set interfaces ae0 unit 0 family ethernet-switching vlan members 441-442
set interfaces ae0 unit 0 family ethernet-switching vlan members 641-644
set interfaces ae0 unit 0 family ethernet-switching vlan members 2404
set interfaces ae0 unit 0 family ethernet-switching vlan members 2406
set interfaces ae0 unit 0 family ethernet-switching vlan members 2408
set interfaces ae0 unit 0 family ethernet-switching vlan members 2410
set interfaces ae0 unit 0 family ethernet-switching vlan members 2412
set interfaces ae0 unit 0 family ethernet-switching vlan members 2414
set interfaces ae0 unit 0 family ethernet-switching vlan members 2420
set interfaces ae0 unit 0 family ethernet-switching vlan members 3404
set interfaces ae0 unit 0 family ethernet-switching vlan members 3406
set interfaces ae0 unit 0 family ethernet-switching vlan members 3408
set interfaces ae0 unit 0 family ethernet-switching vlan members 3410
set interfaces ae0 unit 0 family ethernet-switching vlan members 3412
set interfaces ae0 unit 0 family ethernet-switching vlan members 3414
set interfaces ae0 unit 0 family ethernet-switching recovery-timeout 60

set protocols vstp interface ae0 mode point-to-point


et protocols vstp vlan 1
set protocols vstp vlan 171
set protocols vstp vlan 2404
set protocols vstp vlan 2406
set protocols vstp vlan 2408
set protocols vstp vlan 2410
set protocols vstp vlan 2412
set protocols vstp vlan 2414
set protocols vstp vlan 2420
set protocols vstp vlan 270
set protocols vstp vlan 271
set protocols vstp vlan 272
set protocols vstp vlan 273
set protocols vstp vlan 274
set protocols vstp vlan 275
set protocols vstp vlan 3404
set protocols vstp vlan 3406
set protocols vstp vlan 3408
set protocols vstp vlan 3410
set protocols vstp vlan 3412
set protocols vstp vlan 3414
set protocols vstp vlan 399
set protocols vstp vlan 441
set protocols vstp vlan 442
set protocols vstp vlan 641
set protocols vstp vlan 642
set protocols vstp vlan 643
set protocols vstp vlan 644

 

Highlighted
Ethernet Switching

Re: interesting lacp / ae issue

3 weeks ago

Hi big,

 

Well, according to description, the troubleshooting should start from that cisco in production.

If the same configuration is working perfectly fine on ex4300-(other)cisco3750 - means something missed on production cisco.

Like maybe it gets to the ae-limit, or so.

Please debug issue on cisco-side first.

You said: "you don't see lacp rx packets when the juniper is connected to the production cisco". Where? On which device?

Will be good to have clear picture with lacp statistics outputs from both sides.

 

Thanks,

Deimos.

Highlighted
Ethernet Switching

Re: interesting lacp / ae issue

2 weeks ago

set chassis aggregated-devices ethernet device-count 10

 

did not see above command in juniper config.

ae wont come up without that. Can you check if this command is present. ( device-count no. should be greater than the highest ae bundle)

 

for example the highest ae bundle is ae10 device count should be 11.

 

If this solves your problem, please mark this post as "Accepted Solution".
If you think that my answer was helpful, please spend some Kudos.

Highlighted
Ethernet Switching

Re: interesting lacp / ae issue

a week ago

@amitrai wrote:

set chassis aggregated-devices ethernet device-count 10

 

did not see above command in juniper config.

ae wont come up without that. Can you check if this command is present. ( device-count no. should be greater than the highest ae bundle)

 

for example the highest ae bundle is ae10 device count should be 11.

 

This is not correct. device-count is a quantity, not an index. 

Feedback