Ethernet Switching
Highlighted
Ethernet Switching

interface wildcards for ethernet-switching-options

‎11-30-2010 01:01 PM

Currently have a EX4200 VC with 8 members and am using the interface-range command to set the ports as follows:

 

interface-range voice-data {
    /* all ports in switch 2 through 7 */
    member "ge-[2-7]/0/*";

 

These same ports, switch 2-7, ports 0-47 need mac-limiting set to 2, and voip set to vlan voice, in this example just port ge-3/0/0 is set.  Cannot use 'secure-access-port interface all" or "voip interface access-ports ... " because switch 0 and 1 cannot have these configurations:

 

ethernet-switching-options {
    secure-access-port {
        interface ge-3/0/0.0 {
            mac-limit 2 action drop;
        }
    }
    voip {
        interface ge-3/0/0.0 {
            vlan voice;
        }
    }

 

 

set ethernet-switching-options voip interface ge-[2-7]/0/* vlan voice, results in:

error: missing or invalid fpc number

 

jweb is not used...surely there is a easier way to do this for 288 ports, uhg...?!?

 

-Gerry

2 REPLIES 2
Highlighted
Ethernet Switching
Solution
Accepted by topic author gxc11
‎08-26-2015 01:27 AM

Re: interface wildcards for ethernet-switching-options

[ Edited ]
‎12-02-2010 01:49 PM

Try "set ethernet-switching-options voip interface voice-data"

 

You have to reference the interface-range by its name, not by the member attribute.

 

 

Doug Hanks
JNCIE-ENT #213, JNCIE-SP #875

Follow me on Twitter @douglashanksjr
Highlighted
Ethernet Switching

Re: interface wildcards for ethernet-switching-options

‎09-16-2014 05:52 AM

In my EX2200 I can not set "ethernet-switching-options" using wildcard nor interface-range. Where I can set folowing options for meny interfaces:

set ethernet-switching-options voip interface ge-1/0/0 vlan 10

set ethernet-switching-options voip interface ge-1/0/0 forwarding-class expedited-forwarding

for range from ge-1/0/0 to ge-1/0/24.

 

Feedback