Ethernet Switching
Highlighted
Ethernet Switching

qfx 5200 MC LAG configs

[ Edited ]
‎12-13-2018 01:11 PM

THes are in our lab right now, trying to set this up, however fingin conlficing info, and the MX stuff is all mixed in or its for the qfx-10K 

 

the ICCP link - sync traffic only correct ? does this have to be a 100Gb port? can it be on the em0 mgmt port ? (does it mater we have the 18.1x code and are using the mgmt routing instance?) i hate to waste 2x 100G ports for this 

 

ICL - how large does this need to be? 2x 100GB ports? 3 ports ? 

 

bestpractice on the MX says to seperate the ICL and ICCP, but on another junier configs guide, it has those on the same AE link, witch i would perfer to do but is this a supported config? 

That same guide also show the ICCP ip on a Vlan IRB interface, best practice shows a LO0 as the required interface for that. 

 

just trying to set this up properly the first time 

 

One giude I found shows the ICCP link as L3 with OSPF however all the juniper side i have found this is a L2 link, what is the recommend here? 

 

set chassis aggregated-devices ethernet device-count 6

set interfaces et-0/0/28 ether-options 802.3ad ae1
set interfaces et-0/0/29 ether-options 802.3ad ae1
set interfaces et-0/0/30 ether-options 802.3ad ae0
set interfaces et-0/0/31 ether-options 802.3ad ae0
set interfaces ae0 description ICCP-LINK
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic fast
set interfaces ae0 unit 0 family inet address 10.100.101.0/31
set interfaces ae1 description ICL-LINK-TRAFFIC
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp periodic fast
set interfaces ae1 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan members all
set interfaces em0 unit 0 family inet address 192.168.255.100/23 master-only
set interfaces irb arp-l2-validate
set interfaces lo0 unit 0 family inet address 10.100.100.1/32
set multi-chassis multi-chassis-protection 10.100.100.2 interface ae1

 

set protocols ospf area 0.0.0.0 interface ae0.0 interface-type p2p
set protocols ospf area 0.0.0.0 interface lo0.0
set protocols iccp local-ip-addr 10.100.100.1
set protocols iccp peer 10.100.100.2 session-establishment-hold-time 50
set protocols iccp peer 10.100.100.2 redundancy-group-id-list 1
set protocols iccp peer 10.100.100.2 backup-liveness-detection backup-peer-ip 192.168.255.101
set protocols iccp peer 10.100.100.2 liveness-detection minimum-interval 60
set protocols iccp peer 10.100.100.2 liveness-detection multiplier 3
set routing-instances mgmt_junos routing-options static route 0.0.0.0/0 next-hop 192.168.254.1
set switch-options service-id 1

4 REPLIES 4
Highlighted
Ethernet Switching

Re: qfx 5200 MC LAG configs

[ Edited ]
‎12-13-2018 03:15 PM

ICCP is control, ISL is data. Backup ICCP can be direct or routed, I’ve seen the same multiple recommendations. I use an IRB interface on the same ae used for ISL, with mgmt interfaces as backup ICCP to keep things simple. Size of ISL should probably be larger than maximum expected throughput of north/southbound traffic in case you end up with a Z traffic flow, but in normal active/active MCAE operation VRRP will route traffic locally and not send to VIP first. 60ms BFD on your ICCP link seems really aggressive—qfx5100 does not support BFD <1000ms, I’m not sure if QFX5200 has the same limit.

Highlighted
Ethernet Switching

Re: qfx 5200 MC LAG configs

‎12-13-2018 03:41 PM

@smicker wrote:

ICCP is control, ISL is data. Backup ICCP can be direct or routed, I’ve seen the same multiple recommendations. I use an IRB interface on the same ae used for ISL, with mgmt interfaces as backup ICCP to keep things simple. Size of ISL should probably be larger than maximum expected throughput of north/southbound traffic in case you end up with a Z traffic flow, but in normal active/active MCAE operation VRRP will route traffic locally and not send to VIP first. 60ms BFD on your ICCP link seems really aggressive—qfx5100 does not support BFD <1000ms, I’m not sure if QFX5200 has the same limit.


the 60 was just from the config guides, do you recommed like 300 ? 1000 seems like a long time lol 

 

are you running in prod with the above configs? 

Highlighted
Ethernet Switching

Re: qfx 5200 MC LAG configs

‎12-13-2018 04:37 PM

Yes. QFX10K can do BFD < 1000ms, JTAC may need to advise on 5200.

 

https://www.juniper.net/documentation/en_US/junos/topics/concept/bfd-understanding-qfx-series.html

Ethernet Switching

Re: qfx 5200 MC LAG configs

‎12-14-2018 09:17 AM

are you running your MClag in prod? 

 

ill have to open a ticket with juniper to find the 5200 limits 

Feedback