Ethernet Switching
Highlighted
Ethernet Switching

vQFX and trunk, unable to ping irb interfaces

[ Edited ]
‎11-30-2018 09:32 AM

 

 

HI,

I am unable to ping irb intrfaces on either side of the trunk. Attached is the topology and output of show commands.

Note: When i configured xe-0/0/1 as routed interface and manual set macv address to that of em4, I had IP reachibility. So, I continued with mac address of em4 on xe-0/0/1.

R1_Version.png

 

1 topology.png

 

 R1_output.png

  R2_output.png

3 REPLIES 3
Highlighted
Ethernet Switching

Re: vQFX and trunk, unable to ping irb interfaces

‎04-14-2020 05:17 PM

did you ever get this working?

Highlighted
Ethernet Switching

Re: vQFX and trunk, unable to ping irb interfaces

‎05-14-2020 04:51 AM

I tried it with the latest PFE and RE images, and everything is working as expected.

 

{master:0}[edit]
root@SW1# run show version
fpc0:
--------------------------------------------------------------------------
Hostname: SW1
Model: vqfx-10000
Junos: 19.4R1.10 limited
JUNOS Base OS boot [19.4R1.10]
JUNOS Online Documentation [19.4R1.10]
JUNOS Crypto Software Suite [19.4R1.10]
JUNOS Base OS Software Suite [19.4R1.10]
JUNOS Packet Forwarding Engine Support (qfx-10-f) [19.4R1.10]
JUNOS Kernel Software Suite [19.4R1.10]
JUNOS Routing Software Suite [19.4R1.10]
JUNOS Enterprise Software Suite [19.4R1.10]
JUNOS SDN Software Suite [19.4R1.10]
JUNOS jsd [i386-19.4R1.10-jet-1]
JUNOS Web Management [19.4R1.10]
JUNOS py-base-i386 [19.4R1.10]
JUNOS py-base2-i386 [19.4R1.10]
JUNOS py-extensions-i386 [19.4R1.10]
JUNOS py-extensions2-i386 [19.4R1.10]

 

{master:0}[edit]
root@SW1# show interfaces xe-0/0/1 | display set
set interfaces xe-0/0/1 mac 50:00:00:03:00:04
set interfaces xe-0/0/1 unit 0 family ethernet-switching interface-mode trunk
set interfaces xe-0/0/1 unit 0 family ethernet-switching vlan members vlan100

 

{master:0}[edit]
root@SW1# show interfaces irb.100 | display set
set interfaces irb unit 100 family inet address 10.0.0.1/24

 

{master:0}[edit]
root@SW1# show vlans | display set
set vlans default vlan-id 1
set vlans vlan100 vlan-id 100
set vlans vlan100 l3-interface irb.100

 

{master:0}[edit]
root@SW1# run ping 10.0.0.2 rapid
PING 10.0.0.2 (10.0.0.2): 56 data bytes
!!!!!
--- 10.0.0.2 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/stddev = 138.563/220.678/244.412/41.138 ms

 

{master:0}[edit]
root@SW1# run show arp
MAC Address Address Name Interface Flags
02:05:86:71:71:00 10.0.0.2 10.0.0.2 irb.100 [xe-0/0/1.0] none
50:00:00:08:00:01 169.254.0.1 169.254.0.1 em1.0 none
Total entries: 2

 

 

{master:0}[edit]
root@SW2# show interfaces xe-0/0/1 | display set
set interfaces xe-0/0/1 mac 50:00:00:04:00:04
set interfaces xe-0/0/1 unit 0 family ethernet-switching interface-mode trunk
set interfaces xe-0/0/1 unit 0 family ethernet-switching vlan members vlan100

 

{master:0}[edit]
root@SW2# show interfaces irb.100 | display set
set interfaces irb unit 100 family inet address 10.0.0.2/24

 

{master:0}[edit]
root@SW2# show vlans | display set
set vlans default vlan-id 1
set vlans vlan100 vlan-id 100
set vlans vlan100 l3-interface irb.100

 

{master:0}[edit]
root@SW2# run show arp
MAC Address Address Name Interface Flags
02:05:86:71:2d:00 10.0.0.1 10.0.0.1 irb.100 [xe-0/0/1.0] none
50:00:00:09:00:01 169.254.0.1 169.254.0.1 em1.0 none
Total entries: 2

_
Regards
Malik
JNCIEx4, CCIE, HCIE, VCIX-DCV, VCIX-NV, CISSP, PMP

[If it helped to solve your problem, please mark it "Accept as solution"; Kudos are always Appreciated]
Highlighted
Ethernet Switching

Re: vQFX and trunk, unable to ping irb interfaces

‎05-14-2020 11:33 AM

Hi , 

 

Did you tried to add static ARP? I guess trying the latest version will help.

 

 

Feedback