IOS to Junos (I2J) Tips
IOS to Junos (I2J) Tips

Basic RIP configuration.

[ Edited ]
‎04-29-2012 03:53 PM

 

 

   This is a very easy configuration, as rip is.

 

  Differences between IOS and JunOS on rip configuration.

 

  Under IOS have to configure major network interface, configured with network commands, so this will include every interface under major network, even if not desired. Then will have to configure passive for those extra interfaces, or filter rip routes.

 

  Under JunOS, have to configure only interfaces, so only those interfaces desired will be included in RIP, no extra filtering configuration or passive interfaces. Rip interfaces are configured with neighbor commands.

  Also have to configure the export policy that will allow the rip routes to propagate.

 

 

------------------------------------------------------------------------------------------------------------------------------  

IOS configuration

-----------------------------------------------------------------------------------------------------------------------------

 

R1

 

interface loopback 1

 ip address 10.1.1.1 255.255.255.0

 

interface gigabitethernet 0/0

 ip address 1.1.1.1 255.255.255.0

 

router rip

 no auto-summary

 network 1.0.0.0

 

R2

 

interface loopback 2 

ip address 172.31.1.1 255.255.255.0

 

interface gigabitethernet 0/0

 ip add 1.1.1.2 255.255.255.0


interface gigabitethernet 0/1

 ip add 172.16.1.2 255.255.255.0
 

router rip

 no auto-summary

 network 1.0.0.0
 network 172.16.0.0

 network 172.31.0.0

 

R3

 

interface loopback 3

 ip address 192.168.100.3 255.255.255.0

 

interface gigabitethernet 0/1

 ip add 172.16.1.3 255.255.255.0


interface gigabitethernet 0/0

 ip add 192.168.1.3 255.255.255.0
 

router rip

 network 192.168.0.0
 network 172.16.0.0

 network 192.168.100.0 

 

 

------------------------------------------------------------------------------------------------------------------------------  

JunOS configuration

-----------------------------------------------------------------------------------------------------------------------------

 

/* Export policy that will be configured in R1, R2 and R3. Will allow rip interfaces to be propagated. */


set policy-options policy-statement Export-RIP from protocol rip
set policy-options policy-statement Export-RIP from protocol direct
set policy-options policy-statement Export-RIP then accept

 

R1

 


set interfaces ge-0/0/0  unit 0 family inet address 1.1.1.1/24

set interfaces lo0  unit 1 family inet address 10.1.1.1/24


set protocols rip group R2 export Export-RIP
set protocols rip group R2 neighbor ge-0/0/0.0
set protocols rip group Loop neighbor lo0.1

 

R2

 

set interfaces lo0  unit 1 family inet address 172.31.1.1/24
set interfaces ge-0/0/0 unit 0 family inet address 1.1.1.2/24

set interfaces ge-0/0/1 unit 0 family inet address 172.16.1.2/24

set protocols rip group R1 export Export-RIP
set protocols rip group R1 neighbor ge-0/0/0.0
set protocols rip group R3 export Export-RIP
set protocols rip group R3 neighbor ge-0/0/1.1
set protocols rip group Loop neighbor lo0.1

 

R3

 

set interfaces lo0  unit 1 family inet address 192.168.100.3/24
set interfaces ge-0/0/0 unit 0 family inet address 172.16.1.3/24

set interfaces ge-0/0/1 unit 0 family inet address 192.168.1.3/24

 

set protocols rip group R2 export Export-RIP
set protocols rip group R2 neighbor ge-0/0/0.0
set protocols rip group R2 neighbor ge-0/0/1.0
set protocols rip group Loop neighbor lo0.1

 

 

--------------------------------------------------------------------------------------------

Verifications

--------------------------------------------------------------------------------------------

 

 

IOS

show ip protocols

show ip rip database

show ip route rip

 

JunOS

show route protocol rip

show route advertising-protocol rip x.x.x.x

show route received-protocol rip x.x.x.x

show rip neighbors

 

 

Br
Alex

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

If you want to say thanks, the word is Kudos!!.

Thx.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

JNCIA-JUNOS, JNCIS-ENT, JNCIS-SP, JNCIP-SP.
CCNA, CCNP, Written CCIE.