IOS to Junos (I2J) Tips
IOS to Junos (I2J) Tips

Rip parameters and metrics

[ Edited ]
‎04-30-2012 12:32 PM

 

 

      Hi.

 

      Below you could find how to configure some rip parameters. Under IOS some options are configured under interface hierarchy, others under router rip hierarchy, but at JunOS is configure under the group and neighbor hierarchy (formerly this is the interface).

 


 IOS

 

  Version 1 is broadcast, version 2 is multicast.

 

 ip rip send version 1|2

 ip rip receive version 1|2

 ip rip v2-broadcast

 

 router rip

   passive-interface

 

JunOS

 

  The none option is like the passive-interface configuration for IOS. Broadcast and multicast are v2 rip. Broadcast is the same that ios v2-broadcast.

 

 set group XXXX neighbor xxxx.y receive both|none|version-1|version-2

 set group XXXX neighbor xxxx.y send broadcast|multicast|none|version-1


 

 

 How to adjust the rip timers.

 

 IOS

 

router rip
 timers basic "update" "invalid" "holddown" "flush"

 

JunOS


 set update-interval XX route-timeout YY holddown ZZ

 

 

 

 

 

  This time some configurations about rip metric manipulation and filtering.

 

  The first consideration you must know, IOS, will propagate directly connected routes with metric 1,

but JunOS will add one hop for every interface. So a loopback will be propagated with metric 2, as

every directly connected interface, but under IOS metric will be 1.

 

  Under IOS, you must remember that for every network want to propagate have to configure a network

command. If you want to manipulate its metric, have to apply a offset-list out command, that you could

also use to manipulate other rip routes metrics. If you want to filter routes have to use a

distribute-list.

 

  Under JunOS, you have to use a export policy to propagate routes, under the then statement you could

set a metric, but also could use policy to add or substract metric to other rip routes. You will use

JunOS policy for metric manipultaion, filtering, and propagation.

 

   Under IOS you could not substrac metric from rip routes, and you cant set metrics, only could add

hops.

   If you want to set metrics under IOS, then have to use route redistribution between different

protocols.

 

  For both IOS and JunOS you could apply offset or policy to outgoing or incoming route updates on a

interface basis.

 

  Under JunOS, import policy could be applied globaly under protocol rip hierarchy, but export policy

could be applied only under rip group hierarchy. Unde IOS, you could apply a outgoing offset list of

distribute list globaly.

 

 

.- Add a metric to every received route

 

IOS

 

router rip
  offset-list any 3 in


ip access-list standard Any
 permit any

 


JunOS

 

set protocols rip metric-in 3

 

 

.- Filter outgoing or incoming routes.

IOS

 

router rip

 

  distribute-list Net10 out interface fastethernet0/0

  distribute-list Net11 in

  distribute-list Net12 out


ip access-list standard Net10
 permit 10.0.0.0 0.255.255.255

 

ip access-list standard Net11
 permit 11.0.0.0 0.255.255.255

 

ip access-list standard Net12
 permit 12.0.0.0 0.255.255.255

 


JunOS

 

set protocols rip group Fast0-0 export Net10

 

set protocols rip import Net11

 

set protocols rip group Fast0-0 export Net12
set protocols rip group Fast0-1 export Net12
set protocols rip group Fast0-2 export Net12


set policy-options policy-statement Net10 term Net10 from protocol rip
set policy-options policy-statement Net10 term Net10 from route-filter 10.0.0.0/8 orlonger
set policy-options policy-statement Net10 term Net10 then accept

 

set policy-options policy-statement Net11 term Net11 from protocol rip
set policy-options policy-statement Net11 term Net11 from route-filter 11.0.0.0/8 orlonger
set policy-options policy-statement Net11 term Net11 then accept

 

set policy-options policy-statement Net12 term Net12 from protocol rip
set policy-options policy-statement Net12 term Net12 from route-filter 12.0.0.0/8 orlonger
set policy-options policy-statement Net12 term Net12 then accept

 

 

.- Set metrics.

IOS

 

router rip

  offset-list Net10 out 3 fastethernet 0/0

  offset-list Net11 in 4
 
  offset-list Net12 out 5

  offset-list Direct out 2


ip access-list standard Net10
 permit 10.0.0.0 0.255.255.255

 

ip access-list standard Net11
 permit 11.0.0.0 0.255.255.255

 

ip access-list standard Net12
 permit 12.0.0.0 0.255.255.255


ip access-list standard Direct
 permit 13.0.0.0 0.255.255.255


 

JunOS

 

set protocols rip group Fast0-0 export Net10

 

set protocols rip import Net11

 

set protocols rip group Fast0-0 export Net12
set protocols rip group Fast0-1 export Net12
set protocols rip group Fast0-2 export Net12


set policy-options policy-statement Net10 term Net10 from protocol rip
set policy-options policy-statement Net10 term Net10 from route-filter 10.0.0.0/8 orlonger
set policy-options policy-statement Net10 term Net10 then metric add 2

 

set policy-options policy-statement Net11 term Net11 from protocol rip
set policy-options policy-statement Net11 term Net11 from route-filter 11.0.0.0/8 orlonger
set policy-options policy-statement Net10 term Net11 then metric add 3
set policy-options policy-statement Net10 term Net11 then accept


set policy-options policy-statement Net12 term Net12 from protocol rip
set policy-options policy-statement Net12 term Net12 from route-filter 12.0.0.0/8 orlonger
set policy-options policy-statement Net12 term Net12 then metric add 4
set policy-options policy-statement Net10 term Net12 then accept


set policy-options policy-statement Direct term Net13 from protocol direct
set policy-options policy-statement Direct term Net13 from route-filter 13.0.0.0/8 orlonger
set policy-options policy-statement Direct term Net13 then metric add 1
set policy-options policy-statement Direct term Net13 then accept

 

 

Br
Alex

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

If you want to say thanks, the word is Kudos!!.

Thx.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

JNCIA-JUNOS, JNCIS-ENT, JNCIS-SP, JNCIP-SP.
CCNA, CCNP, Written CCIE.