IOS to Junos (I2J) Tips
IOS to Junos (I2J) Tips

VSTP / PVST+ Spanning-Tree

‎03-30-2012 04:29 AM

Spanning-tree interoperability between Cisco Systems Catalyst switches and Juniper Networks EX switches is the cause of a LOT of frustration and heartache during upgrades or new deployments.

 

The following configuration has two switches - one IOS-based running Per-VLAN Spanning-Tree Plus (PVST+) and one Junos-based running VLAN Spanning-Tree Protocol (VSTP).  Each switch has 20 VLANs, with VLAN-IDs 20-39.  The IOS-based switch is the root bridge for VLANs 20-29, while the EX is the root bridge for VLANs 30-39.  VLAN-ID 1 is used as the native VLAN on a trunked link between the two switches (default for IOS, but manually specified for Junos:

 

Configuration (IOS):

 

spanning-tree mode rapid-pvst
spanning-tree vlan 1,20-29 priority 4096
spanning-tree vlan 30-39 priority 32768

 

interface GigabitEthernet2/0/2
description Link-to-Juniper-EX
switchport trunk encapsulation dot1q
switchport mode trunk allowed vlan 20-39

 

 

Configuration (Junos):

 

set protocols rstp

set protocols vstp vlan-group group PRIMARY-VLANS vlan 20-29

set protocols vstp vlan-group group PRIMARY-VLANS bridge-priority 4k

set protocols vstp vlan-group group SECONDARY-VLANS vlan 30-39

set protocols vstp vlan-group group SECONDARY-VLANS bridge-priority 32k

 

set interfaces ge-0/1/0 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/1/0 unit 0 family ethernet-switching vlan members 20-39
set interfaces ge-0/1/0 unit 0 family ethernet-switching native-vlan-id 1

 

Make sure you leave RSTP enabled and keep a native-vlan on your trunks when running VSTP in a PVST+ environment - IOS will send untagged RSTP BPDUs on all trunk ports, and Junos will drop them unless you specifically enable a native VLAN on the trunk.

 

Confirming operations:

 

Show the current state of spanning-tree for all VLAN instances:

show spanning-tree bridge (IOS) 

show spanning-tree bridge (Junos)

 

Show the current state of each interface configured for spanning-tree:

show spanning-tree brief (IOS)

show spanning-tree interface (Junos)

 

Ben Dale
JNCIP-ENT, JNCIP-SP, JNCIP-DC, JNCIE-SEC #63
Juniper Ambassador
Follow me @labelswitcher
2 REPLIES 2
IOS to Junos (I2J) Tips

Re: VSTP / PVST+ Spanning-Tree

‎04-03-2012 08:16 AM

 

 

  Hi Dfex.

 

   Why do you mix rstp and vstp configuration under the EX switch ?.

 

   If you want to configure the EX as root for some vlans you dont need vstp, you only have to configure rstp and give this a priority of 8k, under the cisco switches priority of 4096 to all the vlans cisco switch should be root, and 32768 to the others.

 

   This way EX will be root of all vlans where Cisco have priority 32k, and Cisco will be root of the rest.

 

    Vstp is not as fast as rstp, and mix protocols is always dangerous, convergence, problems ....

 

 

 

 

   

Br
Alex

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

If you want to say thanks, the word is Kudos!!.

Thx.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

JNCIA-JUNOS, JNCIS-ENT, JNCIS-SP, JNCIP-SP.
CCNA, CCNP, Written CCIE.
IOS to Junos (I2J) Tips

Re: VSTP / PVST+ Spanning-Tree

[ Edited ]
‎04-04-2012 12:11 AM

acecanal - VSTP will not work across an untagged link, hence the need for RSTP.

 

If you configure only RSTP on the Juniper side, and leave PVST+ on the Cisco side, fail-over times will be 30 seconds because the TCN (Topology Change Notifications) for tagged VLANs will be ignored by the RSTP root.

 

When configured correctly VSTP is just as fast* as RSTP, and unlike RSTP it works in environments where VLANs have different topologies.

 

RSTP and VSTP are designed to mix - that is how PVST+ works (which is what VSTP is designed to emulate).

 

*Unless you have hundreds of VLANs

Ben Dale
JNCIP-ENT, JNCIP-SP, JNCIP-DC, JNCIE-SEC #63
Juniper Ambassador
Follow me @labelswitcher