Junos Cup 2014
Highlighted
Junos Cup 2014

Tournament 2: Brazil Challenge & Solution: The Obscure CLI Provisioning

[ Edited ]
‎06-19-2014 07:43 AM

Country Flag: BRAZIL

 

Author:  Diogo Montagner

 

Title: The Obscure CLI Provisioning

 

Type: Automation

 

Difficulty: High (2 points).

 

Technical Description: Perform a big configuration change with just two commands.

 

16 - Brazil Image.jpg

 

 

Challenge Instructions:

For this challenge, you need to start the topology called: “BRAZIL – The Obscure CLI Provisioning”.

 

In this challenge you have to modify the configuration of the interface ge-0/0/1 with two commands that complete the following tasks:

 

-       configure "family mpls" and "family iso" under each unit

 

and

 

-       delete “family inet6” under each unit

 

To avoid confusion, this is how you submit your answer to solve this challenge:

configure private

<COMMAND>

<COMMAND>

commit and-quit

 

Restriction #1: the <COMMAND> cannot contain semicolon (Smiley Wink.

Restriction #2: the use of any variants of the load command is not allowed.

 

### Initial router configuration for interface ge-0/0/1

 

[ interfaces ge-0/0/1 ]

vlan-tagging;

unit 2 {

    vlan-id 2;

    family inet {

        address 10.1.2.1/24;

    }

    family inet6;

}

unit 4 {

    vlan-id 4;

    family inet {

        address 10.1.4.1/24;

    }

    family inet6;

}

unit 6 {

    vlan-id 6;

    family inet {

        address 10.1.6.1/24;

    }

    family inet6;

}

unit 8 {

    vlan-id 8;

    family inet {

        address 10.1.8.1/24;

    }

    family inet6;

}

 

And the final configuration for ge-0/0/1 should be exactly this:

 [ interfaces ge-0/0/1 ]

vlan-tagging;

unit 2 {

    vlan-id 2;

    family inet {

        address 10.1.2.1/24;

    }

    family iso;

    family mpls;

}

unit 4 {

    vlan-id 4;

    family inet {

        address 10.1.4.1/24;

    }

    family iso;

    family mpls;

}

unit 6 {

    vlan-id 6;

    family inet {

        address 10.1.6.1/24;

    }

    family iso;

    family mpls;

}

unit 8 {

    vlan-id 8;

    family inet {

        address 10.1.8.1/24;

    }

    family iso;

    family mpls;

}

 

To solve this challenge submit the two commands according to the parameters of the instructions.

 

NOTE: If you have issues connecting to the Junosphere topology please check Junosphere Technical documentation, or request assistance in the Junosphere forum 

 

Send an email with your proposed solution to junos-cup@juniper.net:

  •  The subject should be “<country-name-of-the-challenge> -  <your-full-name>”. For example: “Brazil – Wolfgang Amadeus Mozart”.
  • In the email body, please include your proposed solution, along with your first and last name and complete mailing address including zip/postal code and your shirt size (S, M, L, XL, XXL, XXXL) (Only if you haven’t already submitted your address/shirt size on a previous submission)

 

Deadline to Respond: Tuesday, 24th of June 23:59:59 Pacific Daylight Time (PDT)

Timezone Converter


Some additional notes:

  • You can try to solve and submit answers for as many active challenges as you wish
  • The answers will be read by the organization right after the deadline
  • The challenge instructions are final, and no additional information or tips will be provided before the publication of the solution and the winner list. Please don’t expect a reply from junos-cup@juniper.net.
  • If you feel that your initial solution is wrong or incomplete, you can send up to three messages for the same challenge, but please note that only your last message (received before the deadline) will be read.
  • If you think there is an error in the definition of the challenges, please send us an email with subject (“<country-name> ERROR”); if there is no reply, then it’s likely an intentional condition of the challenge, rather than an error.

OFFICIAL SOLUTION:

wildcard range set interfaces ge-0/0/1 unit [2,4,6,8] family [iso,mpls]

 

wildcard range delete interfaces ge-0/0/1 unit [2,4,6,8] family inet6

 

 

 

Julie Wider
Advocacy Manager
Twitter: @JNetCommunity & @jawider