Junos Space Developer
Junos Space Developer

Space database out of sync / second node won`t boot up

‎07-17-2017 05:08 AM

Hi,

 

I am running a Junos Space Cluster 15.2 R2 containing two nodes. Used Hypervisor ->VMWARE (ESXi 5.5).

 

It seems one of the hypervisors had a crash this weekend and now I have two problems:

 

First: Only one JSPACE-Node is alive. The second node (which was installed on the crahsed ESXi) doesn`t boot up and keeps hanging with this message:

 

SELinux:  Disabled at runtime.
type=1404 audit(1500290665.586:2): selinux=0 auid=4294967295 ses=4294967295

Second Problem: On the running node, the Database-Satus is "out of sync".

I don`t know if the problem will automatilcy solve after Node2 has recovered or not.

 

So I need to bring Node2 back to live, and make sure that the Database is in Sync again.

 

Your help is highly appreciated.

 

Thanks, Christoph.

 

2 REPLIES 2
Junos Space Developer
Solution
Accepted by topic author interpietz
‎07-19-2017 02:47 AM

Re: Space database out of sync / second node won`t boot up

‎07-17-2017 06:51 PM

Seems like second JSAPCE node is corrupted andy it is not able to boot up.

Since the second JSACE node is unavailable, you have out-of-sync in the primary node.

 

You have few options here.

  1. Delete the Second node from the primary node and add a new node after building a new 15.2R2 node.
  2. Build a new 2 node set up up and restore the latest backup.

I suggest you create a JTAC case and JTAC engineers can help you with this activity. I recommend JTAC as they ensure necessary precautons are taken to avoid the data loss through this process.

Ashish Paul
Junos Space Developer

Re: Space database out of sync / second node won`t boot up

‎07-19-2017 02:47 AM

Hi Paul,

 

thanks for your reply.

 

I tried both scenarions:

1) When I deleted Defctive node and tried to add a new node to the cluster, the process stucked and I was not able to form a healthy cluster.

 

2) When I tried to setup a clean fresh installation and restore a backup, I stuck in maintenenace mode (even the dialog told me the backup was uploaded successfully)

 

So I setup a complete fresh installation and inserted all hosts once again.

Just finished this tasks.

I also decided to install 16.1, seems to be more stable / performant than 15.2

 

But I think, normaly your options you have listed should resolve this issue.

 

Thanks so much for your fast reply.

Have a nice day.

 

Christoph.