Junos Space Developer
Junos Space Developer

how to compile for junos space Version 11.4P1.3

04.23.12   |  
‎04-23-2012 06:07 AM

I'm not able to deploy my application on Junos Space version 11.4P1.3, any ideas?

4 REPLIES
Highlighted
Junos Space Developer

Re: how to compile for junos space Version 11.4P1.3

04.24.12   |  
‎04-24-2012 12:19 AM

Hi,

 

What is the error thrown?Are you deploying on production server?

 

Thanks

Yesh

Junos Space Developer

Re: how to compile for junos space Version 11.4P1.3

04.24.12   |  
‎04-24-2012 03:32 AM

Hi Yesh,

thanks for your help

I'm usig SDK 11.3 and I'd like to deploy my application on Junos Space version 11.4P1.3

If I set minPlatformVersion="11.3" in my app-info.xml I'm not able to deploy the app, an error massages says:
"Current platform version does not support this software version." when I try to upload the app imeage

 

if I try to change the min platform version (by setting it to 1.4) the error is:
"Unable to deploy MYAPP image file. Cause: Installation is Failed, platform version mismatch".

 

Thanks again,

Tobia

Junos Space Developer
Solution
Accepted by topic author tobcast
‎08-26-2015 01:27 AM

Re: how to compile for junos space Version 11.4P1.3

04.24.12   |  
‎04-24-2012 03:41 AM

Hi Tobia,

 

Set minPlatformVersion="99.99" and also the rpmname should belike "JS<appname>-<appversion>-99.99" For example: "JSGoogleMashupApp-11.4-99.99".

Please remember to save app-info.xml before you retry the deploy.

 

Regards

Yesh

Junos Space Developer

Re: how to compile for junos space Version 11.4P1.3

04.24.12   |  
‎04-24-2012 06:37 AM

Hi Yesh,

this fixed my problem

thanks a lot,

Tobia