Junos
Highlighted
Junos

16x GE UPIM Switch Module Configuration

‎10-21-2008 10:31 AM
I have a J-2320 that was recently purchased by my customer with a 16 port switch module along with a T1 card.  I am having trouble with the configuration as I am relatively new to Junos.  Can anyone assist me with a configuration snippet on how to properly configure my switch ports to be in 1 VLAN and communicate accross my T1.  Any guidance will be greatly appreciated. 
Mitch Griffin
IT PITSTOP Inc.
www.itpitstopinc.com
5 REPLIES 5
Highlighted
Junos

Re: 16x GE UPIM Switch Module Configuration

‎10-21-2008 10:59 AM

First you need to tell the system that you want the 16 ports to be in switching mode:

 

chassis {

    fpc 1 {

        pic 0 {

            ethernet {

                pic-mode switching;

            }

        }

    }

 

Or "set chassis fpc 1 pic 0 ethernet pic-mode switching" replacing the "1" with which ever module slot the switch is in.

 

Once that is in you can configure the virtual interface with it's associated IP/protocols:

 

interfaces {

    ge-1/0/0 {

        description "Link to R&D LAB";

        unit 0 {

            family inet {

                address 10.10.10.10/24;

            }

        }

    }

 

Or use the associated set commands, again referencing the appropriate ge-x/0/0 for the slot you have the switching module in.

 

From there you need only setup the T1 port with it's IP's and whatever routing protocols you may want to run. 

Highlighted
Junos

Re: 16x GE UPIM Switch Module Configuration

‎10-21-2008 11:18 AM

How would I go about adding the switch module ports to vlans.  I was able to add the ports to a vlan using the member command, but I was not able to actually create the vlan.  I also do not want to have an ip address on the interface itself.  I want it to function more like a cisco layer 3 switch with an SVI. 

Mitch Griffin
IT PITSTOP Inc.
www.itpitstopinc.com
Highlighted
Junos

Re: 16x GE UPIM Switch Module Configuration

‎10-21-2008 12:42 PM

Last I checked the J-series didn't support VLAN's on the module.  All of the ports are in one broadcast domain (VLAN) and one network only.  This is the case at least up through 8.5 and from reading the release notes is still true on 9.0 and 9.1.

 

As to the IP address, once you put the module into switching mode (via the chassis command) then the ge-x/0/0 interface is the SVI like interface for the VLAN of the module.  So while it looks like you are applying the IP to just the first port, in reality it is the IP for the virtual interface of the whole module.

 

David 

 

 

Highlighted
Junos

Re: 16x GE UPIM Switch Module Configuration

[ Edited ]
‎10-21-2008 01:17 PM
So do I need an IP for every physical port that I use on the switch?  The reason that I ask is that I will be using this 2300 with a T1.  There will be approx. 5 users on the switch module. 
Message Edited by Mitch on 10-21-2008 01:17 PM
Mitch Griffin
IT PITSTOP Inc.
www.itpitstopinc.com
Highlighted
Junos

Re: 16x GE UPIM Switch Module Configuration

‎10-21-2008 02:59 PM

No, you do not need a IP for each physical port.  Once you use the "set chassis fpc x pic 0 ethernet pic-mode switching" command, all of the ports on the module will be in one broadcast domain (one network).  With that set, all you have do is apply a IP address to the module via the ge-x/0/0 interface which is now the SVI for the whole module (and not the first physical port).

 

David 

Feedback