Junos OS

last person joined: 4 days ago 

Ask questions and share experiences about Junos OS.
  • 1.  CE and PE not receiving route from each other

    Posted 10-04-2016 11:08

    I'm trying to set up l3vpn connection between two site with MPLS as core. I'm not seeing any route learned by CE1 router from PE1 and vice versa. Please help me to identify what i'm doing wrong. 

    CE1 config.

    interfaces {
    ge-0/0/1 {
    unit 0 {
    family inet {
    address 192.168.1.2/30;
    }
    }
    }
    lo0 {
    unit 0 {
    family inet {
    address 1.1.1.1/32;
    }
    }
    }
    }
    routing-options {
    static {
    route 192.168.1.1/32 next-hop 192.168.1.2;
    route 0.0.0.0/0 next-hop 192.168.1.2;
    }
    router-id 1.1.1.1;
    autonomous-system 65160;
    }
    protocols {
    bgp {
    group EBGP {
    type external;
    traceoptions {
    file bgp-log size 10k files 2;
    flag all;
    }
    export DEFAULT;
    peer-as 100;
    neighbor 192.168.1.1;
    }
    }
    }
    policy-options {
    policy-statement DEFAULT {
    term 1 {
    from {
    protocol static;
    route-filter 0.0.0.0/0 exact;
    }
    then accept;
    }
    term 2 {
    then reject;
    }
    }
    policy-statement EXPORT-CONNECTED {
    term 1 {
    from protocol direct;
    then accept;
    }
    }

     

    PE1 config.

    interfaces {
    ge-0/0/2 {
    unit 0 {
    family inet {
    address 192.168.1.1/30;
    }
    }
    }
    ge-0/0/3 {
    unit 0 {
    family inet {
    address 172.16.10.5/24;
    }
    family mpls;
    }
    }
    ge-0/0/4 {
    unit 0 {
    family inet {
    address 172.16.10.3/24;
    }
    family mpls;
    }
    }
    lo0 {
    unit 0 {
    family inet {
    address 10.10.10.10/32;
    }
    }
    }
    }
    routing-options {
    router-id 10.10.10.10;
    autonomous-system 100;
    }
    protocols {
    mpls {
    interface ge-0/0/3.0;
    interface ge-0/0/4.0;
    }
    bgp {
    group IBGP {
    type internal;
    local-address 10.10.10.10;
    family inet-vpn {
    any;
    }
    neighbor 20.20.20.20;
    }
    }
    ospf {
    area 0.0.0.0 {
    interface ge-0/0/3.0;
    interface ge-0/0/4.0;
    interface lo0.0;
    }
    }
    ldp {
    interface ge-0/0/3.0;
    interface ge-0/0/4.0;
    }
    }
    routing-instances {
    CUST-A {
    instance-type vrf;
    interface ge-0/0/2.0;
    route-distinguisher 10.10.10.10:16;
    vrf-target target:100:16;
    protocols {
    bgp {
    group EBGP {
    type external;
    traceoptions {
    file bgp-log size 10k files 2;
    flag all;
    }
    peer-as 65160;
    neighbor 192.168.1.2;
    }
    }
    }
    }
    }

     

    Output on CE1

    root@VJXT1# run show route table inet.0 protocol bgp

    inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)

     

    root@VJXT1# run show route receive-protocol bgp 192.168.1.1

    inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)

     

    root@VJXT1# run show route

    inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both

    1.1.1.1/32 *[Direct/0] 12:34:57
    > via lo0.0
    10.233.240.0/20 *[Direct/0] 12:19:09
    > via ge-0/0/0.0
    10.233.248.84/32 *[Local/0] 12:19:09
    Local via ge-0/0/0.0
    192.168.1.0/30 *[Direct/0] 12:52:49
    > via ge-0/0/1.0
    192.168.1.2/32 *[Local/0] 12:52:49
    Local via ge-0/0/1.0

     

    root@VJXT1# run show route advertising-protocol bgp 192.168.1.11

    [edit]
    root@VJXT1#

     

    Output at PE1

    root@VJXT0# run show bgp summary instance CUST-A
    Groups: 1 Peers: 1 Down peers: 0
    Table Tot Paths Act Paths Suppressed History Damp State Pending
    CUST-A.inet.0
    0 0 0 0 0 0
    CUST-A.mdt.0
    0 0 0 0 0 0
    Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
    192.168.1.2 65160 1717 1704 0 0 12:49:27 Establ
    CUST-A.inet.0: 0/0/0/0

     

    root@VJXT0# run show route advertising-protocol bgp 192.168.1.2

    [edit]
    root@VJXT0#

     

    root@VJXT0# run show route receive-protocol bgp 192.168.1.2

    inet.0: 13 destinations, 14 routes (13 active, 0 holddown, 0 hidden)

    inet.3: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)

    CUST-A.inet.0: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)

    mpls.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)

    [edit]
    root@VJXT0#

     

    Any help would be highly appriciated.



  • 2.  RE: CE and PE not receiving route from each other
    Best Answer

    Posted 10-04-2016 11:23

    Hello,

    Your 0/0 route on CE1 is not valid as it points to self:

    CE1 config.
    interfaces {
    ge-0/0/1 {
    unit 0 {
    family inet {
    address 192.168.1.2/30;

    and

     

    route 0.0.0.0/0 next-hop 192.168.1.2;

    Please do on CE1:

     

    delete routing-options static route 0/0
    set routing-options static route 0/0 reject

    You can still ping along this 0/0 route, the only difference is You will get "Dest Unreach" instead of Echo Reply.

    Then collect following printouts and report back:

     

    on CE1:
    show route advertising-protocol bgp 192.168.1.1
    on PE1:
    show route receive-protocol bgp 192.168.1.2

    HTH

    Thx

    Alex



  • 3.  RE: CE and PE not receiving route from each other

    Posted 10-04-2016 11:56

    Thanks !! That works. Appreciate your help.



  • 4.  RE: CE and PE not receiving route from each other

     
    Posted 10-04-2016 11:29

    Hi,

     

    On the CE the default route is not present and hence as per export policy DEFAULT, no routes being announced to PE.

    You could add the static route as a discard to test:

    set routing-options static route 0.0.0.0/0 discard

    Are there any inet-vpn BGP routes in the vrf on PE1? Could you check on PE:

    show route table CUST-A.inet.0 protocol bgp

    Cheers,

    Ashvin

     



  • 5.  RE: CE and PE not receiving route from each other

    Posted 10-04-2016 11:57

    Thanks !! That works. Appreciate your help.

     

    root@VJXT0# run show route table CUST-A.inet.0 protocol bgp

    CUST-A.inet.0: 4 destinations, 5 routes (4 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both

    0.0.0.0/0 *[BGP/170] 00:06:55, localpref 100
    AS path: 65160 I, validation-state: unverified
    > to 192.168.1.2 via ge-0/0/2.0
    [BGP/170] 00:02:08, localpref 100, from 20.20.20.20
    AS path: 65161 I, validation-state: unverified
    > to 172.16.10.55 via ge-0/0/3.0, Push 299840, Push 299808(top)
    to 172.16.10.33 via ge-0/0/4.0, Push 299840, Push 299776(top)
    192.168.2.0/30 *[BGP/170] 00:02:08, localpref 100, from 20.20.20.20
    AS path: I, validation-state: unverified
    to 172.16.10.55 via ge-0/0/3.0, Push 299840, Push 299808(top)
    > to 172.16.10.33 via ge-0/0/4.0, Push 299840, Push 299776(top)