Junos
Highlighted
Junos

Chassis network-services issue

[ Edited ]
3 weeks ago

Hi all,

 

I have already found the solution for this issue but it is not working for me. So, I am configuring up some VRFs that require a physical interface interaction rather than the loopback and stumled on this issue when trying to commit:

 

RT Instance: Only loopback interface is supported under vrf routing instances in triton mode.

 

The resolution on these boards is at this location:

 

https://forums.juniper.net/t5/Routing/Commit-fails-when-creating-VRF-on-MX-Only-loopback-interface-i...

 

When running the command "show chassis network-services" I do get the following results:

 

Network Services Mode: Enhanced-Ethernet

 

So, I enter the command "set chassis network-service enhanced-ip", so, this should allow the ge interface to be utilised in the vrf, but I am still getting the same error and that is because the chassis thinks it is still in "enhanced-ethernet" mode.

 

So, given that I have completed what was recommended before, anyone got any ideas or at least how I can remove the "enhanced-ethernet" from the Network Services Mode so that it is enhanced-ip instead?

 

I am running version: 18.2R1.9 on the eve-ng virtualisation and it is an MX.

 

Thanks

4 REPLIES 4
Highlighted
Junos

Re: Chassis network-services issue

3 weeks ago

Hi 

 

Have you rebooted the device after configuring "set chassis network-service enhanced-ip" ?

Because for this configuration to take effect device needs to be rebooted.

 

https://kb.juniper.net/InfoCenter/index?page=content&id=KB26392

 

https://www.juniper.net/documentation/en_US/junos/topics/topic-map/chassis-guide-tm-config-ntwrk-srv...

 

 

If this solves your problem, please mark this post as "Accepted Solution" so we can help others too

 

Kudos are appreciated too 

 

 

Regards,

Nadeem

Highlighted
Junos

Re: Chassis network-services issue

[ Edited ]
3 weeks ago

Hi Nadeem,

 

Apologies, I forgot to mention that, yes, I have rebooted with no difference.

 

My understanding is that with vMX you need to have a license installed for this, but did not think this was applicable in the eve-ng virtualisation as we are utilising an actual Junos OS.

 

I will check the eve-ng site and see if there is anything there, but this is a problem otherwise.

Highlighted
Junos
Solution
Accepted by topic author adgwytc
3 weeks ago

Re: Chassis network-services issue

[ Edited ]
3 weeks ago

You may load a trial licence. Grab the trial license from here 

https://www.juniper.net/us/en/dm/free-vmx-trial/E421992502.txt

 

_
Regards
Malik
JNCIEx4, CCIE, HCIE, VCIX-DCV, VCIX-NV, CISSP, PMP

[If it helped to solve your problem, please mark it "Accept as solution"; Kudos are always Appreciated]
Highlighted
Junos

Re: Chassis network-services issue

3 weeks ago

Hi Malik,

 

Bingo. Just needed the right license. Awesome. Thanks