Junos
Junos

CoS / ToS on SI interface

‎06-28-2018 08:04 AM

To apply the classifiers (Firewall rules) I have written to an interface for subscribers (PPP), can I configure the following:

 

set dynamic-profiles (name) class-of-service interfaces si-1/0/0 unit 0 family inet filter input (filter name)

 

And then the following:

 

set dynamic-profiles (name) class-of-service interfaces $junos-interface-ifd-name unit $junos-interface-unit output-traffic-control-profile (profile-name)

 

Is this the way to do this please?

 

4 REPLIES 4
Junos

Re: CoS / ToS on SI interface

‎06-28-2018 08:31 AM

Hi Clive,

 

Not sure what exactly you're doing.

 

For CoS, you can configure below statements under the DP.

 

set dynamic-profiles l2tp-test class-of-service traffic-control-profiles tcp scheduler-map test
set dynamic-profiles l2tp-test class-of-service traffic-control-profiles tcp shaping-rate 24m
set dynamic-profiles l2tp-test class-of-service interfaces "$junos-interface-ifd-name" unit "$junos-interface-unit" output-traffic-control-profile tcp
set dynamic-profiles l2tp-test class-of-service interfaces "$junos-interface-ifd-name" unit "$junos-interface-unit" classifiers dscp test-dscp
set dynamic-profiles l2tp-test class-of-service interfaces "$junos-interface-ifd-name" unit "$junos-interface-unit" rewrite-rules ieee-802.1 test-1p
set dynamic-profiles l2tp-test class-of-service interfaces "$junos-interface-ifd-name" unit "$junos-interface-unit" rewrite-rules ieee-802.1 vlan-tag outer-and-inner

Junos

Re: CoS / ToS on SI interface

‎06-28-2018 08:41 AM

Hi Rahul,

 

I am in the late stages of testing in live environment now. I have configured CoS for Voice (SIP and RTP) on the core routers with no problems at all. I have tested throroughly and it works perfectly. 

Now I am onto the LNS which requires Heirarchical CoS for the subscriber interface. So, basically, I have the following configured already:

 

set class-of-service drop-profiles low-drop fill-level 95 drop-probability 0
set class-of-service drop-profiles low-drop fill-level 100 drop-probability 100
set class-of-service drop-profiles med-drop fill-level 75 drop-probability 0
set class-of-service drop-profiles med-drop fill-level 95 drop-probability 30
set class-of-service drop-profiles high-drop fill-level 50 drop-probability 0
set class-of-service drop-profiles high-drop fill-level 95 drop-probability 50
set class-of-service forwarding-classes queue 2 SIP-VOICE
set class-of-service interfaces ae1 scheduler-map normal
set class-of-service scheduler-maps normal forwarding-class best-effort scheduler be
set class-of-service scheduler-maps normal forwarding-class expedited-forwarding scheduler ef
set class-of-service scheduler-maps normal forwarding-class SIP-VOICE scheduler sv
set class-of-service scheduler-maps normal forwarding-class network-control scheduler nc
set class-of-service schedulers be transmit-rate percent 65
set class-of-service schedulers be buffer-size percent 65
set class-of-service schedulers be priority medium-low
set class-of-service schedulers be drop-profile-map loss-priority high protocol any drop-profile high-drop
set class-of-service schedulers be drop-profile-map loss-priority medium-high protocol any drop-profile med-drop
set class-of-service schedulers be drop-profile-map loss-priority medium-low protocol any drop-profile med-drop
set class-of-service schedulers be drop-profile-map loss-priority low protocol any drop-profile low-drop
set class-of-service schedulers nc transmit-rate percent 5
set class-of-service schedulers nc buffer-size percent 5
set class-of-service schedulers nc priority medium-high
set class-of-service schedulers nc drop-profile-map loss-priority high protocol any drop-profile high-drop
set class-of-service schedulers nc drop-profile-map loss-priority medium-high protocol any drop-profile med-drop
set class-of-service schedulers nc drop-profile-map loss-priority medium-low protocol any drop-profile med-drop
set class-of-service schedulers nc drop-profile-map loss-priority low protocol any drop-profile low-drop
set class-of-service schedulers ef transmit-rate 5k
set class-of-service schedulers ef transmit-rate exact
set class-of-service schedulers ef buffer-size temporal 1
set class-of-service schedulers ef priority low
set class-of-service schedulers ef drop-profile-map loss-priority high protocol any drop-profile high-drop
set class-of-service schedulers ef drop-profile-map loss-priority medium-high protocol any drop-profile med-drop
set class-of-service schedulers ef drop-profile-map loss-priority medium-low protocol any drop-profile med-drop
set class-of-service schedulers ef drop-profile-map loss-priority low protocol any drop-profile low-drop
set class-of-service schedulers sv transmit-rate percent 30
set class-of-service schedulers sv buffer-size percent 30
set class-of-service schedulers sv priority high
set class-of-service schedulers sv drop-profile-map loss-priority high protocol any drop-profile high-drop
set class-of-service schedulers sv drop-profile-map loss-priority medium-high protocol any drop-profile med-drop
set class-of-service schedulers sv drop-profile-map loss-priority medium-low protocol any drop-profile med-drop
set class-of-service schedulers sv drop-profile-map loss-priority low protocol any drop-profile low-drop

 

set interfaces ae1 unit 0 family inet filter input cos1

 

set firewall filter cos term 1 from dscp 46
set firewall filter cos term 1 from dscp 26
set firewall filter cos term 1 then forwarding-class SIP-VOICE
set firewall filter cos term 1 then accept
set firewall filter cos term 2 then forwarding-class best-effort
set firewall filter cos term 2 then accept
set firewall filter cos1 term 1 from dscp 46
set firewall filter cos1 term 1 from dscp 26
set firewall filter cos1 term 1 then forwarding-class SIP-VOICE
set firewall filter cos1 term 1 then accept
set firewall filter cos1 term 4 from source-address x.x.x.x/32
set firewall filter cos1 term 4 from source-address x.x.x.x/32
set firewall filter cos1 term 4 from source-address x.x.x.x/32
set firewall filter cos1 term 4 from source-address x.x.x.x/32
set firewall filter cos1 term 4 from source-address x.x.x.x/32
set firewall filter cos1 term 4 then forwarding-class SIP-VOICE
set firewall filter cos1 term 4 then accept
set firewall filter cos1 term 2 then forwarding-class best-effort
set firewall filter cos1 term 2 then accept

 

And I need to know where to apply these settings on the LNS to LAC Subscriber side (SI interface)

 

Good to see you back Smiley Happy

Junos

Re: CoS / ToS on SI interface

‎06-29-2018 05:17 AM

So, I have followed all the recommended Juniper documentation and also Rahuls brilliant recommendation, and, unfortunately, none of them work.

 

If I have the following as ingress and egress:

 

si-1/0/0 (Subscriber ingress dynamic) ---- ae1 (Egress to core router)

 

set class-of-service classifiers dscp sip-voice forwarding-class SIP-VOICE loss-priority low code-points 101110
set class-of-service classifiers dscp sip-voice forwarding-class SIP-VOICE loss-priority low code-points 011010
set class-of-service classifiers dscp sip-voice forwarding-class SIP-VOICE loss-priority high code-points 101111

 

set class-of-service scheduler-maps normal forwarding-class best-effort scheduler be
set class-of-service scheduler-maps normal forwarding-class expedited-forwarding scheduler ef
set class-of-service scheduler-maps normal forwarding-class SIP-VOICE scheduler sv
set class-of-service scheduler-maps normal forwarding-class network-control scheduler nc

 

set class-of-service interfaces ae1 scheduler-map normal   ---- egress for scheduler-map

 

set dynamic-profiles dyn-lns-profile class-of-service traffic-control-profiles tcp scheduler-map normal
set dynamic-profiles dyn-lns-profile class-of-service traffic-control-profiles tcp shaping-rate 24m
set dynamic-profiles dyn-lns-profile class-of-service interfaces "$junos-interface-ifd-name" unit "$junos-interface-unit" output-traffic-control-profile tcp
set dynamic-profiles dyn-lns-profile class-of-service interfaces "$junos-interface-ifd-name" unit "$junos-interface-unit" classifiers dscp sip-voice

 

The above is for the subscriber ingress interface as it is the classifier:

 

This configuration does not work. I view the queues, after making a voip call, on the egress interface ae1 and see NO traffic in the SIP-VOICE queue.

 

None of the documentation seems to work.

 

Help please

 

Thanks

 

Junos
Solution
Accepted by topic author adgwytc
‎06-29-2018 08:02 AM

Re: CoS / ToS on SI interface

[ Edited ]
‎06-29-2018 08:02 AM

I have resolved the issue.

 

For those that don't know, and cannot find it anywhere in the Juniper documentation, as I couldn't, here is how I resolved the issue:

 

set chassis fpc slot (number) flexible-queuing-mode

 

Restart the fpc (You will lose connecitvity so be careful)

 

It all now works end-to-end