Junos
Highlighted
Junos

DHCP Relay problem with Juniper MX running 13.3R6.5

‎02-24-2016 04:00 AM

 

Dear Guys,

 

I have a problem with MX40 dhcp relay over VRF.  DHCP server located at the remote site.

 

DHCP relay status showing in SELECTING state and PC didnt get ip addr.

 

elchin@CAMP-MX#run show dhcp relay binding routing-instance BBB detail

 

Client IP Address: 0.0.0.0
Hardware Address: 1c:75:08:35:6c:06
State: SELECTING(RELAY_STATE_SELECTING)
Lease Expires: unknown
Lease Expires in: 0 seconds
Lease Start: unknown
Last Packet Received: 2016-02-24 15:47:50 AZT
Incoming Client Interface: ge-1/1/1.613(irb.613)
Server Ip Address: 0.0.0.0
Server Interface: none
Bootp Relay Address: 10.11.50.1
Session Id: 19 

 

Here is the configuration:

 

Interface conf:

 

elchin@CAMP-MX#show interfaces ge-1/1/1
description BBB;
vlan-tagging;
encapsulation flexible-ethernet-services;
unit 111 {
encapsulation vlan-vpls;
vlan-id 111;
}
unit 613 {
description CAMP1;
encapsulation vlan-bridge;
vlan-id 613;
family bridge;
}

[edit]

 

elchin@CAMP-MX# show interfaces irb
unit 613 {
family inet {
address 10.10.50.1/24;
address 10.11.50.1/24;
address 10.16.50.1/24;
}

Bridge domain conf: 

 

elchin@CAMP-MX# show bridge-domains
VLAN613 {
domain-type bridge;
vlan-id 613;
interface ge-1/1/1.613;
routing-interface irb.613;

 

VRF conf:

 

elchin@CAMP-MX# show routing-instances BBB
instance-type vrf;
system {
services {
dhcp-local-server {
group default-group {
interface lsi.0 {
upto lsi.16385;
}
}
}
}
}
interface irb.613;
route-distinguisher 65100:22;
vrf-target target:65100:22;
vrf-table-label;
routing-options {
router-id 10.10.30.8;
}
forwarding-options {
dhcp-relay {
server-group {
SRV {
10.10.7.2;
}
}
active-server-group SRV;
group all {
active-server-group SRV;
interface irb.613;
}
}
}

 

 Thanks in advance.

2 REPLIES 2
Highlighted
Junos
Solution
Accepted by topic author elcinhuseyn
‎03-09-2016 08:55 PM

Re: DHCP Relay problem with Juniper MX running 13.3R6.5

‎03-09-2016 08:55 PM

Thanks for help. Problem is solved.

Highlighted
Junos

Re: DHCP Relay problem with Juniper MX running 13.3R6.5

‎12-01-2018 11:45 AM

What was the solution to the problem, we are having a similar problem. 

Feedback