Junos
Highlighted
Junos

DHCP issue with avaya phones

a month ago

Avaya phone can't get an ip from pool created on the Aggregation switch it is directly connected to access switch and when I show lldp on the access switch I see the Avaya phone assigned an ip for it  although the phone doesn't take the ip address from the DHCP Server need assistance from the configuration to be reviewed from the access switch and aggregation switch 

DHCP pool for voice vlan 

--------------------------------------------------------------------------------------

Aggregation Switch 

set system services dhcp-local-server group g80 interface irb.1280

set interfaces irb unit 1280 family inet address 10.112.80.254/24

set access address-assignment pool p80 family inet network 10.112.80.0/24
set access address-assignment pool p80 family inet range r1 low 10.112.80.2
set access address-assignment pool p80 family inet range r1 high 10.112.80.253
set access address-assignment pool p80 family inet dhcp-attributes maximum-lease-time 2419200
set access address-assignment pool p80 family inet dhcp-attributes router 10.112.80.254

set vlans traditionalvoiceuser1280 vlan-id 1280

------------------------------------------------------------------------------------------------------------

Accsess switch 

set interfaces interface-range SCOPE member-range ge-0/0/0 to ge-0/0/24
set interfaces interface-range SCOPE unit 0 family ethernet-switching port-mode access
set interfaces interface-range SCOPE unit 0 family ethernet-switching vlan members traditionaluser1201

set protocols lldp interface all
set protocols lldp-med interface all
set ethernet-switching-options voip interface SCOPE vlan traditionalvoiceuser1280

set vlans traditionalvoiceuser1280 vlan-id 1280

set poe interface all

---------------------------------------------------------------------------------------------------

 

 

2 REPLIES 2
Highlighted
Junos

Re: DHCP issue with avaya phones

2 weeks ago
Hello Abdel,
Greetings!
I have checked the configuration and the configuration looks good. Please check the below and see if it helps. Since you are seeing an IP address in the LLDP info, it would mean that the IP address is being offered by the switch.
1. Are you getting the IP address in the range configured on the aggregation switch?
2. Have you tried re-setting the Avaya phone?
3. What model of Aggregation/access layer switch are you using and what version?
 
Thanks,
Vishaal

Regards,
Vishaal


Accept as Solution = cool ! (Help fellow community members with similar query be redirected here instead of them reposting again)
Accept as Solution+Kudo = You are a Star !
Highlighted
Junos

Re: DHCP issue with avaya phones

2 weeks ago

Hi Abdelmageed,

 

I would suggest a packet capture on the access switch on one of the ports facing an Avaya phone.  I have seen situations where the the address is assigned, but the end device send a release packet rejecting the IP address.  I am not saying this is the situation, but is just an idea for further troubleshooting.

 

Regards,

 

Randall