Junos
Highlighted
Junos

Diferents VLANs with the same layer 3 interface

‎10-30-2018 07:18 AM

Hello,

we have a MX960 router and the following doubt:
We have an Interface (2*10G, ae0 link agregation) with interconexion from other operator from whom we are using their access network infrastructure to give service to subscribers (type GPON/DSL). These subscribers are using IPoE (DHCP) and NOT PPPoE.
we get 1 802.1Q VLAN for each location, in total about 50 VLANs. These VLANs need to use the same Layer 3 interface, as we do not want to segment our public IP address space, but rather use the address space /21 as 1 pool. BUT as using IPoE we also need to separate the broadcast space, so that broadcast like ARP and others from 1 VLAN are NOT propagated to the other VLANs.

Can you please indicate hoy this can be done on the MX960?

Thank you

3 REPLIES 3
Highlighted
Junos

Re: Diferents VLANs with the same layer 3 interface

[ Edited ]
‎10-31-2018 01:01 AM

Hello JGalindo

 

The aggregate interface allows vlan-id tagging. You can create logical interfaces under the aggregate interface and tag each logical interface with its own vlan.

 

Another option is to use "vlan-id-list" and "vlan-id-range" on a single logical interface to associate multiple vlans on the same logical interface

 

Regards

P.S.I. Basondole 

Highlighted
Junos
Solution
Accepted by topic author JGALINDO
‎12-04-2018 06:23 AM

Re: Diferents VLANs with the same layer 3 interface

‎10-31-2018 02:39 AM

Hello.

As i understood you need to use something like that:

 

 show interfaces lo0 unit 0
family inet {
    address 10.10.10.1/32;
}
show interfaces ae2.4083

description "Access interface"; proxy-arp unrestricted; vlan-id 4083; family inet { mtu 1500; unnumbered-address lo0.0; }
show routing-options static

    route 10.10.10.2/32 {
        qualified-next-hop ae2.4083;
    }

 

If you need broadcast go to other interface than you must enable proxy-arp.

Highlighted
Junos

Re: Diferents VLANs with the same layer 3 interface

‎12-04-2018 06:25 AM

Thanks for yours answers.

 

At the begining, I had some problems but it was solved changing the switch.

 

 

Feedback