Junos
Junos

EX-3400 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg error logs

‎07-23-2019 07:54 AM

I have a problem. My device is EX-3400. What is the cause and What is the solutiuns? does anyone know this?

admin@172.18.0.1_NAME> show log messages
Jan 1 02:45:00 newsyslog[11822]: logfile turned over due to size>1024K
Jan 1 02:45:05 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:45:05 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:45:09 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:45:09 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:45:17 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:45:17 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:45:24 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:45:24 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:45:28 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:45:28 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:45:36 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:45:36 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:45:42 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:45:42 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:45:46 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:45:46 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:45:54 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:45:54 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:46:00 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:46:00 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:46:04 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:46:04 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:46:12 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:46:12 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:46:18 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:46:18 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:46:22 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:46:22 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:46:30 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:46:30 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:46:36 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:46:36 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:46:40 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:46:40 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:46:48 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:46:48 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:46:55 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:46:55 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:46:59 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:46:59 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:47:07 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:47:07 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:47:13 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:47:13 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:47:17 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:47:17 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:47:25 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:47:25 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:47:31 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:47:31 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:47:35 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:47:35 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:47:43 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:47:43 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:47:49 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:47:49 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:47:53 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
Jan 1 02:47:53 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 5 and routing instance default failed: Network is down
Jan 1 02:48:01 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg() from 0.0.0.0 to port 67 at 255.255.255.255 via interface 546 and routing instance default failed: Network is down
---(more 2%)---

Attachments

8 REPLIES 8
Junos

Re: EX-3400 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg error logs

‎07-23-2019 08:04 AM

Hi Emre,

 

Please refer the following KB which explains these logs.

https://kb.juniper.net/InfoCenter/index?page=content&id=KB31838

 

Solution is to remove the DHCP configurations on unwanted ports :

Example
vme {
unit 0 {
family inet {
dhcp {
vendor-id Juniper-ex4300-24p;
}
}

Command to remove the configuration:
From configuration mode:

#Delete interface vme unit 0 family inet dhcp
#commit

 

Kindly let me know if this answers your query.

 

Regards,

Ankur

Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!

Junos

Re: EX-3400 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg error logs

‎07-23-2019 08:08 AM
Junos

Re: EX-3400 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg error logs

‎07-23-2019 08:10 AM

Hi,

 

I know this KB. But  This configuration does not already existDelete interface vme unit 0 family inet dhcp" 

Junos

Re: EX-3400 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg error logs

‎07-23-2019 09:55 AM

Hi Emre,

 

Are you seeing any service-impact because of these logs ? Any drops observed ?

 

Also may I know which code do you have on your switch ?

 

Regards,

Ankur

Junos

Re: EX-3400 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg error logs

‎07-23-2019 10:00 AM

Hi Emre,

 

Also can you share/attach your switch configuration ?

 

or share the following show configuration | match dhcp | display set

 

Regards,

Ankur

Junos

Re: EX-3400 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg error logs

‎07-23-2019 11:56 PM

Yeah. Failed to get users IP address. the problem is resolved after restarting the device.

 

set version 15.1X53-D55.5
set system host-name XNAMEX
set system root-authentication encrypted-password XXXXX
set system login user admin uid 2000
set system login user admin class super-user
set system login user admin authentication encrypted-password XXXXXX
set system services ssh
set interfaces interface-range NAME member-range ge-0/0/0 to ge-0/0/47
set interfaces interface-range NAME member-range ge-1/0/0 to ge-1/0/23
set interfaces interface-range NAME unit 0 family ethernet-switching interface-mode access
set interfaces interface-range NAME unit 0 family ethernet-switching vlan members BDB
set interfaces ge-0/2/3 description NAMEX
set interfaces ge-0/2/3 unit 0 family ethernet-switching interface-mode trunk
set interfaces ge-0/2/3 unit 0 family ethernet-switching vlan members VLAN1
set interfaces ge-0/2/3 unit 0 family ethernet-switching vlan members VLAN2
set interfaces irb unit 2 family inet address 10.202.1.13/16
set routing-options static route 0.0.0.0/0 next-hop 10.202.1.10
set protocols lldp interface all
set protocols lldp-med interface all
set protocols igmp-snooping vlan all
set switch-options voip interface access-ports vlan irb.5
set vlans VLAN1 vlan-id 2
set vlans VLAN1 l3-interface irb.2
set vlans VLAN2 vlan-id 5

Junos

Re: EX-3400 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg error logs

‎07-23-2019 11:57 PM

configuration is below

 

set version 15.1X53-D55.5
set system host-name XNAMEX
set system root-authentication encrypted-password XXXXX
set system login user admin uid 2000
set system login user admin class super-user
set system login user admin authentication encrypted-password XXXXXX
set system services ssh
set interfaces interface-range NAME member-range ge-0/0/0 to ge-0/0/47
set interfaces interface-range NAME member-range ge-1/0/0 to ge-1/0/23
set interfaces interface-range NAME unit 0 family ethernet-switching interface-mode access
set interfaces interface-range NAME unit 0 family ethernet-switching vlan members BDB
set interfaces ge-0/2/3 description NAMEX
set interfaces ge-0/2/3 unit 0 family ethernet-switching interface-mode trunk
set interfaces ge-0/2/3 unit 0 family ethernet-switching vlan members VLAN1
set interfaces ge-0/2/3 unit 0 family ethernet-switching vlan members VLAN2
set interfaces irb unit 2 family inet address 10.202.1.13/16
set routing-options static route 0.0.0.0/0 next-hop 10.202.1.10
set protocols lldp interface all
set protocols lldp-med interface all
set protocols igmp-snooping vlan all
set switch-options voip interface access-ports vlan irb.5
set vlans VLAN1 vlan-id 2
set vlans VLAN1 l3-interface irb.2
set vlans VLAN2 vlan-id 5

Highlighted
Junos

Re: EX-3400 jdhcpd: DH_SVC_SENDMSG_FAILURE: sendmsg error logs

‎07-24-2019 09:54 AM
Hi Emre,

Good to know your problem got resolved after switch reboot. I think dhcp service restart on the switch could have also resolved this issue.

Regards,
Ankur
Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!