Junos
Highlighted
Junos

EX3200 J-Web Issue

‎04-24-2020 08:08 AM

I updated the firmware on an EX3200 switch to the J-TAC recommended firmware (14.1X53-D40) via Junos Space.  The firmware installed without issue, and I can access the switch via Junos Space and SSH.  However when I connected to J-Web, I received a message that I need to to updated J-Web to 14.1X53-A3.  This version is not listed as a download option on the J-Web download page, but version 14.1X53-A1.1 is listed.  After looking around on the internet, this version seemed like it would work so I installed in via Junos Space.

 

Now when I try to access J-Web, I get the following error message: Fatal error: Call-time pass-by-reference has been removed in /var/jweb-app/jweb-ex-app/core/html.php on line 211.  I've tried restarting web-management, but that did not help.

2 REPLIES 2
Highlighted
Junos

Re: EX3200 J-Web Issue

[ Edited ]
‎04-24-2020 11:49 AM

Hello Jconn

see below explanation for this Problem Report:

“Installed old application pages are not running properly with the new platform package where PHP latest version is available to parse server side scripts.

Remarks: Yes. It is not possible for us to run old version of php code using the latest version of php interpreter(upgraded) since there are code changes required to make old pages to be compatible with the new interpreter.


Though the installation of old application package was going through fine, the php files inside that are throwing fatal errors while running. Hence not got a success reply for the installation page and it keep on running in the UI.


This cannot be fixed and it is a known limitation“
The good thing is that there is a workaround for this:
Work-around :
Release 14.1X53-D46 is not affected by this issue.
As it is the way to recover this is by making a downgrade to D46.

 

If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated.

Highlighted
Junos

Re: EX3200 J-Web Issue

‎04-24-2020 11:58 AM

Hello,

 

This issue should be fixed in jweb application 14.1X53-A3, then you should have to create a ticket and request this specific package or if you require to restore the access to Jweb, you would have to re-install junos once again. 

 

#If this solution worked for you, please flag my post as an "Accepted Solution" so others can benefit. Kudos are appreciated as well.

Feedback