Junos
Junos

EX4300 upgrade

a week ago

Hi I did an upgrade on my EX 4300 Juniper from version 19.1R1 to version 19.4R1 and i noticed that the web interface doesn't work after searching around I found out that the httpd.conf file is missing (i used the find command, nothing) and the httpd service doesn't even start. Is there a way to regenerate this file? What can i do? If I revert the upgrade will that work? The switch is not configured at all I wanted to upgrade before configuration after the upgrade I set the management interface and web-management configurations when I noticed the problem.

3 REPLIES 3
Junos

Re: EX4300 upgrade

[ Edited ]
a week ago

Hi hajdusz,

 

is there any specific reason that you need 19.4R1 on your EX switch? Please note that latest and greatest JUNOS release are the most unstable release as well. The currently recommended release for EX4300 is Junos 18.1R3-S8/18.4R2-S2 (updated on Dec 10th). Please see the following link for the recommended releases:

 

https://kb.juniper.net/InfoCenter/index?page=content&id=KB21476

 

If you don't need any specific feature, and if stability is important for you, I'd suggest to downgrade to 18.1R3-S8 or 18.4R3 and then check again if your issue is solved or not.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution".
If you think that my answer was helpful, please spend some Kudos.
Junos

Re: EX4300 upgrade

a week ago

Thank you for the replay I did not know that the newest is not the most stable. I will try this .

Junos

Re: EX4300 upgrade

a week ago

You're welcome, please mark my post as "Accepted Solution" if the downgrade works for you.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution".
If you think that my answer was helpful, please spend some Kudos.